diff options
author | zxp19821005 | 2024-12-31 17:02:37 +0800 |
---|---|---|
committer | zxp19821005 | 2024-12-31 17:02:37 +0800 |
commit | 0f15a9c165448c6fb9272cadc50eb42a0a2270c4 (patch) | |
tree | 84a19ba585a5217d112b8c9db796bfd47c9e33fe | |
parent | a6e59a1cb6694b1352221cbaf37ab26c3ba740cd (diff) | |
download | aur-aniflix-bin.tar.gz |
update to fix errors
-rw-r--r-- | .SRCINFO | 6 | ||||
-rw-r--r-- | PKGBUILD | 21 | ||||
-rw-r--r-- | aniflix.sh | 2 |
3 files changed, 15 insertions, 14 deletions
@@ -1,7 +1,7 @@ pkgbase = aniflix-bin - pkgdesc = Anime Streaming Desktop App + pkgdesc = Anime Streaming Desktop App.(Prebuilt version.Use system-wide electron) pkgver = 0.0.1 - pkgrel = 11 + pkgrel = 12 url = https://aniflix.lamaau.space/ arch = x86_64 license = MIT @@ -13,6 +13,6 @@ pkgbase = aniflix-bin source = aniflix.sh sha256sums = db3c22d7f9d359852125fd5f3dc570fe540d3e10b2a172472cbf0c9df2b986da sha256sums = c3cc74287725f86a3a56a0e4d88895716ff81ff3c576ae69221feaa2539c0f86 - sha256sums = 2b2e8aeed33fd71c521e49fd54fb2fa81218d16aef8bccb88d77909055ab8051 + sha256sums = 291f50480f5a61bc9c68db7d44cd0412071128706baa868a9cb854f8779a1980 pkgname = aniflix-bin @@ -2,8 +2,8 @@ pkgname=aniflix-bin pkgver=0.0.1 _electronversion=23 -pkgrel=11 -pkgdesc="Anime Streaming Desktop App" +pkgrel=12 +pkgdesc="Anime Streaming Desktop App.(Prebuilt version.Use system-wide electron)" arch=('x86_64') url="https://aniflix.lamaau.space/" _ghurl="https://github.com/rizkhal/aniflix" @@ -20,14 +20,15 @@ source=( ) sha256sums=('db3c22d7f9d359852125fd5f3dc570fe540d3e10b2a172472cbf0c9df2b986da' 'c3cc74287725f86a3a56a0e4d88895716ff81ff3c576ae69221feaa2539c0f86' - '2b2e8aeed33fd71c521e49fd54fb2fa81218d16aef8bccb88d77909055ab8051') -build() { - sed -e "s|@electronversion@|${_electronversion}|g" \ - -e "s|@appname@|${pkgname%-bin}|g" \ - -e "s|@runname@|app.asar|g" \ - -e "s|@cfgdirname@|${pkgname%-bin}|g" \ - -e "s|@options@||g" \ - -i "${srcdir}/${pkgname%-bin}.sh" + '291f50480f5a61bc9c68db7d44cd0412071128706baa868a9cb854f8779a1980') +prepare() { + sed -e " + s/@electronversion@/${_electronversion}/g + s/@appname@/${pkgname%-bin}/g + s/@runname@/app.asar/g + s/@cfgdirname@/${pkgname%-bin}/g + s/@options@//g + " -i "${srcdir}/${pkgname%-bin}.sh" bsdtar -xf "${srcdir}/data."* sed -e "s|/opt/${pkgname%-bin}/${pkgname%-bin}|${pkgname%-bin}|g" \ -e "s|Categories=Video;|Categories=AudioVideo;|g" \ diff --git a/aniflix.sh b/aniflix.sh index 4cfe3ac09dd8..40e422ca2ee7 100644 --- a/aniflix.sh +++ b/aniflix.sh @@ -21,7 +21,7 @@ if [[ -f "${_FLAGS_FILE}" ]]; then fi done < "${_FLAGS_FILE}" fi -cd "${_APPDIR}" +cd "${_APPDIR}" || { echo "Failed to change directory to ${_APPDIR}"; exit 1; } if [[ "${EUID}" -ne 0 ]] || [[ "${ELECTRON_RUN_AS_NODE}" ]]; then exec electron@electronversion@ "${_RUNNAME}" ${_OPTIONS} "${_USER_FLAGS[@]}" "$@" else |