summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeth Barberee2016-08-12 17:31:38 -0500
committerSeth Barberee2016-08-12 17:31:38 -0500
commit1683539bc669c2232971be6959833644a392839f (patch)
tree6f6b86c9936b4bbb8a6c75a75b841437f866b63e
parent48be02e7bff4b2a7e5a4f78c47fa84e1ce4cf599 (diff)
downloadaur-1683539bc669c2232971be6959833644a392839f.tar.gz
updated dep according to source
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34c1aa06c9b2..16610f1b03a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = animewatch-pyqt4
pkgdesc = An Audio/Video Manager and Front End for mpv/mplayer with special emphasis on Anime Collection based on PyQt4
- pkgver = 2.4.2
+ pkgver = 2.5.0
pkgrel = 0
url = https://github.com/kanishka-linux/AnimeWatch
arch = any
@@ -12,6 +12,7 @@ pkgbase = animewatch-pyqt4
depends = curl
depends = libnotify
depends = python-dbus
+ depends = libtorrent-rasterbar
depends = python-beautifulsoup4
depends = python-psutil
depends = python-pillow
@@ -22,8 +23,8 @@ pkgbase = animewatch-pyqt4
depends = sqlite3
depends = python-pytaglib
conflicts = animewatch-pyqt5
- source = https://github.com/kanishka-linux/AnimeWatch/archive/v2.4.2-0.zip
- md5sums = 883b8d537d2918929bf85d03acf0db31
+ source = https://github.com/kanishka-linux/AnimeWatch/archive/v2.5.0-0.zip
+ md5sums = bf982456618eaf552768893de886042d
pkgname = animewatch-pyqt4
diff --git a/PKGBUILD b/PKGBUILD
index 9d446709a8f4..a85c25ed0095 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
pkgname=animewatch-pyqt4
_pkgname=AnimeWatch
-pkgver=2.4.2
+pkgver=2.5.0
pkgrel=0
pkgdesc="An Audio/Video Manager and Front End for mpv/mplayer with special emphasis on Anime Collection based on PyQt4"
arch=(any)
conflicts=('animewatch-pyqt5')
license=('GPL3')
url="https://github.com/kanishka-linux/AnimeWatch"
-depends=('python' 'python-pyqt4' 'python-pycurl' 'python-urllib3' 'curl' 'libnotify' 'python-dbus'
+depends=('python' 'python-pyqt4' 'python-pycurl' 'python-urllib3' 'curl' 'libnotify' 'python-dbus' 'libtorrent-rasterbar'
'python-beautifulsoup4' 'python-psutil' 'python-pillow' 'python-lxml' 'mpv' 'mplayer' 'ffmpegthumbnailer' 'sqlite3' 'python-pytaglib')
#source=("git+https://github.com/kanishka-linux/AnimeWatch.git")
source=("https://github.com/kanishka-linux/"${_pkgname}"/archive/v"${pkgver}-${pkgrel}".zip")
-md5sums=('883b8d537d2918929bf85d03acf0db31')
+md5sums=('bf982456618eaf552768893de886042d')
_gitname=AnimeWatch-PyQt4-Stable
@@ -27,7 +27,7 @@ package() {
install -d "${pkgdir}/usr/share/applications/"
install -d "${pkgdir}/usr/bin/"
- install -Dm755 "${_bpath}"/{animeWatch.py,musicArtist.py,adb.py,1.png,input.conf,default.jpg,default.html,introspect.xml,stream.png} "${pkgdir}/usr/share/${_pkgname}/"
+ install -Dm755 "${_bpath}"/{animeWatch.py,musicArtist.py,adb.py,1.png,input.conf,default.jpg,introspect.xml,stream.py,tray.png} "${pkgdir}/usr/share/${_pkgname}/"
cat "${_bpath}/AnimeWatch.desktop" | sed 's/Exec=/Exec=python -B \/usr\/share\/AnimeWatch\/animeWatch.py \%u/g' > "${pkgdir}/usr/share/applications/AnimeWatch.desktop"
echo '#!/bin/bash' > "${pkgdir}/usr/bin/anime-watch"
echo 'if [ -z "$1" ]; then python -B /usr/share/AnimeWatch/animeWatch.py; else python -B /usr/share/AnimeWatch/animeWatch.py "$(pwd)/$1"; fi' >> "${pkgdir}/usr/bin/anime-watch"