summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbemxio2023-09-29 18:26:11 +0200
committerbemxio2023-09-29 18:26:11 +0200
commit4ec42726e3c7e5a67cdedab7fbe5d7dc5d62adb5 (patch)
tree614cd6224ff5a77fe716d30290893e01c0163d86
parent993ef910edd68a95c07ef5bdeda2c32a537c259f (diff)
downloadaur-4ec42726e3c7e5a67cdedab7fbe5d7dc5d62adb5.tar.gz
eliminate the use of a temporary directory and include the license file
-rw-r--r--.SRCINFO8
-rw-r--r--LICENSE3
-rw-r--r--PKGBUILD49
3 files changed, 29 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d810d36e1da5..7f6335f67286 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = anituner
pkgdesc = Create, edit and convert Windows animated cursors
pkgver = 2.0.0
- pkgrel = 4
+ pkgrel = 5
url = https://www.gdgsoft.com/anituner
arch = i686
arch = x86_64
@@ -12,6 +12,12 @@ pkgbase = anituner
depends = wine
provides = anituner
source = https://download.gdgsoft.com/anitun2p.zip
+ source = anituner
+ source = anituner-atd.xml
+ source = LICENSE
md5sums = f0cff36790da5e3f9b02a65aa4d64101
+ md5sums = be9cfcd1a8c5f57cfae60e6739e0fceb
+ md5sums = 2c084aaadfb308a757c12ca19c012f9f
+ md5sums = 337e55594ad95557e6659ae8e0a91164
pkgname = anituner
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..5a9c4f885e4d
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,3 @@
+AniTuner is a full freeware: no advertisement, no restrictions, no nags.
+No registration is required.
+You can distribute, install and use it free of charge, even for commercial purposes. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 394ba4dec358..c32a53999dcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname="anituner"
pkgdesc="Create, edit and convert Windows animated cursors"
pkgver=2.0.0
-pkgrel=4
+pkgrel=5
arch=(i686 x86_64)
@@ -16,15 +16,12 @@ makedepends=(unzip gendesk icoutils)
provides=(anituner)
-source=("https://download.gdgsoft.com/anitun2p.zip")
-md5sums=("f0cff36790da5e3f9b02a65aa4d64101")
+source=("https://download.gdgsoft.com/anitun2p.zip" "anituner" "anituner-atd.xml" "LICENSE")
+md5sums=("f0cff36790da5e3f9b02a65aa4d64101" "be9cfcd1a8c5f57cfae60e6739e0fceb" "2c084aaadfb308a757c12ca19c012f9f" "337e55594ad95557e6659ae8e0a91164")
prepare() {
- # make a temporary directory and move into it
- mkdir -p "${startdir}/tmp" && cd "${startdir}/tmp"
-
# extract the icon out of the executable
- wrestool -x -n MAINICON "${srcdir}/AniTuner.exe" -o AniTuner.ico
+ wrestool -x -n MAINICON AniTuner.exe -o AniTuner.ico
# get the highest quality PNG from the icon file
icotool -x AniTuner.ico -i 6 --output AniTuner.png
@@ -40,36 +37,28 @@ prepare() {
}
package() {
- # rename the default configuration file
- mv "${srcdir}/AniTunerPref.xml" "${srcdir}/AniTunerPrefDefault.xml"
-
- # make the required directories
- mkdir -p "${pkgdir}/usr/share/anituner"
+ # make a directory for the AniTuner samples
mkdir -p "${pkgdir}/usr/share/anituner/Samples"
- mkdir -p "${pkgdir}/usr/bin"
-
- mkdir -p "${pkgdir}/usr/share/applications"
- mkdir -p "${pkgdir}/usr/share/pixmaps"
- mkdir -p "${pkgdir}/usr/share/mime/packages"
-
# copy all of AniTuner's files
- install -Dm755 "${srcdir}/AniTuner.exe" "${pkgdir}/usr/share/anituner"
- install -Dm644 "${srcdir}/AniTuner.chm" "${pkgdir}/usr/share/anituner"
- install -Dm644 "${srcdir}/AniTunerPrefDefault.xml" "${pkgdir}/usr/share/anituner"
- install -Dm644 "${srcdir}/Readme.txt" "${pkgdir}/usr/share/anituner"
- install -Dm644 "${srcdir}/Samples/"* "${pkgdir}/usr/share/anituner/Samples"
+ install -Dm755 AniTuner.exe "${pkgdir}/usr/share/anituner"
+ install -Dm644 AniTunerPref.xml "${pkgdir}/usr/share/anituner/AniTunerPrefDefault.xml"
- # remove the symlink to the ZIP from the package files
- rm -f "${pkgdir}/usr/share/anituner/anitun2p.zip"
+ install -Dm644 AniTuner.chm "${pkgdir}/usr/share/anituner/AniTuner.chm"
+ install -Dm644 Readme.txt "${pkgdir}/usr/share/anituner/Readme.txt"
+
+ install -Dm644 Samples/* "${pkgdir}/usr/share/anituner/Samples"
# copy the executable script
- install -v -Dm755 "${startdir}/anituner" "${pkgdir}/usr/bin"
+ install -Dm755 anituner "${pkgdir}/usr/bin/anituner"
# copy the extracted icon and the generated .desktop file
- install -Dm644 "${startdir}/tmp/AniTuner.png" "${pkgdir}/usr/share/pixmaps"
- install -Dm644 "${startdir}/tmp/AniTuner.desktop" "${pkgdir}/usr/share/applications"
+ install -Dm644 AniTuner.png "${pkgdir}/usr/share/pixmaps/AniTuner.png"
+ install -Dm644 AniTuner.desktop "${pkgdir}/usr/share/applications/AniTuner.desktop"
# copy the custom MIME type
- install -Dm644 "${startdir}/anituner-atd.xml" "${pkgdir}/usr/share/mime/packages"
-}
+ install -Dm644 anituner-atd.xml "${pkgdir}/usr/share/mime/packages/anituner-atd.xml"
+
+ # copy the license file
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+} \ No newline at end of file