summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbemxio2023-07-28 16:21:57 +0200
committerbemxio2023-07-28 16:21:57 +0200
commit8f1941fbd0c63e0d425b08913cd182fb15db85d2 (patch)
tree1c00a45e9cdd75f03b0c31d3ccd68e6ec7caee9d
parentad5f3d0ebb13f0a9a1458923d16a2bf31be4e261 (diff)
downloadaur-8f1941fbd0c63e0d425b08913cd182fb15db85d2.tar.gz
make the package version update automatically
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD26
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b6b003f852d..a9669d860443 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = anituner
pkgdesc = Create, edit and convert Windows animated cursors
- pkgver = 2.0.0
+ pkgver = 2.0.0.0
pkgrel = 1
url = https://www.gdgsoft.com/anituner
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 3428cbcfe353..e3c6d243e5fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,27 @@
# Maintainer: bemxio <bemxiov@protonmail.com>
-pkgname="anituner"
-pkgdesc="Create, edit and convert Windows animated cursors"
+pkgname='anituner'
+pkgdesc='Create, edit and convert Windows animated cursors'
-pkgver=2.0.0
+pkgver=2.0.0.0
pkgrel=1
arch=(i686 x86_64)
-url="https://www.gdgsoft.com/anituner"
-license=("freeware")
+url='https://www.gdgsoft.com/anituner'
+license=('freeware')
depends=(wine)
makedepends=(unzip gendesk icoutils)
provides=(anituner)
-source=("https://download.gdgsoft.com/anitun2p.zip")
-md5sums=("f0cff36790da5e3f9b02a65aa4d64101")
+source=('https://download.gdgsoft.com/anitun2p.zip')
+md5sums=('f0cff36790da5e3f9b02a65aa4d64101')
+
+pkgver() {
+ peres -v ${srcdir}/AniTuner.exe -f csv | tail -n 1 | awk -F',' '{print $NF}'
+}
prepare() {
# make a temporary directory for generated files
@@ -35,11 +39,11 @@ prepare() {
# generate a .desktop file
gendesk -f -n \
--pkgname AniTuner \
- --pkgdesc "$pkgdesc" \
+ --pkgdesc '$pkgdesc' \
--exec anituner \
--icon AniTuner.png \
- --categories "Graphics;Utility" \
- --mimetypes "image/bmp;image/jpeg;image/png;image/gif;image/vnd.adobe.photoshop;image/x-icon;image/x-win-bitmap;application/x-navi-animation;application/anituner-atd"
+ --categories 'Graphics;Utility' \
+ --mimetypes 'image/bmp;image/jpeg;image/png;image/gif;image/vnd.adobe.photoshop;image/x-icon;image/x-win-bitmap;application/x-navi-animation;application/anituner-atd'
}
package() {
@@ -69,4 +73,4 @@ package() {
# copy the custom MIME type
cp -r ${startdir}/anituner-atd.xml ${pkgdir}/usr/share/mime/packages
-} \ No newline at end of file
+}