summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbemxio2023-08-28 10:14:53 +0200
committerbemxio2023-08-28 10:14:53 +0200
commitc6e4090b33af850adca2557ec0bfd60c3152f0b2 (patch)
treecad6af134089658b68c82741a77d26422578165c
parent8e58b9ea234791f63c27008e4724710d790b1a78 (diff)
downloadaur-c6e4090b33af850adca2557ec0bfd60c3152f0b2.tar.gz
make slight changes to stuff
-rw-r--r--PKGBUILD8
-rwxr-xr-xanituner3
2 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f9eaeb56299d..88e0bd5430cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname='anituner'
pkgdesc='Create, edit and convert Windows animated cursors'
pkgver=2.0.0
-pkgrel=2
+pkgrel=3
arch=(i686 x86_64)
@@ -19,10 +19,6 @@ provides=(anituner)
source=('https://download.gdgsoft.com/anitun2p.zip')
md5sums=('f0cff36790da5e3f9b02a65aa4d64101')
-#pkgver() {
-# peres -v ${srcdir}/AniTuner.exe -f csv | tail -n 1 | awk -F',' '{print $NF}'
-#}
-
prepare() {
# make a temporary directory for generated files
mkdir -p ${startdir}/tmp
@@ -31,7 +27,7 @@ prepare() {
cd ${startdir}/tmp
# extract the icon out of the executable
- wrestool -x -t14 ${srcdir}/AniTuner.exe --output AniTuner.ico
+ wrestool -x -n MAINICON ${srcdir}/AniTuner.exe -o AniTuner.ico
# get the highest quality PNG from the icon file
icotool -x AniTuner.ico -i 6 --output AniTuner.png
diff --git a/anituner b/anituner
index 2383a57d4ccf..d6948429b795 100755
--- a/anituner
+++ b/anituner
@@ -3,6 +3,7 @@
export WINEARCH=win32 WINEPREFIX="$HOME/.anituner/wine"
if [ ! -d "$HOME/.anituner" ]; then
+ # create the directory for the wine prefix
mkdir -p "$HOME/.anituner/wine" || exit 1
# copy the default configuration file
@@ -12,4 +13,4 @@ if [ ! -d "$HOME/.anituner" ]; then
ln -s /usr/share/anituner/AniTuner.exe "$HOME/.anituner/anituner"
fi
-wine "$HOME/.anituner/anituner" "$@" \ No newline at end of file
+WINEDEBUG=-all wine "$HOME/.anituner/anituner" "$@" \ No newline at end of file