summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Ambauen2022-01-02 10:00:35 +0100
committerFabio Ambauen2022-01-02 10:00:35 +0100
commit6026e4b5cc41760f4ab3fe0fb4a9b87fca9e5086 (patch)
tree74f595b9b4ba6e4f6f9efcb44ea173ad746f967f
parentbd3af97eabd291bfb11b7ad54f7c9df569e49e06 (diff)
downloadaur-anonip.tar.gz
update to v1.1.0
-rw-r--r--.SRCINFO9
-rw-r--r--LICENSE27
-rw-r--r--PKGBUILD10
3 files changed, 7 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3184b4ae58ef..735558e6e6e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,12 @@
pkgbase = anonip
pkgdesc = Anonip is a tool to anonymize IP-addresses in log-files.
- pkgver = 1.0.0
+ pkgver = 1.1.0
pkgrel = 1
url = https://github.com/DigitaleGesellschaft/Anonip
arch = any
license = BSD
depends = python
- source = https://github.com/DigitaleGesellschaft/Anonip/archive/v1.0.0.tar.gz
- source = LICENSE
- sha256sums = ee34c76817d32aa97cf96451a9005948bddbdaaa0dc93b3583d1fa1ace61d454
- sha256sums = bfb9e7ead9baa5171df9f9fe24e93a917cd9903cc9e0bcc3cdf948f33bbb89ad
+ source = https://github.com/DigitaleGesellschaft/Anonip/archive/v1.1.0.tar.gz
+ sha256sums = 3511892021367165a13fffcb4483b4fc85a004d888708e2e365b514554779012
pkgname = anonip
-
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 433966189d49..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,27 +0,0 @@
-Copyright (c) 2013 - 2016, Swiss Privacy Foundation
- 2016 - 2019, Digitale Gesellschaft
-All rights reserved.
-
-Redistribution and use in source and binary forms, with or without
-modification, are permitted provided that the following conditions are met:
-
- * Redistributions of source code must retain the above copyright notice,
- this list of conditions and the following disclaimer.
- * Redistributions in binary form must reproduce the above copyright
- notice, this list of conditions and the following disclaimer in the
- documentation and/or other materials provided with the distribution.
- * Neither the name of Digitale Gesellschaft nor the names of its
- contributors may be used to endorse or promote products derived from
- this software without specific prior written permission.
-
-THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
-AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
-IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
-ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
-LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
-CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
-SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
-INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
-CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
-ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
-POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index 87e4c199a0b5..d2a7fd3736f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,19 @@
_pkgname=Anonip
pkgname=anonip
-pkgver=1.0.0
+pkgver=1.1.0
pkgrel=1
pkgdesc="Anonip is a tool to anonymize IP-addresses in log-files."
arch=('any')
url="https://github.com/DigitaleGesellschaft/Anonip"
license=('BSD')
depends=('python')
-source=("https://github.com/DigitaleGesellschaft/${_pkgname}/archive/v${pkgver}.tar.gz"
- "LICENSE")
-sha256sums=('ee34c76817d32aa97cf96451a9005948bddbdaaa0dc93b3583d1fa1ace61d454'
- 'bfb9e7ead9baa5171df9f9fe24e93a917cd9903cc9e0bcc3cdf948f33bbb89ad')
+source=("https://github.com/DigitaleGesellschaft/${_pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('3511892021367165a13fffcb4483b4fc85a004d888708e2e365b514554779012')
package() {
install -d $pkgdir/usr/share/licenses/$pkgname
- install -m644 -t $pkgdir/usr/share/licenses/$pkgname LICENSE
+ install -m644 -t $pkgdir/usr/share/licenses/$pkgname "${_pkgname}-${pkgver}/LICENSE.txt"
cd "${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1
}