summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBryn Edwards2017-09-25 10:40:17 +0100
committerBryn Edwards2017-09-25 10:40:17 +0100
commit9e43e40a15ddcf95eb4974c2bfe1801a87ff4d1c (patch)
tree52b9ccc73e2cb2ecfcad84177fbccabc6fd61d79
parent304c71b603f4c3b1bc518f41b5a40f4ffd14c6ff (diff)
downloadaur-9e43e40a15ddcf95eb4974c2bfe1801a87ff4d1c.tar.gz
Fix
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2361fe52dfb6..254fc0b51acb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=antibody
pkgver=3.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="A shell plugin manager."
arch=('i686' 'x86_64')
url="https://getantibody.github.io/"
@@ -26,12 +26,15 @@ prepare() {
}
build() {
- cd "$_repodir/$pkgname"
+ export GOPATH="$srcdir/.go"
+ cd "$srcdir/$_repodir/$pkgname"
make
}
check() {
- cd "$_repodir/$pkgname"
+ export GOPATH="$srcdir/.go"
+ export PATH="$GOPATH/bin:$PATH"
+ cd "$srcdir/$_repodir/$pkgname"
make test
}