summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrafcube2022-05-17 12:50:02 +0530
committerGrafcube2022-05-17 12:50:02 +0530
commitb90051e6fd88c8556463f7d0237261cc5d0a0e85 (patch)
tree0b2ea2bcada832d8db9db1b7c4eb526605533d7c
downloadaur-antidot-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD42
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2bfdab37455f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = antidot-git
+ pkgdesc = Cleans up your $HOME from those pesky dotfiles
+ pkgver = v0.6.2.r50.g3abc66f
+ pkgrel = 1
+ url = https://github.com/doron-cohen/antidot
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ depends = glibc
+ provides = antidot
+ conflicts = antidot
+ source = antidot-git::git+https://github.com/doron-cohen/antidot.git
+ sha256sums = SKIP
+
+pkgname = antidot-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2bb3032b76a9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!*.patch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9516d04f0d79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Grafcube <grafcube at disroot dot org>
+
+_pkgname=antidot
+pkgname=${_pkgname}-git
+pkgver=v0.6.2.r50.g3abc66f
+pkgrel=1
+pkgdesc='Cleans up your $HOME from those pesky dotfiles'
+arch=('x86_64')
+url="https://github.com/doron-cohen/${_pkgname}"
+license=('MIT')
+depends=('glibc')
+makedepends=('go')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("${pkgname}::git+https://github.com/doron-cohen/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git describe --long --tags --exclude latest | sed 's/^gittyup_v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${pkgname}"
+ mkdir -p build/
+}
+
+build() {
+ cd "${pkgname}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build
+}
+
+package() {
+ cd "${pkgname}"
+ install -Dm755 build/$_pkgname "$pkgdir"/usr/bin/$_pkgname
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$_pkgname/LICENSE
+}