summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGennadiy Chernyshyk2018-11-15 22:00:43 +0200
committerGennadiy Chernyshyk2018-11-15 22:00:43 +0200
commitf798365a904a66d3cb88f3935faefc0a57bb64cc (patch)
treeebd4b7db3dea79ca235ef6f9bc33d22922a632ac
parentf6aedc67b6373580af4177297958bf4ea0cedf3c (diff)
downloadaur-antu-icon-theme-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD40
-rw-r--r--update.sh6
3 files changed, 31 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4fe1a21bc552..f793dd2eeef7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
-# Generated by mksrcinfo v8
-# Thu Sep 8 19:04:20 UTC 2016
pkgbase = antu-icon-theme-git
- pkgdesc = An icon theme for Plasma Desktop
- pkgver = r103.edf89e7
- pkgrel = 2
- url = https://github.com/barcia/Antu
+ pkgdesc = A smooth theme designed for Plasma Desktop
+ pkgver = 0.8.r3.g4a801b4
+ pkgrel = 1
+ url = https://github.com/fabianalexisinostroza/Antu-icons
arch = any
- license = GPL3
+ license = Creative Commons
+ makedepends = git
+ provides = antu-icon-theme
+ conflicts = antu-icon-theme
options = !strip
- source = git+https://github.com/barcia/Antu.git
+ source = antu-icon-theme-git::git+https://github.com/fabianalexisinostroza/Antu-icons.git
sha256sums = SKIP
pkgname = antu-icon-theme-git
diff --git a/PKGBUILD b/PKGBUILD
index 8f07350c4c17..9d0ea3ca1e6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,32 @@
-# Maintainer: barcia <barcia@opmbx.org>
+# Maintainer: Shatur95 <genaloner@gmail.com>
-_gitname=Antu
-_pkgname=Antu
pkgname=('antu-icon-theme-git')
-pkgver=r103.edf89e7
-pkgrel=2
-pkgdesc="An icon theme for Plasma Desktop"
+pkgver=0.8.r3.g4a801b4
+pkgrel=1
+pkgdesc="A smooth theme designed for Plasma Desktop"
arch=('any')
-url="https://github.com/barcia/${_gitname}"
-license=('GPL3')
+url="https://github.com/fabianalexisinostroza/Antu-icons"
+license=('Creative Commons')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
options=('!strip')
-conflicts=('')
-source=("git+${url}.git")
+source=("${pkgname}::git+${url}.git")
sha256sums=('SKIP')
-pkgver(){
- cd ${_gitname}
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+pkgver() {
+ cd "$srcdir/${pkgname%}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$srcdir/${pkgname%}"
+ rm LICENSE.md
+ rm README.md
+}
+
+
package() {
- install -d ${pkgdir}/usr/share/icons
- cp -r ${srcdir}/${_gitname}/Icons/${_pkgname}* ${pkgdir}/usr/share/icons/
- find ${pkgdir}/usr -type f -exec chmod 644 {} \;
- find ${pkgdir}/usr -type d -exec chmod 755 {} \;
- find ${pkgdir}/usr -type f -name '.directory' -delete
+ install -dm 755 "$pkgdir"/usr/share/icons/Antu
+ cp -r ${srcdir}/${pkgname%}/* ${pkgdir}/usr/share/icons/Antu/
}
diff --git a/update.sh b/update.sh
deleted file mode 100644
index 0c5a7350ea6f..000000000000
--- a/update.sh
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/bash
-
-mksrcinfo &&
-git add PKGBUILD .SRCINFO update.sh &&
-git commit -m 'Update $(git rev-parse --short HEAD)' &&
-git push origin master