summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD3SOX2021-01-29 08:47:50 +0100
committerD3SOX2021-01-29 08:47:50 +0100
commit0ca7d9cf1ba124b597f51a1c04417a76da842c6a (patch)
tree8a3eedc4fc3361ba56bea092a43ff1aa5d958d7d
parentb4ecb4a87f07374c0d1c1f5c8e958432f6bda7fc (diff)
downloadaur-0ca7d9cf1ba124b597f51a1c04417a76da842c6a.tar.gz
update to 6.1.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1932b154b8ad..b2abe96d091c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = anydesk-bin
- pkgdesc = The Fast Remote Desktop Application (Generic based package)
- pkgver = 6.0.1
+ pkgdesc = The Fast Remote Desktop Application
+ pkgver = 6.1.0
pkgrel = 1
url = https://anydesk.com
arch = i686
@@ -36,8 +36,7 @@ pkgbase = anydesk-bin
options = !strip
source_i686 = https://download.anydesk.com/linux/anydesk-6.0.1-i386.tar.gz
sha256sums_i686 = cb22b026e2d81c0de220238fa3d4e13a6d0016787b8c680923794296bbd548e2
- source_x86_64 = https://download.anydesk.com/linux/anydesk-6.0.1-amd64.tar.gz
- sha256sums_x86_64 = b7826dcd379c27f615424d36d9383b8033c0b8c221751cad4ae7d9809f0fe5a4
+ source_x86_64 = https://download.anydesk.com/linux/anydesk-6.1.0-amd64.tar.gz
+ sha256sums_x86_64 = 797808eb2cf39a5cb91a268a2597188e2f5232e2f47914f5bd4a5ae5413678e1
pkgname = anydesk-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index 7322cadfb7c2..40d4ea887902 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Nico <d3sox at protonmail dot com>
pkgname=anydesk-bin
-pkgver=6.0.1
+pkgver=6.1.0
pkgrel=1
-pkgdesc="The Fast Remote Desktop Application (Generic based package)"
+pkgdesc="The Fast Remote Desktop Application"
arch=('i686' 'x86_64')
url="https://anydesk.com"
license=('custom')
@@ -14,14 +14,16 @@ provides=('anydesk')
replaces=('anydesk-debian')
options=('!strip')
-source_i686=("https://download.anydesk.com/linux/anydesk-${pkgver}-i386.tar.gz")
+# 32bit was not yet updated to 6.1.0
+_pkgver_i686="6.0.1"
+
+source_i686=("https://download.anydesk.com/linux/anydesk-${_pkgver_i686}-i386.tar.gz")
source_x86_64=("https://download.anydesk.com/linux/anydesk-${pkgver}-amd64.tar.gz")
sha256sums_i686=('cb22b026e2d81c0de220238fa3d4e13a6d0016787b8c680923794296bbd548e2')
-sha256sums_x86_64=('b7826dcd379c27f615424d36d9383b8033c0b8c221751cad4ae7d9809f0fe5a4')
+sha256sums_x86_64=('797808eb2cf39a5cb91a268a2597188e2f5232e2f47914f5bd4a5ae5413678e1')
package() {
- # install start script which sets the env variable for theme?
# install binary
install -Dm 755 "${srcdir}/anydesk-${pkgver}/anydesk" "${pkgdir}/usr/bin/anydesk"
# patch the binary to replace obsolete dependency
@@ -29,7 +31,7 @@ package() {
# install desktop entry
install -Dm 644 "${srcdir}/anydesk-${pkgver}/anydesk.desktop" "${pkgdir}/usr/share/applications/anydesk.desktop"
- # force gtk2 theme to adwaita in desktop entry to fix unreadable text
+ # force gtk2 theme to adwaita in desktop entry to fix unreadable text when using a dark gtk theme
sed -i -e "s:Exec=/usr/bin/anydesk:Exec=env GTK2_RC_FILES=/usr/share/themes/Adwaita/gtk-2.0/gtkrc /usr/bin/anydesk:g" "${pkgdir}/usr/share/applications/anydesk.desktop"
# install polkit action