summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD3SOX2020-05-06 22:08:16 +0200
committerD3SOX2020-05-06 22:08:16 +0200
commitd42922969f03526e5bcc095803d5df73c8f245bc (patch)
tree8bd31821f887fa2681f09d204dd86885d64beef9
parentffe85042783ebf345f968a73d72cee7b10817014 (diff)
downloadaur-d42922969f03526e5bcc095803d5df73c8f245bc.tar.gz
Removed pangox-compat dependency and patch the binary instead (Thanks to severach)
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94c2e6931d07..e4079d9e013a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = anydesk-bin
pkgdesc = 'AnyDesk Free' is an All-In-One Software for Remote Support (Generic based package)
pkgver = 5.5.5
- pkgrel = 5
+ pkgrel = 6
url = https://anydesk.com
arch = i686
arch = x86_64
license = custom
+ makedepends = patchelf
depends = fakeroot
depends = python-shiboken2
depends = gtkglext
@@ -26,13 +27,13 @@ pkgbase = anydesk-bin
depends = libxfixes
depends = libxdamage
depends = gcc-libs
- depends = pangox-compat
optdepends = libpulse: audio support
provides = anydesk
conflicts = anydesk
conflicts = anydesk-test
conflicts = anydesk-debian
conflicts = pango-anydesk
+ options = !strip
source_i686 = https://download.anydesk.com/linux/anydesk-5.5.5-i386.tar.gz
sha256sums_i686 = ead02c9778711a6f028fb0f26f9ef9a48b76ef8f374124b45827e451a55f082a
source_x86_64 = https://download.anydesk.com/linux/anydesk-5.5.5-amd64.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 3f8eb15aafc6..b3d8407e6d65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,17 @@
# Maintainer: Nico <desoxhd@gmail.com>
pkgname=anydesk-bin
pkgver=5.5.5
-pkgrel=5
+pkgrel=6
pkgdesc="'AnyDesk Free' is an All-In-One Software for Remote Support (Generic based package)"
arch=('i686' 'x86_64')
url="https://anydesk.com"
license=('custom')
-depends=('fakeroot' 'python-shiboken2' 'gtkglext' 'libglvnd' 'gtk2' 'libx11' 'glibc' 'glib2' 'gdk-pixbuf2' 'libxcb' 'cairo' 'pango' 'libxi' 'libxrender' 'libxrandr' 'libxtst' 'libxext' 'libxfixes' 'libxdamage' 'gcc-libs' 'pangox-compat')
+depends=('fakeroot' 'python-shiboken2' 'gtkglext' 'libglvnd' 'gtk2' 'libx11' 'glibc' 'glib2' 'gdk-pixbuf2' 'libxcb' 'cairo' 'pango' 'libxi' 'libxrender' 'libxrandr' 'libxtst' 'libxext' 'libxfixes' 'libxdamage' 'gcc-libs')
optdepends=('libpulse: audio support')
+makedepends=('patchelf')
conflicts=('anydesk' 'anydesk-test' 'anydesk-debian' 'pango-anydesk')
provides=('anydesk')
+options=('!strip')
source_i686=("https://download.anydesk.com/linux/anydesk-${pkgver}-i386.tar.gz")
source_x86_64=("https://download.anydesk.com/linux/anydesk-${pkgver}-amd64.tar.gz")
@@ -20,6 +22,9 @@ sha256sums_x86_64=('606950997cfa607eff0f68018b8e6962f2491037a7c590d6e150befcaabe
package() {
# install binary
install -Dm 755 "${srcdir}/anydesk-${pkgver}/anydesk" "${pkgdir}/usr/bin/anydesk"
+ # patch the binary to replace obsolete dependency
+ patchelf --replace-needed 'libpangox-1.0.so.0' 'libpangoxft-1.0.so' "${pkgdir}/usr/bin/anydesk"
+
# install desktop entry
install -Dm 644 "${srcdir}/anydesk-${pkgver}/anydesk.desktop" "${pkgdir}/usr/share/applications/anydesk.desktop"
# install polkit action