summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD3SOX2020-05-05 20:19:16 +0200
committerD3SOX2020-05-05 20:19:16 +0200
commitdb070d54afe873e82c7dd993e362dec43e3b8270 (patch)
tree2fb3c653cd939272c4745e25c624a40f7efe5fef
parentf8e43790fc641c1e96ef784c7e7edf4e547036b4 (diff)
downloadaur-db070d54afe873e82c7dd993e362dec43e3b8270.tar.gz
Removed pangox workaround (Thanks to severach for maintaining pangox-compat)
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 4 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0de1fce943d..526006baf1be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -26,6 +26,7 @@ pkgbase = anydesk-bin
depends = libxfixes
depends = libxdamage
depends = gcc-libs
+ depends = pangox-compat
optdepends = libpulse: audio support
provides = anydesk
provides = libpangox-1.0.so.0
@@ -33,7 +34,6 @@ pkgbase = anydesk-bin
conflicts = anydesk-test
conflicts = anydesk-debian
conflicts = pango-anydesk
- conflicts = pangox-compat
source_i686 = https://download.anydesk.com/linux/anydesk-5.5.5-i386.tar.gz
sha256sums_i686 = ead02c9778711a6f028fb0f26f9ef9a48b76ef8f374124b45827e451a55f082a
source_x86_64 = https://download.anydesk.com/linux/anydesk-5.5.5-amd64.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index bd83c65f9835..d5196db1772c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Nico <desoxhd@gmail.com>
pkgname=anydesk-bin
pkgver=5.5.5
-pkgrel=4
+pkgrel=5
pkgdesc="'AnyDesk Free' is an All-In-One Software for Remote Support (Generic based package)"
arch=('i686' 'x86_64')
url="https://anydesk.com"
license=('custom')
-depends=('fakeroot' 'python-shiboken2' 'gtkglext' 'libglvnd' 'gtk2' 'libx11' 'glibc' 'glib2' 'gdk-pixbuf2' 'libxcb' 'cairo' 'pango' 'libxi' 'libxrender' 'libxrandr' 'libxtst' 'libxext' 'libxfixes' 'libxdamage' 'gcc-libs')
+depends=('fakeroot' 'python-shiboken2' 'gtkglext' 'libglvnd' 'gtk2' 'libx11' 'glibc' 'glib2' 'gdk-pixbuf2' 'libxcb' 'cairo' 'pango' 'libxi' 'libxrender' 'libxrandr' 'libxtst' 'libxext' 'libxfixes' 'libxdamage' 'gcc-libs' 'pangox-compat')
optdepends=('libpulse: audio support')
-conflicts=('anydesk' 'anydesk-test' 'anydesk-debian' 'pango-anydesk' 'pangox-compat')
+conflicts=('anydesk' 'anydesk-test' 'anydesk-debian' 'pango-anydesk')
provides=('anydesk' 'libpangox-1.0.so.0')
source_i686=("https://download.anydesk.com/linux/anydesk-${pkgver}-i386.tar.gz")
@@ -18,10 +18,6 @@ sha256sums_i686=('ead02c9778711a6f028fb0f26f9ef9a48b76ef8f374124b45827e451a55f08
sha256sums_x86_64=('606950997cfa607eff0f68018b8e6962f2491037a7c590d6e150befcaabe5225')
package() {
- # workaround because pangox-compat package has been removed
- mkdir -p "${pkgdir}/usr/lib/"
- ln -sf "/usr/lib/libpangoxft-1.0.so" "${pkgdir}/usr/lib/libpangox-1.0.so.0"
-
# install binary
install -Dm 755 "${srcdir}/anydesk-${pkgver}/anydesk" "${pkgdir}/usr/bin/anydesk"
# install desktop entry