summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD3SOX2020-04-17 22:54:45 +0200
committerD3SOX2020-04-17 22:54:45 +0200
commitf03a2b595a226d1246dbe66d736815a38c06d35f (patch)
tree341a572559d450f63c861d5bb4038fb613f8e76e
parent4e3a8af1a24f69efcec138eaf1beb0ae73ab79a3 (diff)
downloadaur-f03a2b595a226d1246dbe66d736815a38c06d35f.tar.gz
add anydesk to provides
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80672ca37e24..0fa4b88a0bc6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = anydesk-bin
pkgdesc = 'AnyDesk Free' is an All-In-One Software for Remote Support (Generic based package)
pkgver = 5.5.4
- pkgrel = 3
+ pkgrel = 4
url = https://anydesk.com
arch = i686
arch = x86_64
@@ -26,6 +26,7 @@ pkgbase = anydesk-bin
depends = libxdamage
depends = gcc-libs
optdepends = libpulse
+ provides = anydesk
conflicts = anydesk
conflicts = anydesk-test
conflicts = anydesk-debian
diff --git a/PKGBUILD b/PKGBUILD
index 57a397381785..99c9ee6ac550 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Nico <desoxhd@gmail.com>
pkgname=anydesk-bin
pkgver=5.5.4
-pkgrel=3
+pkgrel=4
pkgdesc="'AnyDesk Free' is an All-In-One Software for Remote Support (Generic based package)"
arch=('i686' 'x86_64')
url="https://anydesk.com"
@@ -9,6 +9,7 @@ license=('custom')
depends=('fakeroot' 'python-shiboken2' 'gtkglext' 'libglvnd' 'gtk2' 'libx11' 'glibc' 'glib2' 'gdk-pixbuf2' 'libxcb' 'cairo' 'pango' 'libxi' 'libxrandr' 'libxtst' 'libxext' 'libxfixes' 'libxdamage' 'gcc-libs')
optdepends=('libpulse')
conflicts=('anydesk' 'anydesk-test' 'anydesk-debian')
+provides=('anydesk')
source_i686=(https://download.anydesk.com/linux/anydesk-${pkgver}-i386.tar.gz)
source_x86_64=(https://download.anydesk.com/linux/anydesk-${pkgver}-amd64.tar.gz)
@@ -17,10 +18,15 @@ sha256sums_i686=('79be3846fc51088bc5461752a6f66dae4bb5b9772c84fdd2cb8ece1b8965ba
sha256sums_x86_64=('7a96be4d607b4115999610d324913d57bd7c2fad7137d465276ac157f80fc2e7')
package() {
+ # install binary
install -Dm 755 "${srcdir}/anydesk-${pkgver}/anydesk" "${pkgdir}/usr/bin/anydesk"
+ # install desktop entry
install -Dm 644 "${srcdir}/anydesk-${pkgver}/anydesk.desktop" "${pkgdir}/usr/share/applications/anydesk.desktop"
+ # install icon
install -Dm 644 "${srcdir}/anydesk-${pkgver}/icons/hicolor/scalable/apps/anydesk.svg" "${pkgdir}/usr/share/pixmaps/anydesk.svg"
+ # install license
install -Dm 644 "${srcdir}/anydesk-${pkgver}/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
msg2 "\e[1;32mAnyDesk has a systemd service for unattended access. Enable it with: systemctl enable --now anydesk \e[0m"
+ # install systemd service
install -Dm 644 "${srcdir}/anydesk-${pkgver}/systemd/anydesk.service" "${pkgdir}/usr/lib/systemd/system/anydesk.service"
}