summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD3SOX2020-05-03 18:52:06 +0200
committerD3SOX2020-05-03 18:52:06 +0200
commitf8e43790fc641c1e96ef784c7e7edf4e547036b4 (patch)
tree16aa33aab48df29c20854e6c20a53966e632a4a2
parent8648470b1ea3d4bd29ad9fa68139bfd1353604b8 (diff)
downloadaur-f8e43790fc641c1e96ef784c7e7edf4e547036b4.tar.gz
Added symlink for libpangoxft-1.0.so
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e49a2cbba04..a0de1fce943d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = anydesk-bin
pkgdesc = 'AnyDesk Free' is an All-In-One Software for Remote Support (Generic based package)
pkgver = 5.5.5
- pkgrel = 3
+ pkgrel = 4
url = https://anydesk.com
arch = i686
arch = x86_64
@@ -28,10 +28,12 @@ pkgbase = anydesk-bin
depends = gcc-libs
optdepends = libpulse: audio support
provides = anydesk
+ provides = libpangox-1.0.so.0
conflicts = anydesk
conflicts = anydesk-test
conflicts = anydesk-debian
conflicts = pango-anydesk
+ conflicts = pangox-compat
source_i686 = https://download.anydesk.com/linux/anydesk-5.5.5-i386.tar.gz
sha256sums_i686 = ead02c9778711a6f028fb0f26f9ef9a48b76ef8f374124b45827e451a55f082a
source_x86_64 = https://download.anydesk.com/linux/anydesk-5.5.5-amd64.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index a726028112a6..bd83c65f9835 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Nico <desoxhd@gmail.com>
pkgname=anydesk-bin
pkgver=5.5.5
-pkgrel=3
+pkgrel=4
pkgdesc="'AnyDesk Free' is an All-In-One Software for Remote Support (Generic based package)"
arch=('i686' 'x86_64')
url="https://anydesk.com"
license=('custom')
depends=('fakeroot' 'python-shiboken2' 'gtkglext' 'libglvnd' 'gtk2' 'libx11' 'glibc' 'glib2' 'gdk-pixbuf2' 'libxcb' 'cairo' 'pango' 'libxi' 'libxrender' 'libxrandr' 'libxtst' 'libxext' 'libxfixes' 'libxdamage' 'gcc-libs')
optdepends=('libpulse: audio support')
-conflicts=('anydesk' 'anydesk-test' 'anydesk-debian' 'pango-anydesk')
-provides=('anydesk')
+conflicts=('anydesk' 'anydesk-test' 'anydesk-debian' 'pango-anydesk' 'pangox-compat')
+provides=('anydesk' 'libpangox-1.0.so.0')
source_i686=("https://download.anydesk.com/linux/anydesk-${pkgver}-i386.tar.gz")
source_x86_64=("https://download.anydesk.com/linux/anydesk-${pkgver}-amd64.tar.gz")
@@ -18,6 +18,10 @@ sha256sums_i686=('ead02c9778711a6f028fb0f26f9ef9a48b76ef8f374124b45827e451a55f08
sha256sums_x86_64=('606950997cfa607eff0f68018b8e6962f2491037a7c590d6e150befcaabe5225')
package() {
+ # workaround because pangox-compat package has been removed
+ mkdir -p "${pkgdir}/usr/lib/"
+ ln -sf "/usr/lib/libpangoxft-1.0.so" "${pkgdir}/usr/lib/libpangox-1.0.so.0"
+
# install binary
install -Dm 755 "${srcdir}/anydesk-${pkgver}/anydesk" "${pkgdir}/usr/bin/anydesk"
# install desktop entry