summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirottu2024-04-03 15:46:08 +0300
committerKirottu2024-04-03 15:46:08 +0300
commitb6b8819372e067b104796d53847b9438b47a9bb2 (patch)
tree0e10031c8adc5829c40a2e8e7a5533b1f904e110
downloadaur-anyrun-plugin-dictionary-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD39
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1332fda47813
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = anyrun-plugin-dictionary-git
+ pkgdesc = Dictionary plugin for looking up word definitions.
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/anyrun-org/plugin-dictionary
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cargo
+ depends = anyrun
+ source = anyrun-plugin-dictionary::git+https://github.com/anyrun-org/plugin-dictionary.git
+ sha256sums = SKIP
+
+pkgname = anyrun-plugin-dictionary-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1eddd3f68f35
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: KirottuM <arnovaara@gmail.com>
+_pkgname="anyrun-plugin-dictionary"
+pkgname="${_pkgname}-git"
+pkgrel=1
+pkgver=1
+pkgdesc="Dictionary plugin for looking up word definitions."
+arch=("x86_64")
+url="https://github.com/anyrun-org/plugin-dictionary"
+license=('GPL3')
+depends=(anyrun)
+makedepends=(git cargo)
+source=("${_pkgname}::git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release
+}
+
+package() {
+ cd "${_pkgname}"
+ export RUSTUP_TOOLCHAIN=stable
+ install -Dm0644 -t "$pkgdir/etc/anyrun/plugins/" "target/release/libdictionary.so"
+}