summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirottu2024-04-03 15:47:07 +0300
committerKirottu2024-04-03 15:47:07 +0300
commit15b8ce0512f147c89a863c240e20082bcc2027aa (patch)
tree3d0898ac54cd2a3f9bdfebe22aedbbcb992c7606
downloadaur-anyrun-plugin-kidex.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
-rw-r--r--v0.1.0.tar.gzbin0 -> 20718 bytes
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..47162c275fb6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = anyrun-plugin-kidex
+ pkgdesc = Kidex plugin for file search.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/anyrun-org/plugin-kidex
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cargo
+ depends = anyrun
+ source = https://github.com/anyrun-org/plugin-kidex/archive/refs/tags/v0.1.0.tar.gz
+ sha256sums = 61fa4fc368fdb94db0552b069881b1f93f4fc2b34abdbdb6aa28a97d8b348a6b
+
+pkgname = anyrun-plugin-kidex
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a9785d62797
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: KirottuM <arnovaara@gmail.com>
+pkgname="anyrun-plugin-kidex"
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Kidex plugin for file search."
+arch=("x86_64")
+url="https://github.com/anyrun-org/plugin-kidex"
+license=('GPL3')
+depends=(anyrun)
+makedepends=(git cargo)
+source=("https://github.com/anyrun-org/plugin-kidex/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('61fa4fc368fdb94db0552b069881b1f93f4fc2b34abdbdb6aa28a97d8b348a6b')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ export RUSTUP_TOOLCHAIN=stable
+ install -Dm0644 -t "$pkgdir/etc/anyrun/plugins/" "target/release/libkidex.so"
+}
diff --git a/v0.1.0.tar.gz b/v0.1.0.tar.gz
new file mode 100644
index 000000000000..4ea9323f881a
--- /dev/null
+++ b/v0.1.0.tar.gz
Binary files differ