summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirottu2024-04-03 15:47:13 +0300
committerKirottu2024-04-03 15:47:13 +0300
commitcf779e69a00631d3990e2ce5e6e88643700c93f1 (patch)
tree526a35a6ff36b9b9fde33093a4e3f2d5c007c965
downloadaur-anyrun-plugin-rink.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
-rw-r--r--v0.1.0.tar.gzbin0 -> 25438 bytes
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..737c8717ff31
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = anyrun-plugin-rink
+ pkgdesc = Rink plugin for calculator and unit conversion.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/anyrun-org/plugin-rink
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cargo
+ depends = anyrun
+ source = https://github.com/anyrun-org/plugin-rink/archive/refs/tags/v0.1.0.tar.gz
+ sha256sums = 6a020090efe88e484a1a625b11185b52bad2b866487e38b77388971db2cd99e3
+
+pkgname = anyrun-plugin-rink
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa257c41caa3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: KirottuM <arnovaara@gmail.com>
+pkgname="anyrun-plugin-rink"
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Rink plugin for calculator and unit conversion."
+arch=("x86_64")
+url="https://github.com/anyrun-org/plugin-rink"
+license=('GPL3')
+depends=(anyrun)
+makedepends=(git cargo)
+source=("https://github.com/anyrun-org/plugin-rink/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('6a020090efe88e484a1a625b11185b52bad2b866487e38b77388971db2cd99e3')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ export RUSTUP_TOOLCHAIN=stable
+ install -Dm0644 -t "$pkgdir/etc/anyrun/plugins/" "target/release/librink.so"
+}
diff --git a/v0.1.0.tar.gz b/v0.1.0.tar.gz
new file mode 100644
index 000000000000..f8b8d5673901
--- /dev/null
+++ b/v0.1.0.tar.gz
Binary files differ