summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirottu2024-04-03 15:46:26 +0300
committerKirottu2024-04-03 15:46:26 +0300
commitd7f5628a26ff5c59152431767586ea1468ba6626 (patch)
tree4cb533f91ae0c3d45b050b165b620511a3cf8aa4
downloadaur-anyrun-plugin-shell-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD39
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad30a2dd5f99
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = anyrun-plugin-shell-git
+ pkgdesc = Shell plugin for running shell commands.
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/anyrun-org/plugin-shell
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cargo
+ depends = anyrun
+ source = anyrun-plugin-shell::git+https://github.com/anyrun-org/plugin-shell.git
+ sha256sums = SKIP
+
+pkgname = anyrun-plugin-shell-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c55e76e9f4b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: KirottuM <arnovaara@gmail.com>
+_pkgname="anyrun-plugin-shell"
+pkgname="${_pkgname}-git"
+pkgrel=1
+pkgver=1
+pkgdesc="Shell plugin for running shell commands."
+arch=("x86_64")
+url="https://github.com/anyrun-org/plugin-shell"
+license=('GPL3')
+depends=(anyrun)
+makedepends=(git cargo)
+source=("${_pkgname}::git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release
+}
+
+package() {
+ cd "${_pkgname}"
+ export RUSTUP_TOOLCHAIN=stable
+ install -Dm0644 -t "$pkgdir/etc/anyrun/plugins/" "target/release/libshell.so"
+}