summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirottu2024-04-03 15:47:24 +0300
committerKirottu2024-04-03 15:47:24 +0300
commitafaad848ae925d1cb26f83818334f4e3b3052c62 (patch)
tree3d0dd25a1dfa752ab3d2ac7f00ae9b4ee6f336f5
downloadaur-anyrun-plugin-stdin.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
-rw-r--r--v0.1.0.tar.gzbin0 -> 19471 bytes
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5e8cee93770
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = anyrun-plugin-stdin
+ pkgdesc = Stdin plugin for dmenu-like operation.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/anyrun-org/plugin-stdin
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cargo
+ depends = anyrun
+ source = https://github.com/anyrun-org/plugin-stdin/archive/refs/tags/v0.1.0.tar.gz
+ sha256sums = 0f04326ac4b946a5b888ef4bfb38427dcadb4618e6f7b35c8690f11f60da7cba
+
+pkgname = anyrun-plugin-stdin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f961c21feaff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: KirottuM <arnovaara@gmail.com>
+pkgname="anyrun-plugin-stdin"
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Stdin plugin for dmenu-like operation."
+arch=("x86_64")
+url="https://github.com/anyrun-org/plugin-stdin"
+license=('GPL3')
+depends=(anyrun)
+makedepends=(git cargo)
+source=("https://github.com/anyrun-org/plugin-stdin/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('0f04326ac4b946a5b888ef4bfb38427dcadb4618e6f7b35c8690f11f60da7cba')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ export RUSTUP_TOOLCHAIN=stable
+ install -Dm0644 -t "$pkgdir/etc/anyrun/plugins/" "target/release/libstdin.so"
+}
diff --git a/v0.1.0.tar.gz b/v0.1.0.tar.gz
new file mode 100644
index 000000000000..5d0719e94e6b
--- /dev/null
+++ b/v0.1.0.tar.gz
Binary files differ