summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-08-04 15:55:21 +0000
committerDaniel Bermond2018-08-04 15:55:21 +0000
commit2427744a92355edfaf94c1baf3d3ac3e0303af6f (patch)
treecc375c2209ecf3afaa7b34baf1aad4434090847e
parentac66e3015865d6c56e73a54309812deecfb45aa8 (diff)
downloadaur-2427744a92355edfaf94c1baf3d3ac3e0303af6f.tar.gz
Cosmetic changes
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD56
-rw-r--r--apache-flex-sdk.install3
-rw-r--r--apache-flex-sdk.sh2
4 files changed, 37 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62f3c0f73435..e17ee577133a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,23 @@
pkgbase = apache-flex-sdk
pkgdesc = The open-source framework for building expressive web and mobile applications
pkgver = 4.16.1
- pkgrel = 2
+ pkgrel = 3
url = https://flex.apache.org/
install = apache-flex-sdk.install
arch = any
- license = Apache
+ license = APACHE
depends = bash
depends = java-runtime
optdepends = adobe-air-sdk: for compiling flex projects into AIR apps
- noextract = playerglobal11_1.swc
+ noextract = playerglobal30_0.swc
options = !strip
+ options = !emptydirs
source = https://www.apache.org/dist/flex/4.16.1/binaries/apache-flex-sdk-4.16.1-bin.tar.gz
source = https://fpdownload.macromedia.com/get/flashplayer/installers/archive/playerglobal/playerglobal30_0.swc
source = apache-flex-sdk.sh
sha256sums = 17fda7ac8d3e476cad3127f345455ef316acfb87c6f4322e5897bd8d9b09388e
sha256sums = f906e5c9cbb958ec3da5c7eff054627b20eff4ac28a09bee48f6a02618fa3aad
- sha256sums = 520ae01482825ef28da42c03b3cbadd3d62155ed074d737f3672980f0a97a3fd
+ sha256sums = 950fcb6fbdb1349018fd47277eaaacf0821ee44951e8b64cd1676839f0d39814
pkgname = apache-flex-sdk
diff --git a/PKGBUILD b/PKGBUILD
index 9972a8466554..b3123055df9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,42 +3,44 @@
# Contributor: Michał Górny <zrchos+arch@gmail.com>
# Contributor: Ryan Lee <ryan@swyro.com>
+_player_ver=30.0
+
pkgname=apache-flex-sdk
pkgver=4.16.1
-_player_ver=30.0
-pkgrel=2
-pkgdesc="The open-source framework for building expressive web and mobile applications"
+pkgrel=3
+pkgdesc='The open-source framework for building expressive web and mobile applications'
arch=('any')
-license=('Apache')
url='https://flex.apache.org/'
+license=('APACHE')
depends=('bash' 'java-runtime')
-optdepends=(
- 'adobe-air-sdk: for compiling flex projects into AIR apps'
-)
-source=(
- "https://www.apache.org/dist/flex/$pkgver/binaries/apache-flex-sdk-$pkgver-bin.tar.gz"
- "https://fpdownload.macromedia.com/get/flashplayer/installers/archive/playerglobal/playerglobal${_player_ver/./_}.swc"
- "apache-flex-sdk.sh"
-)
+optdepends=('adobe-air-sdk: for compiling flex projects into AIR apps')
+options=('!strip' '!emptydirs')
+install="${pkgname}.install"
+source=("https://www.apache.org/dist/flex/${pkgver}/binaries/apache-flex-sdk-${pkgver}-bin.tar.gz"
+ "https://fpdownload.macromedia.com/get/flashplayer/installers/archive/playerglobal/playerglobal${_player_ver/./_}.swc"
+ 'apache-flex-sdk.sh')
+noextract=("playerglobal${_player_ver/./_}.swc")
sha256sums=('17fda7ac8d3e476cad3127f345455ef316acfb87c6f4322e5897bd8d9b09388e'
'f906e5c9cbb958ec3da5c7eff054627b20eff4ac28a09bee48f6a02618fa3aad'
- '520ae01482825ef28da42c03b3cbadd3d62155ed074d737f3672980f0a97a3fd')
-install=apache-flex-sdk.install
-options=('!strip')
-noextract=('playerglobal11_1.swc')
-
-_binary_name="${pkgname}-${pkgver}-bin.tar.gz"
+ '950fcb6fbdb1349018fd47277eaaacf0821ee44951e8b64cd1676839f0d39814')
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}-bin/"
- mkdir -p player/${_player_ver}/
- cp ../playerglobal${_player_ver/./_}.swc player/${_player_ver}/playerglobal.swc
+prepare() {
+ cd "${pkgname}-${pkgver}-bin"
+
+ mkdir -p "player/${_player_ver}"
+
+ cp -f "${srcdir}/playerglobal${_player_ver/./_}.swc" "player/${_player_ver}/playerglobal.swc"
}
package() {
- cd "${srcdir}"
- install -dDm755 "${pkgdir}/opt"
- cp -dr --no-preserve=ownership ${pkgname}-${pkgver}-bin "${pkgdir}/opt/${pkgname}"
- rm "${pkgdir}/opt/${pkgname}/bin/"*.bat
- install -Dm755 apache-flex-sdk.sh "${pkgdir}/etc/profile.d/apache-flex-sdk.sh"
+ install -d "${pkgdir}/opt"
+
+ # install sdk files
+ cp -dr --no-preserve='ownership' "${pkgname}-${pkgver}-bin" "${pkgdir}/opt/${pkgname}"
+
+ # set PATH
+ install -D -m755 apache-flex-sdk.sh -t "${pkgdir}/etc/profile.d"
+
+ # remove windows files
+ rm -f "${pkgdir}/opt/${pkgname}/bin/"*.bat
}
diff --git a/apache-flex-sdk.install b/apache-flex-sdk.install
index 5350ef84a136..505526f5171e 100644
--- a/apache-flex-sdk.install
+++ b/apache-flex-sdk.install
@@ -1,3 +1,4 @@
post_install() {
- echo Please re-login or source /etc/profile to use the new \$PATH
+ printf '%s\n' 'The Apache Flex SDK executables are in /opt/apache-flex-sdk/bin'
+ printf '%s\n' 'You need to relogin in order for these files to appear in your PATH'
}
diff --git a/apache-flex-sdk.sh b/apache-flex-sdk.sh
index 20fb9343c70e..aef9313c78ae 100644
--- a/apache-flex-sdk.sh
+++ b/apache-flex-sdk.sh
@@ -1,2 +1,2 @@
export PLAYERGLOBAL_HOME=/opt/apache-flex-sdk/player
-export PATH="${PATH}":/opt/apache-flex-sdk/bin
+export PATH="${PATH:+${PATH}:}/opt/apache-flex-sdk/bin"