summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZach Hoffman2020-06-06 10:08:40 -0600
committerZach Hoffman2020-06-06 10:08:40 -0600
commit366952e91577343c643e4f49f0bf6bc439b8ed0a (patch)
tree823dfc866604b10e238b2936d157e4215ddc82b6
parent0a7db8235a70074b43d955b57c0f1aa1f852cd41 (diff)
downloadaur-366952e91577343c643e4f49f0bf6bc439b8ed0a.tar.gz
playerglobal.swc version 32.0
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD34
-rw-r--r--apache-flex-sdk.sh5
4 files changed, 39 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2eebcb42daa5..f80884b4593e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,28 @@
pkgbase = apache-flex-sdk
pkgdesc = The open-source framework for building expressive web and mobile applications
pkgver = 4.16.1
- pkgrel = 7
+ pkgrel = 8
url = https://flex.apache.org/
install = apache-flex-sdk.install
arch = any
license = APACHE
depends = bash
depends = java-environment
+ optdepends = apache-flex-sdk-docs: Documentation for Apache Flex SDK
optdepends = adobe-air-sdk: for compiling flex projects into AIR apps
- noextract = playerglobal31_0.swc
+ optdepends = flashplayer-standalone-debug: for debugging SWFs
+ optdepends = flashplugin-debug: for debugging SWFs in-browser
+ noextract = playerglobal.swc
options = !strip
options = !emptydirs
- source = https://www.apache.org/dist/flex/4.16.1/binaries/apache-flex-sdk-4.16.1-bin.tar.gz
- source = https://fpdownload.macromedia.com/get/flashplayer/installers/archive/playerglobal/playerglobal31_0.swc
+ source = https://downloads.apache.org/flex/4.16.1/binaries/apache-flex-sdk-4.16.1-bin.tar.gz
+ source = https://downloads.apache.org/flex/4.16.1/binaries/apache-flex-sdk-4.16.1-bin.tar.gz.md5
+ source = playerglobal.swc::https://fpdownload.macromedia.com/get/flashplayer/installers/archive/playerglobal/playerglobal32_0.swc
source = apache-flex-sdk.sh
sha256sums = 17fda7ac8d3e476cad3127f345455ef316acfb87c6f4322e5897bd8d9b09388e
- sha256sums = e8b0799cb19d57729407be54bad0ce13e148b93ac176952ec49952e082b6869a
- sha256sums = 0bb488494fed38498c90c5eb0fede79827f1b074cc21de94bebf2eae28c27890
+ sha256sums = SKIP
+ sha256sums = 66927db00b2aed2ec2159961c2381277c67153e8a26b763ab328c94fab64da85
+ sha256sums = 13a4d4a11e44023f52ae9f3ac984065054604ebe6b1f2e3e69897f723d5fbd5d
pkgname = apache-flex-sdk
diff --git a/.gitignore b/.gitignore
index 30f62ee0a1d7..15abd67c78cb 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,6 @@
-playerglobal11_1.swc
+/apache-flex-sdk-*-any.pkg.tar.xz
+/apache-flex-sdk-*-bin.tar.gz
+/apache-flex-sdk-*-bin.tar.gz.md5
+/pkg/
+/playerglobal.swc
+/src/
diff --git a/PKGBUILD b/PKGBUILD
index 80a5c4f86d3a..63a631fd263b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,45 @@
-# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Maintainer : Zach Hoffman <zach@zrhoffman.net>
# Contributor: Yen Chi Hsuan <yan12125@gmail.com>
# Contributor: Michał Górny <zrchos+arch@gmail.com>
# Contributor: Ryan Lee <ryan@swyro.com>
+# Contributor: Daniel Bermond < gmail-com: danielbermond >
-_player_ver=31.0
-
+_player_ver=32.0
pkgname=apache-flex-sdk
pkgver=4.16.1
-pkgrel=7
+pkgrel=8
pkgdesc='The open-source framework for building expressive web and mobile applications'
arch=('any')
url='https://flex.apache.org/'
license=('APACHE')
depends=('bash' 'java-environment')
-optdepends=('adobe-air-sdk: for compiling flex projects into AIR apps')
+optdepends=('apache-flex-sdk-docs: Documentation for Apache Flex SDK'
+ 'adobe-air-sdk: for compiling flex projects into AIR apps'
+ 'flashplayer-standalone-debug: for debugging SWFs'
+ 'flashplugin-debug: for debugging SWFs in-browser'
+ )
options=('!strip' '!emptydirs')
install="${pkgname}.install"
-source=("https://www.apache.org/dist/flex/${pkgver}/binaries/apache-flex-sdk-${pkgver}-bin.tar.gz"
- "https://fpdownload.macromedia.com/get/flashplayer/installers/archive/playerglobal/playerglobal${_player_ver/./_}.swc"
+source=("https://downloads.apache.org/flex/${pkgver}/binaries/apache-flex-sdk-${pkgver}-bin.tar.gz"{,.md5}
+ "playerglobal.swc::https://fpdownload.macromedia.com/get/flashplayer/installers/archive/playerglobal/playerglobal${_player_ver/./_}.swc"
'apache-flex-sdk.sh')
-noextract=("playerglobal${_player_ver/./_}.swc")
-sha256sums=('17fda7ac8d3e476cad3127f345455ef316acfb87c6f4322e5897bd8d9b09388e'
- 'e8b0799cb19d57729407be54bad0ce13e148b93ac176952ec49952e082b6869a'
- '0bb488494fed38498c90c5eb0fede79827f1b074cc21de94bebf2eae28c27890')
+noextract=('playerglobal.swc')
+sha256sums=('17fda7ac8d3e476cad3127f345455ef316acfb87c6f4322e5897bd8d9b09388e' 'SKIP'
+ '66927db00b2aed2ec2159961c2381277c67153e8a26b763ab328c94fab64da85'
+ '13a4d4a11e44023f52ae9f3ac984065054604ebe6b1f2e3e69897f723d5fbd5d')
package() {
+ # remove windows files
+ rm "${pkgname}-${pkgver}-bin/"{bin,ide}/*.bat
+
install -d "${pkgdir}/opt"
# sdk files
cp -dr --no-preserve='ownership' "${pkgname}-${pkgver}-bin" "${pkgdir}/opt/${pkgname}"
# player
- install -D -m644 "${srcdir}/playerglobal${_player_ver/./_}.swc" "${pkgdir}/opt/${pkgname}/player/${_player_ver}/playerglobal.swc"
+ install -D -m644 "${srcdir}/playerglobal.swc" "${pkgdir}/opt/${pkgname}/player/${_player_ver}/playerglobal.swc"
# set PATH
install -D -m755 apache-flex-sdk.sh -t "${pkgdir}/etc/profile.d"
-
- # remove windows files
- rm -f "${pkgdir}/opt/${pkgname}/bin/"*.bat
}
diff --git a/apache-flex-sdk.sh b/apache-flex-sdk.sh
index b5b6f9f2e027..7d0ab56b1cce 100644
--- a/apache-flex-sdk.sh
+++ b/apache-flex-sdk.sh
@@ -1,2 +1,3 @@
-export PLAYERGLOBAL_HOME='/opt/apache-flex-sdk/player'
-export PATH="${PATH:+${PATH}:}/opt/apache-flex-sdk/bin"
+export FLEX_HOME='/opt/apache-flex-sdk'
+export PLAYERGLOBAL_HOME="${FLEX_HOME}/player"
+export PATH="${PATH:+${PATH}:}${FLEX_HOME}/bin"