summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2023-06-11 09:52:17 +0200
committerFabioLolix2023-06-11 09:52:17 +0200
commit4cb4a04f7cd16d11c5c470d606ac022f8c2357cc (patch)
tree747db03e2145368b017110649eeef6fcd40d8b13
parentc011bbab350b5ec6856511a0f15b7d883aa06370 (diff)
downloadaur-appimagelauncher-git.tar.gz
update git modules, makedepends
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD46
2 files changed, 26 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3627007aed0..35a463c1e578 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = appimagelauncher-git
pkgdesc = A Helper application for running and integrating AppImages.
- pkgver = r1244.d9d4c73
- pkgrel = 2
+ pkgver = r1251.71e8e32
+ pkgrel = 1
url = https://assassinate-you.net/tags/appimagelauncher/
arch = x86_64
license = MIT
@@ -9,6 +9,7 @@ pkgbase = appimagelauncher-git
makedepends = cmake
makedepends = boost
makedepends = qt5-tools
+ makedepends = qt5-declarative
makedepends = lib32-glibc
makedepends = lib32-gcc-libs
makedepends = xxd
@@ -20,15 +21,14 @@ pkgbase = appimagelauncher-git
depends = libxpm
provides = appimagelauncher
conflicts = appimagelauncher
- source = appimagelauncher::git+https://github.com/TheAssassin/AppImageLauncher.git
- source = git+https://github.com/AppImage/AppImageUpdate.git
- source = git+https://github.com/AppImage/libappimage.git
+ source = git+https://github.com/TheAssassin/AppImageLauncher.git
+ source = git+https://github.com/AppImageCommunity/AppImageUpdate.git
source = git+https://github.com/TheAssassin/zsync2.git
source = git+https://github.com/TheAssassin/fltk-1.3.4.git
source = git+https://github.com/TheAssassin/libdesktopenvironments.git
source = git+https://github.com/arsenm/sanitizers-cmake.git
source = git+https://github.com/google/googletest.git
- source = git+https://github.com/AppImage/cpr.git
+ source = AppImage-cpr::git+https://github.com/AppImage/cpr.git
source = git+https://github.com/Taywee/args.git
source = appimage-binfmt-remove.hook
sha256sums = SKIP
@@ -40,7 +40,6 @@ pkgbase = appimagelauncher-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = SKIP
sha256sums = 72a2630cf79b8f90bc21eae1d9f40c07fe77ce22df46c511b500f514455d7c81
pkgname = appimagelauncher-git
diff --git a/PKGBUILD b/PKGBUILD
index 2f97dc375a82..175b3b71ed09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,25 @@
# Contributor: TheAssassin
pkgname=appimagelauncher-git
-pkgver=r1244.d9d4c73
-pkgrel=2
+pkgver=r1251.71e8e32
+pkgrel=1
pkgdesc="A Helper application for running and integrating AppImages."
arch=(x86_64)
url="https://assassinate-you.net/tags/appimagelauncher/"
license=(MIT)
depends=(qt5-base fuse2 squashfuse libappimage libxpm)
-makedepends=(git cmake boost qt5-tools lib32-glibc lib32-gcc-libs xxd chrpath)
+makedepends=(git cmake boost qt5-tools qt5-declarative lib32-glibc lib32-gcc-libs xxd chrpath)
provides=(appimagelauncher)
conflicts=(appimagelauncher)
-source=("${pkgname%-git}::git+https://github.com/TheAssassin/AppImageLauncher.git"
- "git+https://github.com/AppImage/AppImageUpdate.git"
- "git+https://github.com/AppImage/libappimage.git"
+source=("git+https://github.com/TheAssassin/AppImageLauncher.git"
+ "git+https://github.com/AppImageCommunity/AppImageUpdate.git"
+ #"git+https://github.com/AppImageCommunity/libappimage.git"
"git+https://github.com/TheAssassin/zsync2.git"
"git+https://github.com/TheAssassin/fltk-1.3.4.git"
"git+https://github.com/TheAssassin/libdesktopenvironments.git"
"git+https://github.com/arsenm/sanitizers-cmake.git"
"git+https://github.com/google/googletest.git"
- "git+https://github.com/AppImage/cpr.git"
+ "AppImage-cpr::git+https://github.com/AppImage/cpr.git"
"git+https://github.com/Taywee/args.git"
'appimage-binfmt-remove.hook')
sha256sums=('SKIP'
@@ -33,52 +33,46 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
'72a2630cf79b8f90bc21eae1d9f40c07fe77ce22df46c511b500f514455d7c81')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd AppImageLauncher
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
#git describe --long --tags --exclude continuous | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$srcdir/${pkgname%-git}"
+ cd AppImageLauncher
git submodule init
git config submodule.lib/AppImageUpdate.url "${srcdir}/AppImageUpdate"
- git config submodule.lib/libappimage.url "${srcdir}/libappimage"
git -c protocol.file.allow=always submodule update
- cd "$srcdir/${pkgname%-git}/lib/AppImageUpdate"
+ cd "${srcdir}/AppImageLauncher/lib/AppImageUpdate"
git submodule init
git config submodule.lib/zsync2.url "${srcdir}/zsync2"
git config submodule.lib/fltk.url "${srcdir}/fltk-1.3.4"
git config submodule.lib/libdesktopenvironments.url "${srcdir}/libdesktopenvironments"
git config submodule.lib/sanitizers-cmake.url "${srcdir}/sanitizers-cmake"
- git config submodule.lib/libappimage.url "${srcdir}/libappimage"
+ #git config submodule.lib/libappimage.url "${srcdir}/libappimage"
+ git config submodule.lib/libappimage.update none
git -c protocol.file.allow=always submodule update
- cd "$srcdir/${pkgname%-git}/lib/AppImageUpdate/lib/libappimage"
- git submodule init
- git config submodule.lib/gtest.url "${srcdir}/googletest"
- git -c protocol.file.allow=always submodule update
+ #cd "${srcdir}/AppImageLauncher/lib/AppImageUpdate/lib/libappimage"
+ #git submodule init
+ #git config submodule.lib/gtest.url "${srcdir}/googletest"
+ #git -c protocol.file.allow=always submodule update
- cd "$srcdir/${pkgname%-git}/lib/AppImageUpdate/lib/zsync2"
+ cd "$srcdir/AppImageLauncher/lib/AppImageUpdate/lib/zsync2"
git submodule init
- git config submodule.lib/cpr.url "${srcdir}/cpr"
+ git config submodule.lib/cpr.url "${srcdir}/AppImage-cpr"
git config submodule.lib/args.url "${srcdir}/args"
git config submodule.lib/gtest.url "${srcdir}/googletest"
git -c protocol.file.allow=always submodule update
-
- cd "${srcdir}/${pkgname%-git}/lib/libappimage"
- git submodule init
- git config submodule.lib/gtest.url "${srcdir}/googletest"
- git -c protocol.file.allow=always submodule update
}
build() {
- cd "$srcdir/${pkgname%-git}"
+ cd AppImageLauncher
cmake . -Wno-dev \
-DCMAKE_INSTALL_PREFIX=/usr/ \
@@ -90,7 +84,7 @@ build() {
}
package() {
- cd "$srcdir/${pkgname%-git}"
+ cd AppImageLauncher
make DESTDIR="$pkgdir" install
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 ../appimage-binfmt-remove.hook "$pkgdir"/usr/share/libalpm/hooks/appimage-binfmt-remove.hook