summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHeptazhou2024-04-11 20:54:57 +0000
committerHeptazhou2024-04-11 20:58:32 +0000
commitc292b7fe3ae8a8d1771db2f6315dfe29dd3232e2 (patch)
tree1ff682596ea31e2f3fcce5eb646bd1a41aab7de5
downloadaur-apt-zsh-completion.tar.gz
zsh v5.9
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87e5d3c4c256
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = apt-zsh-completion
+ pkgdesc = Zsh completion for apt and dpkg
+ pkgver = 5.9
+ pkgrel = 1
+ url = https://zsh.org/
+ arch = any
+ license = custom
+ depends = zsh
+ options = !debug
+ source = apt-zsh-completion@zsh-v5.9.tar.xz::https://zsh.org/pub/zsh-5.9.tar.xz
+ sha256sums = 9b8d1ecedd5b5e81fbf1918e876752a7dd948e05c1a0dba10ab863842d45acd5
+ sha512sums = d9138b7f379ad942a5f46819d2dd52d31f3a1129f2a0d1b53d4c5cd43c318b60396da6d37c57c477b8e958fb750209aca0ae93f8c9dd42ac958de006a0ff067e
+
+pkgname = apt-zsh-completion
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20b99b7c483c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Heptazhou <zhou at 0h7z dot com>
+
+pkgname=apt-zsh-completion
+pkgver=5.9
+pkgrel=1
+pkgdesc="Zsh completion for apt and dpkg"
+arch=("any")
+url="https://zsh.org/"
+license=("custom")
+depends=("zsh")
+options=(!debug)
+source=("$pkgname@zsh-v$pkgver.tar.xz::${url%/}/pub/zsh-$pkgver.tar.xz")
+sha256sums=("9b8d1ecedd5b5e81fbf1918e876752a7dd948e05c1a0dba10ab863842d45acd5")
+
+package() {
+ cd -- "$srcdir/zsh-$pkgver/"
+ install -Dm644 -t "$pkgdir/usr/share/zsh/site-functions/" Completion/Debian/{Command/_{apt,dpkg},Type/_deb_{file,package}s}
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" "LICENSE"
+}
+
+build() {
+ cd -- "$srcdir/zsh-$pkgver/"
+ mv -f "LICENCE" "LICENSE"
+}
+
+# https://gitlab.archlinux.org/archlinux/packaging/packages/zsh
+sha512sums=("d9138b7f379ad942a5f46819d2dd52d31f3a1129f2a0d1b53d4c5cd43c318b60396da6d37c57c477b8e958fb750209aca0ae93f8c9dd42ac958de006a0ff067e")