summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoeljunior2018-02-26 11:07:50 +0000
committerNoeljunior2018-02-26 11:08:04 +0000
commit1bd966277b4da759e432d4f101bb47ccdb854eb9 (patch)
tree45846eff74baa83e6e2d9f5dd5469088d018b9e7
parent23e3aede2ac9560b4d2afb6ed2655ff87023b0ec (diff)
downloadaur-1bd966277b4da759e432d4f101bb47ccdb854eb9.tar.gz
updating upstream
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD46
2 files changed, 39 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f3887523da0..3f08c9bffb8e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = arc-gtk-theme-git
- pkgdesc = Arc is a flat theme with transparent elements for GTK 3, GTK 2 and Gnome-Shell. It supports GTK 3 and GTK 2 based desktop environments like Gnome, Unity, Budgie, Pantheon, etc.
- pkgver = 53.74f43ab
+ pkgdesc = A flat theme with transparent elements for GTK 3, GTK 2 and Gnome-Shell
+ pkgver = 712.51d88f1
pkgrel = 1
- url = https://github.com/horst3180/Arc-theme
+ url = https://github.com/nicohood/arc-theme
arch = any
license = GPL3
makedepends = git
- makedepends = automake
- makedepends = autoconf
- depends = gnome-themes-standard
- depends = gtk-engine-murrine
- provides = arc-theme
- conflicts = arc-theme
- replaces = arc-theme
- options = !strip
- source = arc-gtk-theme-git::git+https://github.com/horst3180/arc-theme.git
- sha256sums = SKIP
+ makedepends = gtk3
+ makedepends = sassc
+ optdepends = arc-icon-theme: recommended icon theme
+ optdepends = gtk-engine-murrine: for gtk2 themes
+ optdepends = gnome-themes-standard: for gtk2 themes
+ provides = arc-gtk-theme
+ conflicts = arc-gtk-theme
+ source = arc-theme::git+https://github.com/nicohood/arc-theme.git
+ sha512sums = SKIP
pkgname = arc-gtk-theme-git
diff --git a/PKGBUILD b/PKGBUILD
index 7d621c4aa7a3..7e11d2f779c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,43 @@
-# Maintainer: Malte Ohmstede <malte.ohmstede@gmail.com>
+# Maintainer: Noeljnuior <liamgliamgmailcom>
+
+# Contributor: NicoHood <archlinux {cat} nicohood {dog} de>
+# Contributor: zach <zach {at} zach-adams {dot} com>
+# Contributor: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de
+# Contributor: Philipp Wolfer <ph.wolfer@gmail.com>
_pkgname=arc-theme
pkgname=arc-gtk-theme-git
-pkgver=53.74f43ab
+pkgdesc="A flat theme with transparent elements for GTK 3, GTK 2 and Gnome-Shell"
+pkgver=712.51d88f1
pkgrel=1
-pkgdesc="Arc is a flat theme with transparent elements for GTK 3, GTK 2 and Gnome-Shell. It supports GTK 3 and GTK 2 based desktop environments like Gnome, Unity, Budgie, Pantheon, etc."
arch=('any')
-url="https://github.com/horst3180/Arc-theme"
+# Upstream url: https://github.com/horst3180/arc-theme
+# Now using soft fork: https://github.com/horst3180/arc-theme/issues/840
+url="https://github.com/nicohood/arc-theme"
license=('GPL3')
-depends=('gnome-themes-standard' 'gtk-engine-murrine')
-makedepends=('git' 'automake' 'autoconf')
-conflicts=("${_pkgname}")
-provides=("${_pkgname}")
-replaces=("${_pkgname}")
-options=(!strip)
-source=(${pkgname}::"git+https://github.com/horst3180/${_pkgname}.git")
-sha256sums=('SKIP')
-
+optdepends=('arc-icon-theme: recommended icon theme'
+ 'gtk-engine-murrine: for gtk2 themes'
+ 'gnome-themes-standard: for gtk2 themes')
+makedepends=('git' 'gtk3' 'sassc')
+source=(${_pkgname}::"git+https://github.com/nicohood/${_pkgname}.git")
+sha512sums=('SKIP')
+conflicts=('arc-gtk-theme')
+provides=('arc-gtk-theme')
pkgver() {
- cd ${srcdir}/${pkgname}
- echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ cd "${srcdir}/${_pkgname}"
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
-
-build(){
- cd $srcdir/$pkgname
+build() {
+ cd ${_pkgname}
./autogen.sh --prefix=/usr
+ cd ../${_pkgname}
+ ./autogen.sh --prefix=/usr
}
+
package() {
- cd $srcdir/$pkgname
+ cd ${_pkgname}
make DESTDIR="${pkgdir}" install
}