summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoonas Henriksson2020-06-03 06:03:53 +0300
committerJoonas Henriksson2020-06-03 06:03:53 +0300
commit96575a4e353fc8f6f92510bc9e82be6e276280ec (patch)
tree0cb1438744c5abe47d434ed2541e747deb371a4c
parentf81ae7c46e8c1ce5bc91e2facefe1c5a7bd209f6 (diff)
downloadaur-96575a4e353fc8f6f92510bc9e82be6e276280ec.tar.gz
Add custom variables for theme versions
This simplifies the PKGBUILD maintenance, and prevents accidentally forgetting to update the versions for both package variants. The values for the custom variables should be kept in sync with latest stable packages available from Arch mirrors.
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b9c7c33b087a..001c3a6b3e95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,6 +19,11 @@ optdepends=('gtk-engine-murrine: GTK2 support'
source=("${_pkgname}::git+https://github.com/jnsh/${_pkgname}.git")
md5sums=('SKIP')
+# Latest stable Arch package versions
+_cinnamonver=4.6
+_gnomeshellver=3.36
+_gtk3ver=3.24
+
pkgver() {
cd "${_pkgname}"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
@@ -27,9 +32,9 @@ pkgver() {
build() {
cd "${_pkgname}"
./autogen.sh --prefix=/usr \
- --with-cinnamon=4.6 \
- --with-gnome-shell=3.36 \
- --with-gtk3=3.24
+ --with-cinnamon="${_cinnamonver}" \
+ --with-gnome-shell="${_gnomeshellver}" \
+ --with-gtk3="${_gtk3ver}"
make
cd "${srcdir}"
@@ -37,9 +42,9 @@ build() {
cd "${_pkgname}-solid"
./autogen.sh --prefix=/usr \
- --with-cinnamon=4.6 \
- --with-gnome-shell=3.36 \
- --with-gtk3=3.24 \
+ --with-cinnamon="${_cinnamonver}" \
+ --with-gnome-shell="${_gnomeshellver}" \
+ --with-gtk3="${_gtk3ver}" \
--disable-transparency
make
}