summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoonas Henriksson2021-01-15 19:04:59 +0200
committerJoonas Henriksson2021-01-15 19:08:32 +0200
commitdeccac116ec344ec86d119c3fcc3a4c7e3f5f4f0 (patch)
tree79499b103edfe09e0b6d9ae616763c5d3c18d1a4
parentcdcaf46890477f00e2b436d156a7042d0569f0e6 (diff)
downloadaur-deccac116ec344ec86d119c3fcc3a4c7e3f5f4f0.tar.gz
Build with meson
Upstream switched to meson build system with: https://github.com/jnsh/arc-theme/commit/f5b2e047b9be4543c1afc6c0dc3fd443b37771d6
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD37
2 files changed, 19 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5c7d6121d3d..333b9137c830 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = arc-gtk-theme-git
pkgdesc = A flat theme suite with transparent elements.
- pkgver = 20200819.r58.g0c53316
+ pkgver = 20201013.r15.g1c41d1b
pkgrel = 1
url = https://github.com/jnsh/arc-theme
arch = any
license = GPL3
+ makedepends = meson
makedepends = sassc
makedepends = inkscape
- makedepends = optipng
makedepends = git
optdepends = gtk-engine-murrine: GTK2 support
optdepends = gnome-themes-extra: GTK2 support
diff --git a/PKGBUILD b/PKGBUILD
index 96e2c9b20353..fa54b6f76129 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,13 @@
pkgbase=arc-gtk-theme-git
_pkgname=arc-theme
pkgname=('arc-gtk-theme-git' 'arc-solid-gtk-theme-git')
-pkgver=20200819.r58.g0c53316
+pkgver=20201013.r15.g1c41d1b
pkgrel=1
pkgdesc="A flat theme suite with transparent elements."
arch=('any')
url="https://github.com/jnsh/arc-theme"
license=('GPL3')
-makedepends=('sassc' 'inkscape' 'optipng' 'git')
+makedepends=('meson' 'sassc' 'inkscape' 'git')
optdepends=('gtk-engine-murrine: GTK2 support'
'gnome-themes-extra: GTK2 support')
source=("${_pkgname}::git+https://github.com/jnsh/${_pkgname}.git")
@@ -31,35 +31,32 @@ pkgver() {
build() {
cd "${_pkgname}"
- ./autogen.sh --prefix=/usr \
- --with-cinnamon="${_cinnamonver}" \
- --with-gnome-shell="${_gnomeshellver}" \
- --with-gtk3="${_gtk3ver}"
- make
- cd "${srcdir}"
- cp -a "${_pkgname}"{,-solid}
-
- cd "${_pkgname}-solid"
- ./autogen.sh --prefix=/usr \
- --with-cinnamon="${_cinnamonver}" \
- --with-gnome-shell="${_gnomeshellver}" \
- --with-gtk3="${_gtk3ver}" \
- --disable-transparency
- make
+ meson --prefix=/usr build \
+ -Dcinnamon_version="${_cinnamonver}" \
+ -Dgnome_shell_version="${_gnomeshellver}" \
+ -Dgtk3_version="${_gtk3ver}"
+ meson compile -C build
+
+ meson --prefix=/usr build-solid \
+ -Dtransparency=false \
+ -Dcinnamon_version="${_cinnamonver}" \
+ -Dgnome_shell_version="${_gnomeshellver}" \
+ -Dgtk3_version="${_gtk3ver}"
+ meson compile -C build-solid
}
package_arc-gtk-theme-git() {
conflicts=('arc-gtk-theme')
cd "${_pkgname}"
- make DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir" meson install -C build
}
package_arc-solid-gtk-theme-git() {
pkgdesc="A flat theme suite without transparent elements."
conflicts=('arc-solid-gtk-theme')
- cd "${_pkgname}-solid"
- make DESTDIR="$pkgdir/" install
+ cd "${_pkgname}"
+ DESTDIR="$pkgdir" meson install -C build-solid
}