summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoonas Henriksson2020-06-03 05:45:22 +0300
committerJoonas Henriksson2020-06-03 05:45:22 +0300
commitf81ae7c46e8c1ce5bc91e2facefe1c5a7bd209f6 (patch)
treeb0f7e5a86e5d4c10c9a750c052e2a8bade77a5eb
parentce4b9a0a222317775d75a14a3ce15597ca57f8d4 (diff)
downloadaur-f81ae7c46e8c1ce5bc91e2facefe1c5a7bd209f6.tar.gz
Update for new upstream
Switch to actively maintained upstream source, and update the PKGBUILD accordingly based on the arc-gtk-theme-jnsh-git AUR package.
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD70
2 files changed, 48 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29ad1b4b4b9a..8d01847211d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,23 @@
pkgbase = arc-gtk-theme-git
- pkgdesc = A flat theme with transparent elements for GTK 3, GTK 2 and Gnome-Shell
- pkgver = 20180715.r3.b12b2e7
+ pkgdesc = A flat theme suite with transparent elements.
+ pkgver = 20200513.r15.g2f38b0d
pkgrel = 1
- url = https://github.com/nicohood/arc-theme
+ url = https://github.com/jnsh/arc-theme
arch = any
license = GPL3
- makedepends = gtk3
makedepends = sassc
- makedepends = git
- makedepends = optipng
makedepends = inkscape
- optdepends = arc-icon-theme: recommended icon theme
- optdepends = gtk-engine-murrine: for gtk2 themes
- optdepends = gnome-themes-standard: for gtk2 themes
- conflicts = arc-gtk-theme
- replaces = arc-gtk-theme
- source = arc-theme::git+https://github.com/nicohood/arc-theme.git
- validpgpkeys = 97312D5EB9D7AE7D0BD4307351DAE9B7C1AE9161
- sha512sums = SKIP
+ makedepends = optipng
+ makedepends = git
+ optdepends = gtk-engine-murrine: GTK2 support
+ optdepends = gnome-themes-extra: GTK2 support
+ source = arc-theme::git+https://github.com/jnsh/arc-theme.git
+ md5sums = SKIP
pkgname = arc-gtk-theme-git
- conflicts = arc-gtk-theme-git
- replaces = gtk-theme-arc-git
+ conflicts = arc-gtk-theme
pkgname = arc-solid-gtk-theme-git
- pkgdesc = A flat theme for GTK 3, GTK 2 and Gnome-Shell (without transparency)
- conflicts = arc-solid-gtk-theme-git
- replaces = gtk-theme-arc-solid-git
+ pkgdesc = A flat theme suite without transparent elements.
+ conflicts = arc-solid-gtk-theme
diff --git a/PKGBUILD b/PKGBUILD
index bc6c2c64c9e2..b9c7c33b087a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Maintainer: NicoHood <archlinux {cat} nicohood {dog} de>
-# PGP ID: 97312D5EB9D7AE7D0BD4307351DAE9B7C1AE9161
+# Maintainer: Joonas Henriksson <joonas.henriksson at gmail com>
+# Contributor: NicoHood <archlinux {cat} nicohood {dog} de>
# Contributor: zach <zach {at} zach-adams {dot} com>
# Contributor: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de
# Contributor: Philipp Wolfer <ph.wolfer@gmail.com>
@@ -7,52 +7,54 @@
pkgbase=arc-gtk-theme-git
_pkgname=arc-theme
pkgname=('arc-gtk-theme-git' 'arc-solid-gtk-theme-git')
-pkgdesc="A flat theme with transparent elements for GTK 3, GTK 2 and Gnome-Shell"
-pkgver=20180715.r3.b12b2e7
+pkgver=20200513.r15.g2f38b0d
pkgrel=1
+pkgdesc="A flat theme suite with transparent elements."
arch=('any')
-# Upstream url: https://github.com/horst3180/arc-theme
-# Now using soft fork: https://github.com/horst3180/arc-theme/issues/840
-url="https://github.com/nicohood/arc-theme"
+url="https://github.com/jnsh/arc-theme"
license=('GPL3')
-optdepends=('arc-icon-theme: recommended icon theme'
- 'gtk-engine-murrine: for gtk2 themes'
- 'gnome-themes-standard: for gtk2 themes')
-makedepends=('gtk3' 'sassc' 'git' 'optipng' 'inkscape')
-conflicts=('arc-gtk-theme')
-replaces=('arc-gtk-theme')
-source=("${_pkgname}::git+https://github.com/nicohood/${_pkgname}.git")
-sha512sums=('SKIP')
-validpgpkeys=('97312D5EB9D7AE7D0BD4307351DAE9B7C1AE9161') # NicoHood
+makedepends=('sassc' 'inkscape' 'optipng' 'git')
+optdepends=('gtk-engine-murrine: GTK2 support'
+ 'gnome-themes-extra: GTK2 support')
+source=("${_pkgname}::git+https://github.com/jnsh/${_pkgname}.git")
+md5sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}"
- git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g'
-}
-
-prepare() {
- cp -a ${_pkgname}{,-solid}
+ cd "${_pkgname}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd ${_pkgname}
- ./autogen.sh --prefix=/usr
-
- cd ../${_pkgname}-solid
- ./autogen.sh --prefix=/usr --disable-transparency
+ cd "${_pkgname}"
+ ./autogen.sh --prefix=/usr \
+ --with-cinnamon=4.6 \
+ --with-gnome-shell=3.36 \
+ --with-gtk3=3.24
+ make
+
+ cd "${srcdir}"
+ cp -a "${_pkgname}"{,-solid}
+
+ cd "${_pkgname}-solid"
+ ./autogen.sh --prefix=/usr \
+ --with-cinnamon=4.6 \
+ --with-gnome-shell=3.36 \
+ --with-gtk3=3.24 \
+ --disable-transparency
+ make
}
package_arc-gtk-theme-git() {
- replaces=('gtk-theme-arc-git')
- conflicts=('arc-gtk-theme-git')
+ conflicts=('arc-gtk-theme')
- make -C "${srcdir}/${_pkgname}" DESTDIR="${pkgdir}" install
+ cd "${_pkgname}"
+ make DESTDIR="$pkgdir/" install
}
package_arc-solid-gtk-theme-git() {
- pkgdesc="A flat theme for GTK 3, GTK 2 and Gnome-Shell (without transparency)"
- replaces=('gtk-theme-arc-solid-git')
- conflicts=('arc-solid-gtk-theme-git')
+ pkgdesc="A flat theme suite without transparent elements."
+ conflicts=('arc-solid-gtk-theme')
- make -C "${srcdir}/${_pkgname}-solid" DESTDIR="${pkgdir}" install
+ cd "${_pkgname}-solid"
+ make DESTDIR="$pkgdir/" install
}