summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2022-07-12 09:18:55 +0000
committerPellegrino Prevete2022-07-12 09:18:55 +0000
commitb5434211c66da8a760ff44978fc45ecb09640fd9 (patch)
treee258a765f0821fe7c43cde032def0882b889c388
downloadaur-archlinux-gce.tar.gz
initial build
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e48130d7868
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = archlinux-gce
+ pkgdesc = Builds an Archlinux install drive for import in Google Compute Engine.
+ pkgver = 2022.07.12
+ pkgrel = 1
+ url = https://gitlab.archlinux.org/tallero/archiso-profiles
+ arch = i686
+ arch = pentium4
+ arch = x86_64
+ license = AGPL3
+ checkdepends = shellcheck
+ makedepends = archlinux
+ provides = archlinux-ereleng-gce
+
+pkgname = archlinux-gce
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..581d3f719069
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
+
+# shellcheck disable=SC2034
+_pkg="archiso"
+_distro="archlinux"
+_pkgbase="${_pkg}-profiles"
+profile="ereleng"
+_pkgname="${_distro}"
+pkgname=("${_pkgname}-gce")
+pkgver="$(date +%Y.%m.%d)"
+pkgrel=1
+pkgdesc="Builds an Archlinux install drive for import in Google Compute Engine."
+arch=('i686'
+ 'pentium4'
+ 'x86_64')
+license=('AGPL3')
+url="https://gitlab.${_distro}.org/tallero/${_pkgbase}"
+provides=("${_distro}-${profile}-gce")
+makedepends=("${_pkgname}")
+checkdepends=('shellcheck')
+
+## shellcheck disable=SC2154
+package() {
+ local _dest="${pkgdir}/usr/share/${_distro}"
+ local _iso_name="/usr/share/${_distro}/${_pkgname}-x86_64.iso"
+ rm -rf "${_dest}"
+ mkdir -p "${_dest}"
+ cp "${_iso_name}" disk.raw
+ tar --format=oldgnu -Sczf "${_dest}/${_pkgname}.tar.gz" disk.raw
+}