summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantinos2017-06-17 19:27:21 +0300
committerKonstantinos2017-06-17 19:27:21 +0300
commitdc0bc130c562b5f8d516b27a960cf67b32c31b2e (patch)
treecbabfaaa4024ef56562e52af14e7cc7c30f5a633
downloadaur-arcpp-git.tar.gz
useful commit message
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e107aa440a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = arcpp-git
+ pkgdesc = An implementation of the Arc programming language. (GIT version)
+ pkgver = 0.13.2.r0.g946c5c5
+ pkgrel = 1
+ url = https://github.com/kimtg/Arcpp
+ arch = x86_64
+ arch = i686
+ license = Apache
+ makedepends = git
+ depends = readline
+ provides = arcpp
+ conflicts = arcpp
+ source = git+https://github.com/kimtg/arcpp.git
+ sha256sums = SKIP
+
+pkgname = arcpp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..57bf50a65552
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Konstantinos Foutzopoulos <mail@konfou.xyz>
+
+_pkgname=arcpp
+pkgname=${_pkgname}-git
+pkgver=0.13.2.r0.g946c5c5
+pkgrel=1
+pkgdesc="An implementation of the Arc programming language. (GIT version)"
+arch=('x86_64' 'i686')
+url="https://github.com/kimtg/Arcpp"
+license=('Apache')
+depends=('readline')
+makedepends=('git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("git+https://github.com/kimtg/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ git describe --long --tags | sed -e 's/v//;s/-/.r/;s/-/./'
+}
+
+build() {
+ cd ${_pkgname}
+ make readline
+}
+
+package() {
+ cd ${_pkgname}
+ install -Dm755 "arc++" "${pkgdir}/usr/bin/arc++"
+}
+
+# vim:set ts=2 sw=2 et: