summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMastergatto2022-03-31 23:18:05 +0200
committerMastergatto2022-03-31 23:18:05 +0200
commit046a0dafc420355d485b45dd49d90fee29427eac (patch)
tree0ffdcb8060711d96d804372d1361182255925b23
parent05e349598348d828a90a9bf47251942da50fe69c (diff)
downloadaur-046a0dafc420355d485b45dd49d90fee29427eac.tar.gz
desktop-ui/desktop-ui.cpp has changed, so fix the patch.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--ares-paths.patch37
3 files changed, 24 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5ee64d48fa5..fdad7a3f3aaf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = ares-emu-git
pkgdesc = Multi-system emulator by Near with experimental Nintendo 64 and PlayStation support. (git version)
- pkgver = v121a.r47.g409ea8d7c
+ pkgver = v123.r319.g808b658b4
pkgrel = 1
- url = https://ares.dev/
+ url = https://ares-emu.net/
arch = x86_64
arch = i686
license = ISC
@@ -24,6 +24,6 @@ pkgbase = ares-emu-git
source = git+https://github.com/higan-emu/ares.git
source = ares-paths.patch
sha256sums = SKIP
- sha256sums = 71fcc3a8ad81107c025545c39a9f972f80b0d7096739f54b1004a2b58704b2ee
+ sha256sums = 5805cfea308e46b0a209613d4693f3bb15ebb750436fc80d478437e464b6bf52
pkgname = ares-emu-git
diff --git a/PKGBUILD b/PKGBUILD
index 58a7dd449b42..292932656274 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Snowstorm64
pkgname=ares-emu-git
-pkgver=v121a.r47.g409ea8d7c
+pkgver=v123.r319.g808b658b4
pkgrel=1
pkgdesc="Multi-system emulator by Near with experimental Nintendo 64 and PlayStation support. (git version)"
arch=(x86_64 i686)
-url="https://ares.dev/"
+url="https://ares-emu.net/"
license=("ISC")
depends=(gtk3 gtksourceview3 libao libgl libpulse libudev.so=1-64 libxv openal sdl2 vulkan-driver vulkan-icd-loader)
makedepends=(mesa git)
@@ -14,7 +14,7 @@ conflicts=(ares-emu)
source=("git+https://github.com/higan-emu/ares.git"
"ares-paths.patch")
sha256sums=("SKIP"
- "71fcc3a8ad81107c025545c39a9f972f80b0d7096739f54b1004a2b58704b2ee")
+ "5805cfea308e46b0a209613d4693f3bb15ebb750436fc80d478437e464b6bf52")
pkgver() {
cd "${srcdir}/ares"
@@ -26,7 +26,6 @@ pkgver() {
prepare() {
# Patch Ares so that it can look for its files that are installed system-wide here
- # With v123 lucia has been changed to ares, so we rename any user folder named lucia, to ares.
patch -Np1 -i "${srcdir}/ares-paths.patch"
}
@@ -37,7 +36,7 @@ build() {
package() {
install -Dm 644 "${srcdir}/ares/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm 755 "${srcdir}/ares/desktop-ui/out/ares" -t "${pkgdir}/usr/bin/"
- install -Dm 644 "${srcdir}/ares/desktop-ui/resource/ares.png" -t "${pkgdir}/usr/share/icons/"
+ install -Dm 644 "${srcdir}/ares/desktop-ui/resource/ares.png" -t "${pkgdir}/usr/share/icons/hicolor/256x256/apps/"
install -Dm 644 "${srcdir}/ares/desktop-ui/resource/ares.desktop" -t "${pkgdir}/usr/share/applications/"
# Also install the shaders in Ares' shared directory
diff --git a/ares-paths.patch b/ares-paths.patch
index e3cb9289e51f..bd81e2c16fe8 100644
--- a/ares-paths.patch
+++ b/ares-paths.patch
@@ -1,23 +1,20 @@
diff --git a/ares/desktop-ui/desktop-ui.cpp b/ares/desktop-ui/desktop-ui.cpp
-@@ -15,8 +15,19 @@
- if(inode::exists(location)) return location;
- #endif
-
-- directory::create({Path::userData(), "ares/"});
-- return {Path::userData(), "ares/", name};
+@@ -23,15 +23,15 @@
+ // ship with the executable.
+ // On Windows, this allows settings from to be carried over
+ // from previous versions (pre-portable)
+- location = {Path::userData(), "ares/", name};
+ location = {Path::sharedData(), "ares/", name};
-+ if(inode::exists(location)) return location;
-+
-+ if(directory::exists({Path::userSettings(), "lucia/"})) {
-+ directory::rename({Path::userSettings(), "lucia/"}, {Path::userSettings(), "ares/"});
-+ }
-+
-+ if(directory::exists({Path::userData(), "lucia/"})) {
-+ directory::rename({Path::userData(), "lucia/"}, {Path::userData(), "ares/"});
-+ }
-+
-+ directory::create({Path::userSettings(), "ares/"});
-+ return {Path::userSettings(), "ares/", name};
- }
+ if(inode::exists(location)) return location;
- #include <nall/main.hpp>
+ // On non-windows platforms, after exhausting other options,
+ // default to userData, on Windows, default to program dir
+ // this ensures Portable mode is the default on Windows platforms.
+ #if !defined(PLATFORM_WINDOWS)
+- directory::create({Path::userData(), "ares/"});
+- return {Path::userData(), "ares/", name};
++ directory::create({Path::userSettings(), "ares/"});
++ return {Path::userSettings(), "ares/", name};
+ #else
+ return {Path::program(), name};
+ #endif