summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMastergatto2023-08-06 00:14:28 +0200
committerMastergatto2023-08-06 00:14:28 +0200
commit80d70690eed4d336fe22330ffcd251712b58d613 (patch)
tree4959fdbf0c3686c84704ecafbd9d6c964b37de0d
parent2caa5c8d0fbebd3de0d3a137771070e051b77427 (diff)
downloadaur-80d70690eed4d336fe22330ffcd251712b58d613.tar.gz
Patch is now merged upstream, but keep the code for migrating settings.bml to new location, for now.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--ares-paths.patch41
3 files changed, 12 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3cec854cf9ac..bfe726dbbcd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ares-emu-git
pkgdesc = Cross-platform, open source, multi-system emulator by Near and Ares team, focusing on accuracy and preservation. (git version)
- pkgver = 132.r129.g5f9804fb6
- pkgrel = 2
+ pkgver = 133.r30.g9fb87dc0c
+ pkgrel = 1
url = https://ares-emu.net/
install = ares.install
arch = x86_64
@@ -26,6 +26,6 @@ pkgbase = ares-emu-git
source = git+https://github.com/ares-emulator/ares.git
source = ares-paths.patch
sha256sums = SKIP
- sha256sums = cd3a069e0b67ba192a8fbf96575fc64e2cb863e060e20a13d2dba09f7ef867ce
+ sha256sums = 60e6c9424680a16868098721a8238c8407a0e1a6cc5437a8306d36d66ec6a3ce
pkgname = ares-emu-git
diff --git a/PKGBUILD b/PKGBUILD
index c33ce1988048..384d2cd78678 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Snowstorm64
pkgname=ares-emu-git
-pkgver=132.r129.g5f9804fb6
-pkgrel=2
+pkgver=133.r30.g9fb87dc0c
+pkgrel=1
pkgdesc="Cross-platform, open source, multi-system emulator by Near and Ares team, focusing on accuracy and preservation. (git version)"
arch=(x86_64 i686)
url="https://ares-emu.net/"
@@ -15,7 +15,7 @@ install=ares.install
source=("git+https://github.com/ares-emulator/ares.git"
"ares-paths.patch")
sha256sums=("SKIP"
- "cd3a069e0b67ba192a8fbf96575fc64e2cb863e060e20a13d2dba09f7ef867ce")
+ "60e6c9424680a16868098721a8238c8407a0e1a6cc5437a8306d36d66ec6a3ce")
pkgver() {
cd "${srcdir}/ares"
@@ -23,7 +23,7 @@ pkgver() {
}
prepare() {
- # Patch Ares so that it can look for its resources, that are installed in its shared data directory
+ # For time being patch Ares so that it copies settings.bml, if applicable, from old location to default location
patch -Np1 -i "${srcdir}/ares-paths.patch"
}
diff --git a/ares-paths.patch b/ares-paths.patch
index b56594c29858..499e71911b33 100644
--- a/ares-paths.patch
+++ b/ares-paths.patch
@@ -1,44 +1,13 @@
diff --git a/ares/desktop-ui/desktop-ui.cpp b/ares/desktop-ui/desktop-ui.cpp
-@@ -26,10 +26,20 @@
- location = {Path::userData(), "ares/", name};
- if(inode::exists(location)) return location;
-
-- // On non-windows platforms, after exhausting other options,
-- // default to userData, on Windows, default to program dir
-+ // On non-windows platforms, this time check the shared
-+ // data directory, on Windows, default to program dir,
- // this ensures Portable mode is the default on Windows platforms.
+@@ -32,6 +32,11 @@
#if !defined(PLATFORM_WINDOWS)
-+ string shared_location = {Path::sharedData(), "ares/", name};
-+ if(inode::exists(shared_location)) return shared_location;
+ string shared_location = {Path::sharedData(), "ares/", name};
+ if(inode::exists(shared_location)) return shared_location;
+
+ // XXX: Change settings.bml location to match Ares' default behavior.
+ if(directory::exists({Path::userSettings(), "ares/"})) {
+ file::copy({Path::userSettings(), "ares/settings.bml"}, {Path::userData(), "ares/settings.bml"});
+ }
-+
-+ // On non-windows platforms, after exhausting other options,
-+ // default to userData.
- directory::create({Path::userData(), "ares/"});
- return {Path::userData(), "ares/", name};
- #else
-
-diff --git a/ares/mia/mia.cpp b/ares/mia/mia.cpp
-@@ -26,10 +26,15 @@
- location = {Path::userData(), "ares/", name};
- if(inode::exists(location)) return location;
-- // On non-windows platforms, after exhausting other options,
-- // default to userData, on Windows, default to program dir
-+ // On non-windows platforms, this time check the shared
-+ // data directory, on Windows, default to program dir
- // this ensures Portable mode is the default on Windows platforms.
- #if !defined(PLATFORM_WINDOWS)
-+ string shared_location = {Path::sharedData(), "ares/", name};
-+ if(inode::exists(shared_location)) return shared_location;
-+
-+ // On non-windows platforms, after exhausting other options,
-+ // default to userData
- directory::create({Path::userData(), "ares/"});
- return {Path::userData(), "ares/", name};
- #else
+ // On non-windows platforms, after exhausting other options,
+ // default to userData.