summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMastergatto2024-02-21 21:15:27 +0100
committerMastergatto2024-02-21 21:15:27 +0100
commitafaddbfd78c3170fa7eab8822b9dd6ad226af322 (patch)
tree087f32bf478b3f1fd4abd18fd03b9b00de7c1cdd
parent80d70690eed4d336fe22330ffcd251712b58d613 (diff)
downloadaur-afaddbfd78c3170fa7eab8822b9dd6ad226af322.tar.gz
Drop patch.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
-rw-r--r--ares.install10
3 files changed, 11 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bfe726dbbcd9..9465643ffd8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ares-emu-git
pkgdesc = Cross-platform, open source, multi-system emulator by Near and Ares team, focusing on accuracy and preservation. (git version)
- pkgver = 133.r30.g9fb87dc0c
+ pkgver = 135.r47.g5cdefb088
pkgrel = 1
url = https://ares-emu.net/
install = ares.install
@@ -24,8 +24,6 @@ pkgbase = ares-emu-git
provides = ares-emu
conflicts = ares-emu
source = git+https://github.com/ares-emulator/ares.git
- source = ares-paths.patch
sha256sums = SKIP
- sha256sums = 60e6c9424680a16868098721a8238c8407a0e1a6cc5437a8306d36d66ec6a3ce
pkgname = ares-emu-git
diff --git a/PKGBUILD b/PKGBUILD
index 384d2cd78678..fbd6a456fbc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,25 @@
# Maintainer: Snowstorm64
pkgname=ares-emu-git
-pkgver=133.r30.g9fb87dc0c
+pkgver=135.r47.g5cdefb088
pkgrel=1
pkgdesc="Cross-platform, open source, multi-system emulator by Near and Ares team, focusing on accuracy and preservation. (git version)"
arch=(x86_64 i686)
url="https://ares-emu.net/"
license=("ISC")
-depends=(gtk3 libao libgl libpulse libudev.so=1-64 libxv openal sdl2 vulkan-driver vulkan-icd-loader)
+depends=(gtk3 libao libgl libpulse libudev.so=1-64 libxv openal sdl2 vulkan-driver vulkan-icd-loader) #TODO: require librashader soon
makedepends=(mesa git clang lld)
provides=(ares-emu)
conflicts=(ares-emu)
install=ares.install
-source=("git+https://github.com/ares-emulator/ares.git"
- "ares-paths.patch")
-sha256sums=("SKIP"
- "60e6c9424680a16868098721a8238c8407a0e1a6cc5437a8306d36d66ec6a3ce")
+source=("git+https://github.com/ares-emulator/ares.git")
+sha256sums=("SKIP")
pkgver() {
cd "${srcdir}/ares"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- # For time being patch Ares so that it copies settings.bml, if applicable, from old location to default location
- patch -Np1 -i "${srcdir}/ares-paths.patch"
-}
-
build() {
# If you want to build with gcc, edit to use g++ instead of clang++
make -C "${srcdir}/ares/desktop-ui" hiro=gtk3 compiler=clang++
@@ -41,5 +34,6 @@ package() {
# Also install shaders and databases in Ares' shared data directory
install -dm 755 "${pkgdir}/usr/share/ares"
cp -dr --no-preserve=ownership "${srcdir}/ares/ares/Shaders/" "${pkgdir}/usr/share/ares/Shaders/"
+ #cp -dr --no-preserve=ownership "${srcdir}/ares/thirdparty/slang-shaders/" "${pkgdir}/usr/share/ares/Shaders/"
cp -dr --no-preserve=ownership "${srcdir}/ares/mia/Database/" "${pkgdir}/usr/share/ares/Database/"
}
diff --git a/ares.install b/ares.install
index f92e5ab49ad8..b156a666f5b2 100644
--- a/ares.install
+++ b/ares.install
@@ -3,11 +3,11 @@ post_upgrade() {
********************************************************************************
* Wanting to be as close as possible to Ares vanilla, the location *
* of settings files has been changed from *
-* $XDG_CONFIG_HOME (likely ~/.config/ares/settings.bml) to the default *
-* $XDG_DATA_HOME (likely ~/.local/share/ares/settings.bml). *
-* Ares will attempt to copy this file to the new location but success is not *
-* guaranteed, so please check whether the settings are successfully copied. *
-* After which, the file in old location can be safely removed. *
+* $XDG_CONFIG_HOME *
+* to the default *
+* $XDG_DATA_HOME . *
+* Should you read this message, please move the file settings.bml to the new *
+* location. Once done, only then ares can start with your customized settings. *
********************************************************************************
EOF
fi