summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipe Nascimento2024-01-22 14:59:21 -0300
committerFilipe Nascimento2024-01-22 14:59:21 -0300
commita62a2c4a47fbad6ba6d177b71d9c130ec2c2a7f3 (patch)
treeb96a98158c1597dcc3a41ba270359896b030e630
parent0431d2b2c70be70dda86737eca13025ed2c1017f (diff)
downloadaur-aria2p.tar.gz
upgpkg: aria2p 0.12.0-1
upstream release
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35e4073f6c4e..0f7c6f983b28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
pkgbase = aria2p
pkgdesc = Command-line tool and library to interact with an aria2c daemon process with JSON-RPC
- pkgver = 0.11.3
- pkgrel = 2
+ pkgver = 0.12.0
+ pkgrel = 1
url = https://pawamoy.github.io/showcase/aria2p
arch = any
license = ISC
makedepends = python-build
makedepends = python-installer
- makedepends = python-pdm-pep517
+ makedepends = python-pdm-backend
depends = python-appdirs
depends = python-loguru
depends = python-requests
- depends = python-toml
depends = python-websocket-client
optdepends = aria2: aria2c daemon
optdepends = python-asciimatics: interactive interface support
optdepends = python-pyperclip: interactive interface support
- source = https://files.pythonhosted.org/packages/source/a/aria2p/aria2p-0.11.3.tar.gz
- sha256sums = 517667f7b38adde8826908d6b6fbbf862a3066a56415e0fd2fd3ba61dc9cd19d
+ source = https://files.pythonhosted.org/packages/source/a/aria2p/aria2p-0.12.0.tar.gz
+ sha256sums = ac42d2b67b819994df75c79be461ee6adf71be8616105275bce7e8794372c0b7
pkgname = aria2p
diff --git a/PKGBUILD b/PKGBUILD
index 889b9a897daa..737180cea613 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,19 @@
# Maintainer: Filipe Nascimento <flipee at tuta dot io>
pkgname=aria2p
-pkgver=0.11.3
-pkgrel=2
+pkgver=0.12.0
+pkgrel=1
pkgdesc="Command-line tool and library to interact with an aria2c daemon process with JSON-RPC"
arch=('any')
url="https://pawamoy.github.io/showcase/aria2p"
license=('ISC')
-depends=('python-appdirs' 'python-loguru' 'python-requests'
- 'python-toml' 'python-websocket-client' )
-makedepends=('python-build' 'python-installer' 'python-pdm-pep517')
+depends=('python-appdirs' 'python-loguru' 'python-requests' 'python-websocket-client' )
+makedepends=('python-build' 'python-installer' 'python-pdm-backend')
optdepends=('aria2: aria2c daemon'
'python-asciimatics: interactive interface support'
'python-pyperclip: interactive interface support')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=('517667f7b38adde8826908d6b6fbbf862a3066a56415e0fd2fd3ba61dc9cd19d')
+sha256sums=('ac42d2b67b819994df75c79be461ee6adf71be8616105275bce7e8794372c0b7')
build() {
cd $pkgname-$pkgver