summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilken Gottwalt2024-05-07 14:01:59 +0200
committerWilken Gottwalt2024-05-07 14:01:59 +0200
commit9a86457c753b9f2d9ec2f1402263b5b8dc1f57f4 (patch)
tree0d190fdf1d355ec59a187d87f9bbcbeaa6992fad
parentfc5d6404560d7568faeee8f9891bf169cd8778ca (diff)
downloadaur-arm-linux-gnueabihf-gcc.tar.gz
update to version 14.1.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c5f67f5a885..3e349d7b203f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = arm-linux-gnueabihf-gcc
pkgdesc = The GNU Compiler Collection
- pkgver = 13.2.0
- pkgrel = 11
+ pkgver = 14.1.0
+ pkgrel = 1
url = https://gcc.gnu.org
arch = x86_64
license = GPL
@@ -19,8 +19,8 @@ pkgbase = arm-linux-gnueabihf-gcc
depends = elfutils
depends = zlib
depends = zstd
- provides = arm-linux-gnueabihf-gcc-stage1=13.2.0
- provides = arm-linux-gnueabihf-gcc-stage2=13.2.0
+ provides = arm-linux-gnueabihf-gcc-stage1=14.1.0
+ provides = arm-linux-gnueabihf-gcc-stage2=14.1.0
conflicts = arm-linux-gnueabihf-gcc-stage1
conflicts = arm-linux-gnueabihf-gcc-stage2
replaces = arm-linux-gnueabihf-gcc-stage1
@@ -29,8 +29,8 @@ pkgbase = arm-linux-gnueabihf-gcc
options = !distcc
options = !strip
options = lto
- source = https://sourceware.org/pub/gcc/releases/gcc-13.2.0/gcc-13.2.0.tar.xz
- source = https://sourceware.org/pub/gcc/releases/gcc-13.2.0/gcc-13.2.0.tar.xz.sig
+ source = https://sourceware.org/pub/gcc/releases/gcc-14.1.0/gcc-14.1.0.tar.xz
+ source = https://sourceware.org/pub/gcc/releases/gcc-14.1.0/gcc-14.1.0.tar.xz.sig
source = https://gmplib.org/download/gmp/gmp-6.3.0.tar.xz
source = https://gmplib.org/download/gmp/gmp-6.3.0.tar.xz.sig
source = https://libisl.sourceforge.io/isl-0.26.tar.xz
@@ -43,7 +43,7 @@ pkgbase = arm-linux-gnueabihf-gcc
validpgpkeys = D3A93CAD751C2AF4F8C7AD516C35B99309B5FA62
validpgpkeys = 343C2FF0FBEE5EC2EDBEF399F3599FF828C67298
validpgpkeys = A534BE3F83E241D918280AEB5831D11A0D4DB02A
- sha256sums = e275e76442a6067341a27f04c5c6b83d8613144004c0413528863dc6b5c743da
+ sha256sums = e283c654987afe3de9d8080bc0bd79534b5ca0d681a73a11ff2b5d3767426840
sha256sums = SKIP
sha256sums = a3c2b80201b89e68616f4ad30bc66aee4927c3ce50e33929ca819d5c43538898
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d2724fff5cda..7dedb81fb466 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,13 @@
_target=arm-linux-gnueabihf
pkgname="${_target}-gcc"
-pkgver=13.2.0
+pkgver=14.1.0
_majorver=${pkgver%%.*}
_gmpver=6.3.0
_islver=0.26
_mpcver=1.3.1
_mpfrver=4.2.1
-pkgrel=11
+pkgrel=1
pkgdesc="The GNU Compiler Collection"
arch=(x86_64)
license=(GPL LGPL FDL custom)
@@ -36,7 +36,7 @@ validpgpkeys=(F3691687D867B81B51CE07D9BBE43771487328A9 # bpiotrowski@archlinux.
D3A93CAD751C2AF4F8C7AD516C35B99309B5FA62 # jakub@redhat.com
343C2FF0FBEE5EC2EDBEF399F3599FF828C67298 # nisse@lysator.liu.se
A534BE3F83E241D918280AEB5831D11A0D4DB02A) # vincent@vinc17.net
-sha256sums=('e275e76442a6067341a27f04c5c6b83d8613144004c0413528863dc6b5c743da'
+sha256sums=('e283c654987afe3de9d8080bc0bd79534b5ca0d681a73a11ff2b5d3767426840'
'SKIP'
'a3c2b80201b89e68616f4ad30bc66aee4927c3ce50e33929ca819d5c43538898'
'SKIP'
@@ -53,9 +53,7 @@ prepare() {
mv ../mpc-${_mpcver} mpc
mv ../mpfr-${_mpfrver} mpfr
- echo "${pkgver}" > gcc/BASE-VER
-
- # do not run fixincludes
+ #echo "${pkgver}" > gcc/BASE-VER
sed -i 's@\./fixinc\.sh@-c true@' gcc/Makefile.in
mkdir -p "${srcdir}"/gcc-build