summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChrister Solskogen2023-01-07 11:56:43 +0000
committerChrister Solskogen2023-01-07 11:56:43 +0000
commit17180fb52acc380828a2a3bd9cbc8c903b052fe9 (patch)
tree25a89bbe811d3c74101ca3493d2477756072df70
parentd783ce6e759db16b37ca940742988153086b3561 (diff)
downloadaur-armv7l-gcc-bootstrap.tar.gz
switch to using git
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD54
2 files changed, 27 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a624ed2478a8..35dc9d7560f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = armv7l-gcc-bootstrap
- pkgdesc = The GNU Compiler Collection - cross compiler for armv7l
- pkgver = 12.2.0
- pkgrel = 0
+ pkgdesc = The GNU Compiler Collection - cross compiler for ARM64 target - bootstrap compiler
+ pkgver = 12.2.1
+ pkgrel = 3
url = https://gcc.gnu.org/
arch = x86_64
license = GPL
license = LGPL
license = FDL
makedepends = armv7l-binutils
+ makedepends = git
depends = libmpc
depends = zstd
depends = libisl
@@ -16,13 +17,11 @@ pkgbase = armv7l-gcc-bootstrap
options = !emptydirs
options = !strip
options = staticlibs
- source = https://ftp.gnu.org/gnu/gcc/gcc-12.2.0/gcc-12.2.0.tar.xz
- source = https://ftp.gnu.org/gnu/gcc/gcc-12.2.0/gcc-12.2.0.tar.xz.sig
+ source = git+https://sourceware.org/git/gcc.git#commit=6b1adeb22789e190e87b905761f8a47a2e4e830a
validpgpkeys = F3691687D867B81B51CE07D9BBE43771487328A9
validpgpkeys = 86CFFCA918CF3AF47147588051E8B148A9999C34
validpgpkeys = 13975A70E63C361C73AE69EF6EEB81F8981C74C7
validpgpkeys = D3A93CAD751C2AF4F8C7AD516C35B99309B5FA62
- sha256sums = e549cf9cf3594a00e27b6589d4322d70e0720cdd213f39beb4181e06926230ff
sha256sums = SKIP
pkgname = armv7l-gcc-bootstrap
diff --git a/PKGBUILD b/PKGBUILD
index 0ccbb4b863a3..a9922bf1ce71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,38 +4,30 @@
_arch=armv7l
_target=$_arch-unknown-linux-gnueabihf
pkgname=$_arch-gcc-bootstrap
-pkgver=12.2.0
-pkgrel=0
-pkgdesc='The GNU Compiler Collection - cross compiler for armv7l'
+pkgver=12.2.1
+pkgrel=3
+pkgdesc='The GNU Compiler Collection - cross compiler for ARM64 target - bootstrap compiler'
arch=(x86_64)
url='https://gcc.gnu.org/'
license=(GPL LGPL FDL)
depends=(libmpc zstd libisl)
-makedepends=($_arch-binutils)
+makedepends=($_arch-binutils git)
provides=($_arch-gcc)
conflicts=($_arch-gcc)
options=(!emptydirs !strip staticlibs)
-source=(https://ftp.gnu.org/gnu/gcc/gcc-$pkgver/gcc-$pkgver.tar.xz{,.sig}
-)
+_commit=6b1adeb22789e190e87b905761f8a47a2e4e830a
+source=(git+https://sourceware.org/git/gcc.git#commit=${_commit})
-sha256sums=('e549cf9cf3594a00e27b6589d4322d70e0720cdd213f39beb4181e06926230ff'
- 'SKIP')
+sha256sums=('SKIP')
-validpgpkeys=('F3691687D867B81B51CE07D9BBE43771487328A9' # bpiotrowski@archlinux.org
- '86CFFCA918CF3AF47147588051E8B148A9999C34' # evangelos@foutrelis.com
- '13975A70E63C361C73AE69EF6EEB81F8981C74C7' # richard.guenther@gmail.com
- 'D3A93CAD751C2AF4F8C7AD516C35B99309B5FA62') # Jakub Jelinek <jakub@redhat.com>
-
-
-
-if [ -n "$_snapshot" ]; then
- _basedir=gcc-$_snapshot
-else
- _basedir=gcc-$pkgver
-fi
+validpgpkeys=(F3691687D867B81B51CE07D9BBE43771487328A9 # bpiotrowski@archlinux.org
+ 86CFFCA918CF3AF47147588051E8B148A9999C34 # evangelos@foutrelis.com
+ 13975A70E63C361C73AE69EF6EEB81F8981C74C7 # richard.guenther@gmail.com
+ D3A93CAD751C2AF4F8C7AD516C35B99309B5FA62) # Jakub Jelinek <jakub@redhat.com>
prepare() {
- cd $_basedir
+ [[ ! -d gcc ]] && ln -s gcc-${pkgver/+/-} gcc
+ cd gcc
rm -rf "$srcdir"/gcc-build
mkdir "$srcdir"/gcc-build
@@ -43,24 +35,23 @@ prepare() {
build() {
cd gcc-build
+
+ # Credits @allanmcrae
+ # https://github.com/allanmcrae/toolchain/blob/f18604d70c5933c31b51a320978711e4e6791cf1/gcc/PKGBUILD
+ # TODO: properly deal with the build issues resulting from this
CFLAGS=${CFLAGS/-Werror=format-security/}
CXXFLAGS=${CXXFLAGS/-Werror=format-security/}
- "$srcdir"/$_basedir/configure \
+ "$srcdir"/gcc/configure \
--prefix=/usr \
--with-sysroot=/usr/$_target/sys-root \
--libexecdir=/usr/lib \
--target=$_target \
- --disable-nls --enable-default-pie \
- --enable-languages=c,c++ \
- --with-system-zlib --enable-__cxa_atexit \
- --enable-linker-build-id \
- --enable-plugin \
- --with-linker-hash-style=gnu --enable-gnu-indirect-function \
+ --disable-nls \
+ --enable-languages=c \
+ --with-system-zlib \
--disable-multilib --disable-werror \
- --enable-checking=release --enable-host-shared \
- --with-arch=armv7-a --with-float=hard --with-fpu=vfpv3-d16 \
- --disable-threads --without-headers --with-glibc-version=2.34 \
+ --disable-threads --without-headers \
--disable-shared --with-newlib
make all-gcc all-target-libgcc
@@ -70,7 +61,6 @@ package() {
cd gcc-build
make install-strip-gcc install-strip-target-libgcc DESTDIR="$pkgdir"
- ln -s $_target-gcc "$pkgdir"/usr/bin/$_target-cc
# Remove files that conflict with host gcc package
rm -r "$pkgdir"/usr/{include,share}