summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-05-14 12:14:12 +0000
committerBioArchLinuxBot2023-05-14 12:14:12 +0000
commiteefbbd9325ff56bac4a7b698b3895cc9fb7cebf8 (patch)
tree6ff8634142662ecf9c8d35c329eafdcfb2c6bd7d
parentdb7e98f9a66f7861411c7167b2b0b5320e55ecfc (diff)
downloadaur-artemis.tar.gz
[lilac] updated to 18.2.0-6
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD82
-rwxr-xr-xact.desktop16
-rwxr-xr-xartemis.desktop16
-rwxr-xr-xbamview.desktop16
-rwxr-xr-xdnaplotter.desktop16
-rw-r--r--fix_bin.patch362
-rw-r--r--readme5
8 files changed, 508 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93e3fb295878..bcfc4e5713a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,22 @@
pkgbase = artemis
pkgdesc = A genome viewer and annotation tool that visualizes biological sequence features
pkgver = 18.2.0
- pkgrel = 5
+ pkgrel = 6
url = https://www.sanger.ac.uk/science/tools/artemis
arch = x86_64
license = GPL2
- depends = java-runtime>=1.6
- source = artemis-18.2.0.tar.gz::https://github.com/sanger-pathogens/Artemis/releases/download/v18.2.0/artemis-unix-release-18.2.0.tar.gz
- sha256sums = 06441e1abab139cb0a09d5844cb1b84ae727ace53a6c0efdd1eea8d8cfab8382
+ makedepends = java-environment
+ makedepends = maven
+ depends = java-runtime
+ source = artemis-18.2.0.tar.gz::https://github.com/sanger-pathogens/Artemis/archive/refs/tags/v18.2.0.tar.gz
+ source = act.desktop
+ source = artemis.desktop
+ source = bamview.desktop
+ source = dnaplotter.desktop
+ sha256sums = 842c055f5cce021adbaea4f076b2ea80335ab1e44fbaa34b2ab608df6314a18e
+ sha256sums = a7dda77f6518c98af6df88ba5d725f1b89d86aca125240f63a9c6e08afeb2a24
+ sha256sums = dea9a1cc47b110c4f6ebe17c1b698866082997ffd9e6008d89847ddf745a0789
+ sha256sums = 3ca519b00ffac02d635a62884996ad5b8c4580d8ffe8fcd427ee4edee1562f00
+ sha256sums = ef584b45f9c92da15511779f20a1a1449915315066662e4c142ea4cd92dd717c
pkgname = artemis
diff --git a/PKGBUILD b/PKGBUILD
index fcda9d3fb731..97f1cc5a214f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,75 @@
-# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+# Contributor: Clint Valentine <valentine.clint@gmail.com>
-pkgname='artemis'
+pkgname=artemis
+_pkgname=Artemis
pkgver=18.2.0
-pkgrel=5
+pkgrel=6
pkgdesc='A genome viewer and annotation tool that visualizes biological sequence features'
arch=('x86_64')
url=https://www.sanger.ac.uk/science/tools/"${pkgname}"
license=('GPL2')
-depends=('java-runtime>=1.6')
-source=("${pkgname}"-"${pkgver}".tar.gz::https://github.com/sanger-pathogens/Artemis/releases/download/v${pkgver}/artemis-unix-release-${pkgver}.tar.gz)
-sha256sums=('06441e1abab139cb0a09d5844cb1b84ae727ace53a6c0efdd1eea8d8cfab8382')
-
+depends=('java-runtime')
+makedepends=('java-environment' 'maven')
+source=($pkgname-$pkgver.tar.gz::https://github.com/sanger-pathogens/Artemis/archive/refs/tags/v${pkgver}.tar.gz
+ act.desktop
+ artemis.desktop
+ bamview.desktop
+ dnaplotter.desktop)
+sha256sums=('842c055f5cce021adbaea4f076b2ea80335ab1e44fbaa34b2ab608df6314a18e'
+ 'a7dda77f6518c98af6df88ba5d725f1b89d86aca125240f63a9c6e08afeb2a24'
+ 'dea9a1cc47b110c4f6ebe17c1b698866082997ffd9e6008d89847ddf745a0789'
+ '3ca519b00ffac02d635a62884996ad5b8c4580d8ffe8fcd427ee4edee1562f00'
+ 'ef584b45f9c92da15511779f20a1a1449915315066662e4c142ea4cd92dd717c')
+#prepare() {
+#scripts=('act' 'art' 'bamview' 'dnaplotter')
+# cd $srcdir/$_pkgname-$pkgver
+# patch -N -i $srcdir/fix_bin.patch
+#}
+build() {
+ cd $srcdir/$_pkgname-$pkgver
+ mvn validate
+ mvn package
+}
package() {
- cd "${srcdir}"/"${pkgname}"
+bina=('act' 'art' 'bamview' 'dnaplotter')
+scripts=('act' 'artemis' 'bamview' 'dnaplotter')
+
+ # desktop
+ cd $srcdir/
+ for des in ${scripts[@]}
+do
+ install -Dm 755 $des.desktop $pkgdir/usr/share/applications/$des.desktop
+done
+
+ # bin
+ cd $srcdir/$_pkgname-$pkgver
+ for bin in ${bina[@]}
+do
+ install -Dm 775 $bin $pkgdir/usr/share/$pkgname/$bin
+done
- sed -i 's#ARTEMIS_HOME=`dirname "$PRG"`/.#ARTEMIS_HOME=/opt/artemis/#' art
- sed -i 's#ACT_HOME=`dirname "$PRG"`/.#ACT_HOME=/opt/artemis/#' act
- sed -i 's#ARTEMIS_HOME=`dirname "$PRG"`/.#ARTEMIS_HOME=/opt/artemis/#' dnaplotter
+ # jar
+ cd $srcdir/$_pkgname-$pkgver/target/jars
+ for jar in $(ls *.jar)
+do
+ install -Dm 755 $jar $pkgdir/usr/share/$pkgname/target/jars/$jar
+done
- mkdir -p "${pkgdir}"/opt/"${pkgname}"/
- cp -a * "${pkgdir}"/opt/"${pkgname}"/
+ # icons
+ cd $srcdir/$_pkgname-$pkgver/target/classes/images
+ for icn in ${scripts[@]}
+do
+ mv ${icn}_icon.png ${icn}.png
+ install -Dm 644 ${icn}.png $pkgdir/usr/share/pixmaps/${icn}.png
+done
- scripts=('act' 'art' 'dnaplotter')
- for script in "${scripts[@]}"; do
- install -Dm775 "${script}" "${pkgdir}"/usr/bin/"${script}"
- rm "${pkgdir}"/opt/"${pkgname}"/"${script}"
- done
+ # link bin
+ cd $srcdir/$_pkgname-$pkgver
+ mkdir -p $pkgdir/usr/bin
+ for bin in ${bina[@]}
+do
+ ln -s /usr/share/$pkgname/$bin $pkgdir/usr/bin/$bin
+done
- install -Dm644 README.md "${pkgdir}"/usr/share/doc/"${pkgname}"/README.md
}
diff --git a/act.desktop b/act.desktop
new file mode 100755
index 000000000000..1eee89974535
--- /dev/null
+++ b/act.desktop
@@ -0,0 +1,16 @@
+[Desktop Entry]
+Categories=
+Encoding=UTF-8
+Exec=act
+GenericName=
+Icon=act
+MimeType=
+Name=act
+ServiceTypes=
+SwallowExec=
+SwallowTitle=
+Terminal=false
+TerminalOptions=
+Type=Application
+X-KDE-SubstituteUID=false
+X-KDE-Username=root
diff --git a/artemis.desktop b/artemis.desktop
new file mode 100755
index 000000000000..4237a47be88c
--- /dev/null
+++ b/artemis.desktop
@@ -0,0 +1,16 @@
+[Desktop Entry]
+Categories=
+Encoding=UTF-8
+Exec=art
+GenericName=
+Icon=artemis
+MimeType=
+Name=artemis
+ServiceTypes=
+SwallowExec=
+SwallowTitle=
+Terminal=false
+TerminalOptions=
+Type=Application
+X-KDE-SubstituteUID=false
+X-KDE-Username=root
diff --git a/bamview.desktop b/bamview.desktop
new file mode 100755
index 000000000000..129dfa286141
--- /dev/null
+++ b/bamview.desktop
@@ -0,0 +1,16 @@
+[Desktop Entry]
+Categories=
+Encoding=UTF-8
+Exec=bamview
+GenericName=
+Icon=bamview
+MimeType=
+Name=bamview
+ServiceTypes=
+SwallowExec=
+SwallowTitle=
+Terminal=false
+TerminalOptions=
+Type=Application
+X-KDE-SubstituteUID=false
+X-KDE-Username=root
diff --git a/dnaplotter.desktop b/dnaplotter.desktop
new file mode 100755
index 000000000000..2261a0c83924
--- /dev/null
+++ b/dnaplotter.desktop
@@ -0,0 +1,16 @@
+[Desktop Entry]
+Categories=
+Encoding=UTF-8
+Exec=dnaplotter
+GenericName=
+Icon=dnaplotter
+MimeType=
+Name=dnaplotter
+ServiceTypes=
+SwallowExec=
+SwallowTitle=
+Terminal=false
+TerminalOptions=
+Type=Application
+X-KDE-SubstituteUID=false
+X-KDE-Username=root
diff --git a/fix_bin.patch b/fix_bin.patch
new file mode 100644
index 000000000000..fae90595b9ed
--- /dev/null
+++ b/fix_bin.patch
@@ -0,0 +1,362 @@
+Description: Simplifying the provided launchers
+ Many options or tricks are useless on a Debian system.
+ The paths are also adapted to the Debian install.
+Author: Pierre Gruet <pgt@debian.org>
+Forwarded: not-needed
+Last-Update: 2020-09-06
+
+--- a/act
++++ b/act
+@@ -38,36 +38,6 @@
+ exit 0
+ }
+
+-add_proxy_properties() {
+-
+- if [[ "$http_proxy" = "" ]]
+- then
+- http_proxy=$HTTP_PROXY
+- fi
+-
+- if [[ "$http_proxy" = "" ]]
+- then
+- http_proxy=$HTTP_proxy
+- fi
+-
+- if [[ "$http_proxy" != "" ]]
+- then
+- APPLICATION_PROPERTIES="$APPLICATION_PROPERTIES -DproxySet=true "`echo $http_proxy | sed 's/http:\/\/\(.*\):\(.*\)/ -Dhttp.proxyHost=\1 -Dhttp.proxyPort=\2/'`
+- fi
+-}
+-
+-#
+-# Resolve script path (inc symlinks)
+-#
+-SOURCE="${BASH_SOURCE[0]}"
+-while [ -h "$SOURCE" ]; do # resolve $SOURCE until the file is no longer a symlink
+- DIR="$( cd -P "$( dirname "$SOURCE" )" && pwd )"
+- SOURCE="$(readlink "$SOURCE")"
+- [[ $SOURCE != /* ]] && SOURCE="$DIR/$SOURCE" # if $SOURCE was a relative symlink, we need to resolve it relative to the path where the symlink file was located
+-done
+-APPLICATION_HOME="$( cd -P "$( dirname "$SOURCE" )" && pwd )"; # get final path of this script
+-
+-
+ # Special Sanger override on chado PGUSER
+ if [[ "$ARTEMIS_SANGER_DBUSER" != "" ]]
+ then
+@@ -93,28 +63,6 @@
+ shift
+ done
+
+-
+-JAR_NAME=act.jar
+-JAR_FILE_DEFAULT=$APPLICATION_HOME/target/jars/$JAR_NAME
+-JAR_FILE_INSTALLED=$APPLICATION_HOME/dist/$JAR_NAME
+-ARTEMIS_CP=$APPLICATION_HOME:$JAR_FILE_DEFAULT:$JAR_FILE_INSTALLED
+-
+-#
+-# Use a custom Java version if necessary
+-#
+-if [[ "$ARTEMIS_JAVA_JRE" = "" ]]
+-then
+- JAVA=`which java`
+-else
+- JAVA_HOME=$ARTEMIS_JAVA_JRE
+- JAVA=$ARTEMIS_JAVA_JRE/bin/java
+-fi
+-
+-#
+-# Allow URLs to work from behind firewalls.
+-#
+-add_proxy_properties
+-
+ #
+ # "-mx2g" sets the maximum amount of memory to use.
+ # This may need to be increased when dealing with large files
+@@ -132,20 +80,12 @@
+ #
+ FLAGS="$FLAGS --add-opens=java.base/java.lang=ALL-UNNAMED --add-opens=java.base/java.util=ALL-UNNAMED"
+
+-PLATTMP=`uname`
+-if [[ "$PLATTMP" = "Darwin" ]]
+-then
+- APPLICATION_PROPERTIES="$APPLICATION_PROPERTIES -Dapple.laf.useScreenMenuBar=true -Xdock:name=ACT"
+- JAR_FILE_MACAPP=$APPLICATION_HOME/Java/$JAR_NAME
+- ARTEMIS_CP="$JAR_FILE_MACAPP:$ARTEMIS_CP"
+-fi
+-
+ if [[ "$QUIET" = no ]]
+ then
+ echo "Starting ACT with arguments: $FLAGS $APPLICATION_PROPERTIES $*"
+ fi
+
+-$JAVA $FLAGS $APPLICATION_PROPERTIES -cp "$ARTEMIS_CP" uk.ac.sanger.artemis.components.ActMain $*
++java $FLAGS $APPLICATION_PROPERTIES -jar /usr/share/artemis/act.jar $*
+ result=$?
+
+ exit $result
+--- a/art
++++ b/art
+@@ -44,36 +44,6 @@
+ exit 0
+ }
+
+-add_proxy_properties() {
+-
+- if [[ "$http_proxy" = "" ]]
+- then
+- http_proxy=$HTTP_PROXY
+- fi
+-
+- if [[ "$http_proxy" = "" ]]
+- then
+- http_proxy=$HTTP_proxy
+- fi
+-
+- if [[ "$http_proxy" != "" ]]
+- then
+- APPLICATION_PROPERTIES="$APPLICATION_PROPERTIES -DproxySet=true "`echo $http_proxy | sed 's/http:\/\/\(.*\):\(.*\)/ -Dhttp.proxyHost=\1 -Dhttp.proxyPort=\2/'`
+- fi
+-}
+-
+-#
+-# Resolve script path (inc symlinks)
+-#
+-SOURCE="${BASH_SOURCE[0]}"
+-while [ -h "$SOURCE" ]; do # resolve $SOURCE until the file is no longer a symlink
+- DIR="$( cd -P "$( dirname "$SOURCE" )" && pwd )"
+- SOURCE="$(readlink "$SOURCE")"
+- [[ $SOURCE != /* ]] && SOURCE="$DIR/$SOURCE" # if $SOURCE was a relative symlink, we need to resolve it relative to the path where the symlink file was located
+-done
+-APPLICATION_HOME="$( cd -P "$( dirname "$SOURCE" )" && pwd )"; # get final path of this script
+-
+-
+ # Special Sanger override on chado PGUSER
+ if [[ "$ARTEMIS_SANGER_DBUSER" != "" ]]
+ then
+@@ -99,28 +69,6 @@
+ shift
+ done
+
+-
+-JAR_NAME=artemis.jar
+-JAR_FILE_DEFAULT=$APPLICATION_HOME/target/jars/$JAR_NAME
+-JAR_FILE_INSTALLED=$APPLICATION_HOME/dist/$JAR_NAME
+-ARTEMIS_CP=$APPLICATION_HOME:$JAR_FILE_DEFAULT:$JAR_FILE_INSTALLED
+-
+-#
+-# Use a custom Java version if necessary
+-#
+-if [[ "$ARTEMIS_JAVA_JRE" = "" ]]
+-then
+- JAVA=`which java`
+-else
+- JAVA_HOME=$ARTEMIS_JAVA_JRE
+- JAVA=$ARTEMIS_JAVA_JRE/bin/java
+-fi
+-
+-#
+-# Allow URLs to work from behind firewalls.
+-#
+-add_proxy_properties
+-
+ #
+ # "-mx2g" sets the maximum amount of memory to use.
+ # This may need to be increased when dealing with large files
+@@ -139,20 +87,12 @@
+ #
+ FLAGS="$FLAGS --add-opens=java.base/java.lang=ALL-UNNAMED --add-opens=java.base/java.util=ALL-UNNAMED"
+
+-PLATTMP=`uname`
+-if [[ "$PLATTMP" = "Darwin" ]]
+-then
+- APPLICATION_PROPERTIES="$APPLICATION_PROPERTIES -Dapple.laf.useScreenMenuBar=true -Xdock:name=Artemis"
+- JAR_FILE_MACAPP=$APPLICATION_HOME/Java/$JAR_NAME
+- ARTEMIS_CP="$JAR_FILE_MACAPP:$ARTEMIS_CP"
+-fi
+-
+ if [[ "$QUIET" = "no" ]]
+ then
+ echo "Starting Artemis with arguments: $FLAGS $APPLICATION_PROPERTIES $*"
+ fi
+
+-$JAVA $FLAGS $APPLICATION_PROPERTIES -cp "$ARTEMIS_CP" uk.ac.sanger.artemis.components.ArtemisMain $*
++java $FLAGS $APPLICATION_PROPERTIES -jar /usr/share/artemis/artemis.jar $*
+ result=$?
+
+ exit $result
+--- a/bamview
++++ b/bamview
+@@ -6,57 +6,7 @@
+
+ QUIET=no
+
+-add_proxy_properties() {
+-
+- if [[ "$http_proxy" = "" ]]
+- then
+- http_proxy=$HTTP_PROXY
+- fi
+-
+- if [[ "$http_proxy" = "" ]]
+- then
+- http_proxy=$HTTP_proxy
+- fi
+-
+- if [[ "$http_proxy" != "" ]]
+- then
+- APPLICATION_PROPERTIES="$APPLICATION_PROPERTIES -DproxySet=true "`echo $http_proxy | sed 's/http:\/\/\(.*\):\(.*\)/ -Dhttp.proxyHost=\1 -Dhttp.proxyPort=\2/'`
+- fi
+-}
+-
+-#
+-# Resolve script path (inc symlinks)
+-#
+-SOURCE="${BASH_SOURCE[0]}"
+-while [ -h "$SOURCE" ]; do # resolve $SOURCE until the file is no longer a symlink
+- DIR="$( cd -P "$( dirname "$SOURCE" )" && pwd )"
+- SOURCE="$(readlink "$SOURCE")"
+- [[ $SOURCE != /* ]] && SOURCE="$DIR/$SOURCE" # if $SOURCE was a relative symlink, we need to resolve it relative to the path where the symlink file was located
+-done
+-APPLICATION_HOME="$( cd -P "$( dirname "$SOURCE" )" && pwd )"; # get final path of this script
+-
+-
+ APPLICATION_PROPERTIES="-Djdbc.drivers=org.postgresql.Driver -Dartemis.environment=UNIX $SANGER_ARTEMIS_OPTIONS"
+-JAR_NAME=bamview.jar
+-JAR_FILE_DEFAULT=$APPLICATION_HOME/target/jars/$JAR_NAME
+-JAR_FILE_INSTALLED=$APPLICATION_HOME/dist/$JAR_NAME
+-ARTEMIS_CP=$APPLICATION_HOME:$JAR_FILE_DEFAULT:$JAR_FILE_INSTALLED
+-
+-#
+-# Use a custom Java version if necessary
+-#
+-if [[ "$ARTEMIS_JAVA_JRE" = "" ]]
+-then
+- JAVA=`which java`
+-else
+- JAVA_HOME=$ARTEMIS_JAVA_JRE
+- JAVA=$ARTEMIS_JAVA_JRE/bin/java
+-fi
+-
+-#
+-# Allow URLs to work from behind firewalls.
+-#
+-add_proxy_properties
+
+ #
+ # "-mx2g" sets the maximum amount of memory to use.
+@@ -69,20 +19,12 @@
+ FLAGS="$ARTEMIS_JVM_FLAGS -noverify"
+ fi
+
+-PLATTMP=`uname`
+-if [[ "$PLATTMP" = "Darwin" ]]
+-then
+- APPLICATION_PROPERTIES="$APPLICATION_PROPERTIES -Xdock:name=BamView"
+- JAR_FILE_MACAPP=$APPLICATION_HOME/Java/$JAR_NAME
+- ARTEMIS_CP="$JAR_FILE_MACAPP:$ARTEMIS_CP"
+-fi
+-
+ if [[ "$QUIET" = "no" ]]
+ then
+ echo "Starting BamView with arguments: $FLAGS $APPLICATION_PROPERTIES $*"
+ fi
+
+-$JAVA $FLAGS $APPLICATION_PROPERTIES -cp "$ARTEMIS_CP" uk.ac.sanger.artemis.components.alignment.BamView $*
++java $FLAGS $APPLICATION_PROPERTIES -jar /usr/share/artemis/bamview.jar $*
+ result=$?
+
+ exit $result
+--- a/dnaplotter
++++ b/dnaplotter
+@@ -25,37 +25,6 @@
+ exit 0
+ }
+
+-add_proxy_properties() {
+-
+- if [[ "$http_proxy" = "" ]]
+- then
+- http_proxy=$HTTP_PROXY
+- fi
+-
+- if [[ "$http_proxy" = "" ]]
+- then
+- http_proxy=$HTTP_proxy
+- fi
+-
+- if [[ "$http_proxy" != "" ]]
+- then
+- APPLICATION_PROPERTIES="$APPLICATION_PROPERTIES -DproxySet=true "`echo $http_proxy | sed 's/http:\/\/\(.*\):\(.*\)/ -Dhttp.proxyHost=\1 -Dhttp.proxyPort=\2/'`
+- fi
+-}
+-
+-
+-#
+-# Resolve script path (inc symlinks)
+-#
+-SOURCE="${BASH_SOURCE[0]}"
+-while [ -h "$SOURCE" ]; do # resolve $SOURCE until the file is no longer a symlink
+- DIR="$( cd -P "$( dirname "$SOURCE" )" && pwd )"
+- SOURCE="$(readlink "$SOURCE")"
+- [[ $SOURCE != /* ]] && SOURCE="$DIR/$SOURCE" # if $SOURCE was a relative symlink, we need to resolve it relative to the path where the symlink file was located
+-done
+-APPLICATION_HOME="$( cd -P "$( dirname "$SOURCE" )" && pwd )"; # get final path of this script
+-
+-
+ #
+ # Parse arguments.
+ #
+@@ -75,28 +44,6 @@
+ shift
+ done
+
+-
+-JAR_NAME=dnaplotter.jar
+-JAR_FILE_DEFAULT=$APPLICATION_HOME/target/jars/$JAR_NAME
+-JAR_FILE_INSTALLED=$APPLICATION_HOME/dist/$JAR_NAME
+-ARTEMIS_CP=$APPLICATION_HOME:$JAR_FILE_DEFAULT:$JAR_FILE_INSTALLED
+-
+-#
+-# Use a custom Java version if necessary
+-#
+-if [[ "$ARTEMIS_JAVA_JRE" = "" ]]
+-then
+- JAVA=`which java`
+-else
+- JAVA_HOME=$ARTEMIS_JAVA_JRE
+- JAVA=$ARTEMIS_JAVA_JRE/bin/java
+-fi
+-
+-#
+-# Allow URLs to work from behind firewalls.
+-#
+-add_proxy_properties
+-
+ #
+ # "-mx2g" sets the maximum amount of memory to use.
+ # This may need to be increased when dealing with large files
+@@ -108,20 +55,12 @@
+ FLAGS="$ARTEMIS_JVM_FLAGS -noverify"
+ fi
+
+-PLATTMP=`uname`
+-if [[ "$PLATTMP" = "Darwin" ]]
+-then
+- APPLICATION_PROPERTIES="$APPLICATION_PROPERTIES -Dapple.laf.useScreenMenuBar=true -Xdock:name=Circular-Plot"
+- JAR_FILE_MACAPP=$APPLICATION_HOME/Java/$JAR_NAME
+- ARTEMIS_CP="$JAR_FILE_MACAPP:$ARTEMIS_CP"
+-fi
+-
+ if [[ "$QUIET" = "no" ]]
+ then
+ echo "Starting DNA Plotter with arguments: $FLAGS $APPLICATION_PROPERTIES $TEMPLATE_FILE_ARG"
+ fi
+
+-$JAVA $FLAGS $APPLICATION_PROPERTIES -cp "$ARTEMIS_CP" uk.ac.sanger.artemis.circular.DNADraw $TEMPLATE_FILE_ARG
++java $FLAGS $APPLICATION_PROPERTIES -jar /usr/share/artemis/dnaplotter.jar $TEMPLATE_FILE_ARG
+ result=$?
+
+ exit $result
+
+
diff --git a/readme b/readme
new file mode 100644
index 000000000000..29a8ebab5f14
--- /dev/null
+++ b/readme
@@ -0,0 +1,5 @@
+# Artemis
+
+ art and act shell script doesn't work.
+
+ Fix it and then this package can work