summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2017-06-13 03:16:40 -0700
committerDonald Carr2017-06-13 03:18:09 -0700
commit3ba8d8efd58eb594110fa09c9b642599dfe262a2 (patch)
tree31d5d0d6d2c05a2d7be7ce6492ac7d0d5b7c4273
parent1e7ccb9d0ceffb03c194a7334d49a217f38a97f0 (diff)
downloadaur-3ba8d8efd58eb594110fa09c9b642599dfe262a2.tar.gz
Adjust artriculate to package latest version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94996159bf90..c4e9a81abe3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Jun 13 03:33:57 UTC 2017
+# Tue Jun 13 10:18:07 UTC 2017
pkgbase = artriculate
pkgdesc = QML box2d application for displaying artwork
- pkgver = 0.4
+ pkgver = 0.4.r0.g9d27639
pkgrel = 1
url = https://github.com/sirspudd/artriculate
arch = any
@@ -10,7 +10,7 @@ pkgbase = artriculate
makedepends = qt-sdk-raspberry-pi
depends = qt-sdk-raspberry-pi-target-libs
options = !strip
- source = git://github.com/sirspudd/artriculate#tag=0.4
+ source = git://github.com/sirspudd/artriculate
sha256sums = SKIP
pkgname = artriculate
diff --git a/PKGBUILD b/PKGBUILD
index 59ea0d314078..ad63aab1cbe0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ fi
# Uncomment for a debug build
#_qmake_args="CONFIG+=debug"
pkgname=artriculate
-pkgver=0.4
+pkgver=0.4.r0.g9d27639
pkgrel=1
pkgdesc='QML box2d application for displaying artwork'
arch=('any')
@@ -22,10 +22,16 @@ url='https://github.com/sirspudd/artriculate'
license=('GPL3')
makedepends=("qt-sdk-raspberry-pi${_piver}")
depends=('qt-sdk-raspberry-pi-target-libs')
-source=("git://github.com/sirspudd/artriculate#tag=${pkgver}")
+source=("git://github.com/sirspudd/artriculate")
sha256sums=('SKIP')
options=('!strip')
+pkgver () {
+ cd "$srcdir/$pkgname"
+
+ git describe --tags --long | sed -r 's/^v//;s/-RC/RC/;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
build() {
cd "$srcdir"/"$pkgname"
$_qmake
@@ -35,13 +41,11 @@ build() {
package() {
local _repo_src=${srcdir}/${pkgname}
local _systemd_deploy_path=${pkgdir}/usr/lib/systemd/system
- local _qml_deploy_path=${pkgdir}/usr/share/${pkgname}
local _bin_path=${pkgdir}/usr/bin
mkdir -p $_systemd_deploy_path $_qml_deploy_path $_bin_path
cp ${_repo_src}/artriculate $_bin_path
cp ${_repo_src}/src/resources/*.service ${_systemd_deploy_path}
- cp -r ${_repo_src}/qml ${_qml_deploy_path}
cd ${_repo_src}
INSTALL_ROOT="$pkgdir" make install