summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Kundt2016-10-16 12:56:52 +0200
committerMarco Kundt2016-10-16 12:56:52 +0200
commit8f9d7a4e4edcfdb90d35a51f4610832126eafb7b (patch)
tree5ff37f5c48b8c5214bf11acb87b72168beea87f5
downloadaur-asem51.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD49
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bad422d8dc77
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Sun Oct 16 10:56:35 UTC 2016
+pkgbase = asem51
+ pkgdesc = ASEM-51 is a two-pass macro assembler for the Intel MCS-51 family of microcontrollers.
+ pkgver = 1.3
+ pkgrel = 1
+ url = http://plit.de/asem-51/home.htm
+ arch = i686
+ arch = x86_64
+ license = Custom
+ source = http://plit.de/asem-51/asem51-1.3-ELF.tar.gz
+ md5sums = 895fd5e6617f8b21b9f56484f9258c94
+
+pkgname = asem51
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..39d37457bd0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Marco Kundt <mrckndt@gmail.com>
+
+pkgname=asem51
+pkgver=1.3
+pkgrel=1
+pkgdesc="ASEM-51 is a two-pass macro assembler for the Intel MCS-51 family of
+microcontrollers."
+arch=('i686' 'x86_64')
+license=('Custom')
+url="http://plit.de/asem-51/home.htm"
+md5sums=('895fd5e6617f8b21b9f56484f9258c94')
+source=("http://plit.de/asem-51/$pkgname-$pkgver-ELF.tar.gz")
+
+package() {
+ cd ${srcdir}/${pkgname}
+
+ install -d "${pkgdir}"/usr/local/bin
+ for i in $(find -executable -type f ! -path "*.sh"); do
+ install -m755 "${i}" "${pkgdir}"/usr/local/bin/
+ done
+
+ install -d "${pkgdir}"/usr/local/man/man1
+ for i in *.1; do
+ install -m644 "${i}" "${pkgdir}"/usr/local/man/man1/
+ done
+
+ install -d "${pkgdir}"/usr/local/share/"${pkgname}"
+ install -m644 asem_51.doc "${pkgdir}"/usr/local/share/"${pkgname}"/
+ install -m644 blink.a51 "${pkgdir}"/usr/local/share/"${pkgname}"/
+ install -m644 boot51.a51 "${pkgdir}"/usr/local/share/"${pkgname}"/
+ install -m644 boot51.doc "${pkgdir}"/usr/local/share/"${pkgname}"/
+ install -m644 demo.a51 "${pkgdir}"/usr/local/share/"${pkgname}"/
+ install -m644 license.doc "${pkgdir}"/usr/local/share/"${pkgname}"/
+ install -m644 README.1ST "${pkgdir}"/usr/local/share/"${pkgname}"/
+ install -m644 release.130 "${pkgdir}"/usr/local/share/"${pkgname}"/
+ install -m644 support.doc "${pkgdir}"/usr/local/share/"${pkgname}"/
+ install -m755 install.sh "${pkgdir}"/usr/local/share/"${pkgname}"/
+ install -m755 uninst51.sh "${pkgdir}"/usr/local/share/"${pkgname}"/
+
+ install -d "${pkgdir}"/usr/local/share/"${pkgname}"/html
+ for i in html/*; do
+ install -m644 ${i} "${pkgdir}"/usr/local/share/"${pkgname}"/html/
+ done
+
+ install -d "${pkgdir}"/usr/local/share/"${pkgname}"/mcu
+ for i in mcu/*; do
+ install -m644 ${i} "${pkgdir}"/usr/local/share/"${pkgname}"/mcu/
+ done
+}