summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGr3q2020-04-16 22:00:57 +0100
committerGr3q2020-04-16 22:00:57 +0100
commit30ef0c03652b2194f64853dd6bb4dd2dbe445ec4 (patch)
treea464fadb3df2c8cb5b176b57fb7da86d3936a363
parent0dcd54ebdfc5a5f039046cad10b1d38e184ac2e3 (diff)
downloadaur-30ef0c03652b2194f64853dd6bb4dd2dbe445ec4.tar.gz
Remove makedepends, reorganise to be in line with other packages
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e66a5348a1b6..21494d29a35f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = aspnet-runtime-2.1
- pkgdesc = The ASP.NET Core runtime version 2.1
+ pkgdesc = The ASP.NET Core runtime binary version 2.1
pkgver = 2.1.17.sdk805
pkgrel = 2
url = https://www.microsoft.com/net/core
arch = x86_64
arch = armv7h
license = MIT
- makedepends = clang
- makedepends = cmake
- makedepends = curl
- makedepends = git
- makedepends = lldb
- makedepends = llvm
- makedepends = lttng-ust
+ depends = dotnet-runtime-2.1
+ provides = aspnet-runtime-2.1
+ provides = aspnet-runtime=2.1.17.sdk805
+ conflicts = aspnet-runtime-2.1
+ conflicts = aspnet-runtime=2.1.17.sdk805
options = staticlibs
source_x86_64 = https://download.visualstudio.microsoft.com/download/pr/8074db1d-516d-44c9-abf5-5efe38752226/c809c044b639ce439d227c377dec2355/aspnetcore-runtime-2.1.17-linux-x64.tar.gz
sha512sums_x86_64 = 92ac51b814357cf1e8050cdd3803a7efad2147b7f0a4a97ce2aee34fcd02ca0b1c97f9f47b57b3b798e047b1947ea522fdd698842a1c020dcc05f759093639f1
@@ -20,11 +18,4 @@ pkgbase = aspnet-runtime-2.1
sha512sums_armv7h = 945a3de10e36f356acb6f6c84534e88ec49fcb6636e0351467aa1a449e79f4e3bf9fb1bfba7ed278fdd92d31c51ae6c638f0a7511fdbf42d29bd1f92903bd87b
pkgname = aspnet-runtime-2.1
- pkgdesc = The ASP.NET Core runtime version 2.1
- arch = x86_64
- arch = armv7h
- depends = dotnet-runtime-2.1
- provides = aspnet-runtime-2.1
- provides = aspnet-runtime=2.1.17.sdk805
- conflicts = aspnet-runtime-2.1
diff --git a/PKGBUILD b/PKGBUILD
index ed019d5959d4..a007ee7dd8ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,20 @@
pkgname=('aspnet-runtime-2.1')
pkgver=2.1.17.sdk805
pkgrel=2
-pkgdesc='The ASP.NET Core runtime version 2.1'
+pkgdesc='The ASP.NET Core runtime binary version 2.1'
arch=('x86_64' 'armv7h')
url='https://www.microsoft.com/net/core'
license=('MIT')
-makedepends=(
- 'clang' 'cmake' 'curl' 'git' 'lldb' 'llvm' 'lttng-ust' )
options=('staticlibs')
+depends=('dotnet-runtime-2.1')
+provides=("aspnet-runtime-2.1" "aspnet-runtime=${pkgver}")
+conflicts=("aspnet-runtime-2.1" "aspnet-runtime=${pkgver}")
source_armv7h=('https://download.visualstudio.microsoft.com/download/pr/1a3c3183-ea43-4060-9205-09151a6ab9d7/6f15f282afcd70fffd8b9e12de4cd8b9/aspnetcore-runtime-2.1.17-linux-arm.tar.gz')
source_x86_64=('https://download.visualstudio.microsoft.com/download/pr/8074db1d-516d-44c9-abf5-5efe38752226/c809c044b639ce439d227c377dec2355/aspnetcore-runtime-2.1.17-linux-x64.tar.gz')
sha512sums_armv7h=('945a3de10e36f356acb6f6c84534e88ec49fcb6636e0351467aa1a449e79f4e3bf9fb1bfba7ed278fdd92d31c51ae6c638f0a7511fdbf42d29bd1f92903bd87b')
sha512sums_x86_64=('92ac51b814357cf1e8050cdd3803a7efad2147b7f0a4a97ce2aee34fcd02ca0b1c97f9f47b57b3b798e047b1947ea522fdd698842a1c020dcc05f759093639f1')
package() {
- arch=('x86_64' 'armv7h')
- pkgdesc='The ASP.NET Core runtime version 2.1'
- depends=('dotnet-runtime-2.1')
- provides=("aspnet-runtime-2.1" "aspnet-runtime=${pkgver}")
- conflicts=("aspnet-runtime-2.1")
-
install -dm 755 "${pkgdir}"/usr/share/{dotnet/shared,licenses}
cp -dr --no-preserve='ownership' shared/Microsoft.AspNetCore.App "${pkgdir}"/usr/share/dotnet/shared/
ln -s dotnet-host-2.1 "${pkgdir}"/usr/share/licenses/aspnet-runtime-2.1