summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHalosGhost2015-06-26 23:11:31 -0500
committerHalosGhost2015-06-26 23:11:31 -0500
commit1796dedc94334260671df83caf34592d914070af (patch)
tree60e61b1464c6d10912f52b6439b21387863018be
downloadaur-asteroid-git.tar.gz
Initial Commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a9fa413bb836
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = asteroid-git
+ pkgdesc = A modern version of the arcade classic Asteroids
+ pkgver = 1.2.1.4.g0e37197
+ pkgrel = 1
+ url = http://chazomaticus.github.io/asteroid/
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ makedepends = git
+ makedepends = cmake
+ depends = freeglut
+ depends = gtk2
+ depends = hicolor-icon-theme
+ depends = sdl_mixer
+ source = asteroid::git+https://github.com/chazomaticus/asteroid.git
+ sha256sums = SKIP
+
+pkgname = asteroid-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a6f7080765c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Sam Stuewe <halosghost at archlinux dot info>
+_name=asteroid
+pkgname="${_name}-git"
+pkgver=1.2.1.4.g0e37197
+pkgrel=1
+pkgdesc="A modern version of the arcade classic Asteroids"
+arch=('i686' 'x86_64')
+url="http://chazomaticus.github.io/asteroid/"
+license=('GPLv3')
+depends=('freeglut' 'gtk2' 'hicolor-icon-theme' 'sdl_mixer')
+makedepends=('git' 'cmake')
+source=("${_name}::git+https://github.com/chazomaticus/${_name}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_name}"
+ git describe --always | sed 's|-|.|g'
+}
+
+prepare() {
+ cd "${_name}"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr
+ sed -i 's_lcairo_lcairo -lm_' CMakeFiles/asteroid.dir/link.txt
+}
+
+package() {
+ cd "${_name}"
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
+ find "${pkgdir}" -type d -name .git -exec rm -r '{}' +
+}
+
+# vim:set ts=2 sw=2 et: