summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Rizzitello2016-11-13 08:38:15 -0500
committerChris Rizzitello2016-11-13 08:38:15 -0500
commite74ce2aea5aa09682cbc26a8c8b5275caee2f1d6 (patch)
treecaecb35c7f20e8a63b2f111ef593c839321e38fc
parent3d883425194356e9a9c4e507bd57ed216aedfa91 (diff)
downloadaur-e74ce2aea5aa09682cbc26a8c8b5275caee2f1d6.tar.gz
Add CMake Option to build test gui
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac7bde27d806..0dab09b573cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
# Generated by mksrcinfo v8
-# Thu Nov 10 21:32:26 UTC 2016
+# Sun Nov 13 13:37:32 UTC 2016
pkgbase = atcore-git
pkgdesc = KDE 3D Printing libary
- pkgver = 43949e2
- pkgrel = 2
- url = https://github.com/KDE/atcore
+ pkgver = fb7d440
+ pkgrel = 1
+ url = https://www.kde.org/
arch = i686
arch = x86_64
license = LGPL3
depends = qt5-base
depends = qt5-serialport
depends = solid
- source = git://github.com/kde/atcore.git
+ source = git://anongit.kde.org/atcore.git
md5sums = SKIP
pkgname = atcore-git
diff --git a/PKGBUILD b/PKGBUILD
index 8c89aab87e11..bb19a79d279f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Chris Rizzitello <sithlord48@gmail.com>
pkgname=atcore-git
confilicts=('atcore')
-pkgver=43949e2
-pkgrel=2
+pkgver=fb7d440
+pkgrel=1
pkgdesc="KDE 3D Printing libary"
arch=('i686' 'x86_64')
-url="https://github.com/KDE/atcore"
+url="https://www.kde.org/"
license=('LGPL3')
buildDepends=('git' 'cmake' 'extra-cmake-modules')
depends=('qt5-base' 'qt5-serialport' 'solid') #Qt5)
-source=("git://github.com/kde/atcore.git")
+source=('git://anongit.kde.org/atcore.git')
md5sums=(SKIP)
pkgver() {
@@ -19,15 +19,10 @@ pkgver() {
build() {
cd "atcore"
- cmake -DCMAKE_INSTALL_PREFIX=$(qtpaths --install-prefix) -DCMAKE_INSTALL_LIBDIR=lib -DCMAKE_BUILD_TYPE=Release CMakeLists.txt
+ cmake -DCMAKE_INSTALL_PREFIX=$(qtpaths --install-prefix) -DCMAKE_INSTALL_LIBDIR=lib -DCMAKE_BUILD_TYPE=Release -DBUILD_TEST_GUI=ON CMakeLists.txt
make
}
package(){
cd "atcore"
make DESTDIR="$pkgdir/" install
- #add the optional stuff for AtCoreTest deployment
- install -D -s -m755 testclient/AtCoreTest $pkgdir/usr/bin/AtCoreTest
- install -D -m644 testclient/AtCoreTest.menu $pkgdir/usr/share/menu/AtCoreTest
- install -D -m644 testclient/AtCoreTest.png $pkgdir/usr/share/pixmaps/AtCoreTest.png
- install -D -m644 testclient/AtCoreTest.desktop $pkgdir/usr/share/applications/AtCoreTest.desktop
}