summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-29 09:29:16 +0200
committerChristian Hesse2015-06-29 09:29:16 +0200
commitcc37f5f5cd77dff80862ad2cdc0c417695f890aa (patch)
tree91985814f5bec2268b6003c9d394816be4713d96
downloadaur-atftp-git.tar.gz
initial import of atftp-git 0.7.1.r1.gf9dbb96-1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD64
-rw-r--r--atftpd.conf3
-rw-r--r--atftpd.service11
4 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d17353f2852f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = atftp-git
+ pkgdesc = a client/server implementation of the TFTP protocol - git checkout
+ pkgver = 0.7.1.r1.gf9dbb96
+ pkgrel = 1
+ url = http://sourceforge.net/projects/atftp/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = pcre
+ depends = readline
+ provides = atftp
+ conflicts = atftp
+ backup = etc/conf.d/atftpd
+ source = atftp::git://git.code.sf.net/p/atftp/code
+ source = atftpd.conf
+ source = atftpd.service
+ sha256sums = SKIP
+ sha256sums = 100225ede793b9c01d0c5bcb9c2cc1933552609d3a9439b9bd03dfa0b269143e
+ sha256sums = 77e7e40d5d0749d18ddeed434ed2cc0d9c6d56609d9c106da78499e1b03c1c35
+
+pkgname = atftp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d5f9db6047f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+# Contributor: Benjamin Bukowski <benjamin.bukowski@gmail.com>
+
+pkgname=atftp-git
+pkgver=0.7.1.r1.gf9dbb96
+pkgrel=1
+pkgdesc='a client/server implementation of the TFTP protocol - git checkout'
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/atftp/"
+license=('GPL')
+depends=('pcre' 'readline')
+conflicts=('atftp')
+provides=('atftp')
+backup=('etc/conf.d/atftpd')
+source=('atftp::git://git.code.sf.net/p/atftp/code'
+ 'atftpd.conf'
+ 'atftpd.service')
+
+pkgver() {
+ cd atftp/
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ else
+ echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ fi
+}
+
+prepare() {
+ cd atftp/
+
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac
+}
+
+
+build() {
+ cd atftp/
+
+ ./autogen.sh
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --sbindir=/usr/bin \
+ --enable-libreadline \
+ --disable-libwrap
+ make
+}
+
+package() {
+ cd atftp/
+
+ make DESTDIR="${pkgdir}" install
+
+ install -D -m0644 "${srcdir}/atftpd.conf" "${pkgdir}/etc/conf.d/atftpd"
+ install -D -m0644 "${srcdir}/atftpd.service" "${pkgdir}/usr/lib/systemd/system/atftpd.service"
+ install -d -m0775 --group=nobody "${pkgdir}/var/tftpboot"
+
+ # remove in.tftpd link as it conflicts with extra/tftp-hpa
+ rm "${pkgdir}/usr/share/man/man8/in.tftpd.8"
+ rm "${pkgdir}/usr/bin/in.tftpd"
+}
+
+sha256sums=('SKIP'
+ '100225ede793b9c01d0c5bcb9c2cc1933552609d3a9439b9bd03dfa0b269143e'
+ '77e7e40d5d0749d18ddeed434ed2cc0d9c6d56609d9c106da78499e1b03c1c35')
diff --git a/atftpd.conf b/atftpd.conf
new file mode 100644
index 000000000000..fb1021b74207
--- /dev/null
+++ b/atftpd.conf
@@ -0,0 +1,3 @@
+# Parameters to be passed to ATFTPD
+ATFTPD_ARGS="--no-multicast --maxthread 20 --verbose=6 --bind-address 0.0.0.0 --group nobody /var/tftpboot"
+
diff --git a/atftpd.service b/atftpd.service
new file mode 100644
index 000000000000..489278ffaf05
--- /dev/null
+++ b/atftpd.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Advanced TFTP Daemon
+After=network.target
+
+[Service]
+Type=forking
+EnvironmentFile=/etc/conf.d/atftpd
+ExecStart=/usr/bin/atftpd $ATFTPD_ARGS
+
+[Install]
+WantedBy=multi-user.target