summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton2019-05-14 14:31:32 +0300
committerAnton2019-05-14 14:31:32 +0300
commit3d4f33a6eaf9b9869d15b93cdb7481ce209f3481 (patch)
tree1417071fb59c61f428f00582352954f02873abb0
parent286cdb8eafb3756cdb3d63f0f6c6084e55a31169 (diff)
downloadaur-3d4f33a6eaf9b9869d15b93cdb7481ce209f3481.tar.gz
Code cleanup, preparing to the next release
-rw-r--r--.SRCINFO32
-rw-r--r--Makefile (renamed from makefile.shared.mt)0
-rw-r--r--PKGBUILD111
-rw-r--r--atlas-license.txt29
-rw-r--r--blas-license.txt19
-rw-r--r--makefile.shared.st25
6 files changed, 52 insertions, 164 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7efe8658c7c6..cbfed1c708f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,43 +1,35 @@
-# Generated by mksrcinfo v8
-# Sat Jul 30 16:35:26 UTC 2016
pkgbase = atlas-lapack
- pkgdesc = Complete LAPACK and BLAS implementation using optimised ATLAS routines
+ pkgdesc = Automatically Tuned Linear Algebra Software
pkgver = 3.10.3
- pkgrel = 1
+ pkgrel = 2
url = http://math-atlas.sourceforge.net/
install = atlas-lapack.install
- arch = i686
arch = x86_64
- license = custom:blas
+ license = BSD
license = custom:lapack
- license = custom:atlas
makedepends = binutils
makedepends = sed
makedepends = gcc-fortran
depends = gcc-libs
provides = blas
- provides = lapack=3.6.1
+ provides = lapack
provides = cblas
provides = atlas-lapack-base
conflicts = blas
conflicts = lapack
conflicts = cblas
conflicts = atlas-lapack-base
- noextract = lapack-3.6.1.tgz
+ conflicts = openblas
+ conflicts = openblas-lapack
+ noextract = v3.8.0.tar.gz
noextract = atlas3.10.3.tar.bz2
options = !makeflags
- source = http://www.netlib.org/lapack/lapack-3.6.1.tgz
+ source = https://github.com/Reference-LAPACK/lapack/archive/v3.8.0.tar.gz
source = http://downloads.sourceforge.net/math-atlas/atlas3.10.3.tar.bz2
- source = blas-license.txt
- source = atlas-license.txt
- source = makefile.shared.mt
- source = makefile.shared.st
- md5sums = 421b2cb72e15f237e144428f9c460ee0
- md5sums = d6ce4f16c2ad301837cfb3dade2f7cef
- md5sums = 38b6acb8ed5691d25863319d30a8b365
- md5sums = 4903eb06072dfbf94710691ccb6660bf
- md5sums = e293bf3b62b7cc02cb5dcf54f9f40053
- md5sums = 5153cb945e8f386e4d98d4b0fe791776
+ source = Makefile
+ sha256sums = deb22cc4a6120bff72621155a9917f485f96ef8319ac074a7afbc68aab88bcf6
+ sha256sums = 2688eb733a6c5f78a18ef32144039adcd62fabce66f2eb51dd59dde806a6d2b7
+ sha256sums = 7627446a0d598b55bc8f2795f8ff2028f134928b9ca597b76bf8dd5622dbff69
pkgname = atlas-lapack
diff --git a/makefile.shared.mt b/Makefile
index 048fa456e23b..048fa456e23b 100644
--- a/makefile.shared.mt
+++ b/Makefile
diff --git a/PKGBUILD b/PKGBUILD
index 6b93502caf66..bc45619b2763 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,79 +2,54 @@
# Contributor: mickele <mimocciola___AT___yahoo___DOT___ com>
# Contributor: iztok pizorn <pizorn___AT___gmail___DOT___com>
# Contributor: olivier medoc <o_medoc___AT___yahoo___DOT___fr>
+# Contributor: Anton Kudelin <kudelin___AT___protonmail___DOT___com>
+
pkgname=atlas-lapack
pkgver=3.10.3
-_lapackver=3.6.1
-pkgrel=1
-pkgdesc="Complete LAPACK and BLAS implementation using optimised ATLAS routines"
+_lapackver=3.8.0
+pkgrel=2
+pkgdesc="Automatically Tuned Linear Algebra Software"
url="http://math-atlas.sourceforge.net/"
depends=('gcc-libs')
makedepends=('binutils' 'sed' 'gcc-fortran')
-arch=('i686' 'x86_64')
-conflicts=('blas' 'lapack' 'cblas' 'atlas-lapack-base')
-provides=("blas" "lapack=$_lapackver" 'cblas' 'atlas-lapack-base')
-license=('custom:blas' 'custom:lapack' 'custom:atlas')
+arch=('x86_64')
+conflicts=('blas' 'lapack' 'cblas' 'atlas-lapack-base' 'openblas' 'openblas-lapack')
+provides=("blas" "lapack" 'cblas' 'atlas-lapack-base')
+license=('BSD' 'custom:lapack')
options=(!makeflags)
install=$pkgname.install
-source=(http://www.netlib.org/lapack/lapack-$_lapackver.tgz
- http://downloads.sourceforge.net/math-atlas/atlas${pkgver}.tar.bz2
- blas-license.txt atlas-license.txt
- makefile.shared.mt makefile.shared.st)
-noextract=(lapack-$_lapackver.tgz atlas$pkgver.tar.bz2)
-md5sums=('421b2cb72e15f237e144428f9c460ee0'
- 'd6ce4f16c2ad301837cfb3dade2f7cef'
- '38b6acb8ed5691d25863319d30a8b365'
- '4903eb06072dfbf94710691ccb6660bf'
- 'e293bf3b62b7cc02cb5dcf54f9f40053'
- '5153cb945e8f386e4d98d4b0fe791776')
-
-build() {
+source=("https://github.com/Reference-LAPACK/lapack/archive/v$_lapackver.tar.gz"
+ "http://downloads.sourceforge.net/math-atlas/atlas${pkgver}.tar.bz2"
+ "Makefile")
+noextract=("v$_lapackver.tar.gz" "atlas$pkgver.tar.bz2")
+sha256sums=('deb22cc4a6120bff72621155a9917f485f96ef8319ac074a7afbc68aab88bcf6'
+ '2688eb733a6c5f78a18ef32144039adcd62fabce66f2eb51dd59dde806a6d2b7'
+ '7627446a0d598b55bc8f2795f8ff2028f134928b9ca597b76bf8dd5622dbff69')
+
+prepare() {
msg 'Before building this package, as root you must set the CPU(s)'
- msg 'governor(s) to "performance".'
+ msg 'governor(s) to "performance" and disable intel_pstate.'
msg 'See: https://wiki.archlinux.org/index.php/CPU_frequency_scaling'
- cd "$srcdir"
+ cd $srcdir
tar -xjf atlas$pkgver.tar.bz2
+ mkdir ATLAS/build
+}
+
+build() {
+ cd $srcdir/ATLAS/build
- unset MAKE
- CORE=`cat /proc/cpuinfo | grep "cpu MHz" | head -n 1 | sed "s/.*: \([0-9.]*\).*/\1/"`
- NCPU=`grep "^processor" /proc/cpuinfo | wc -l`
- if [ "$CARCH" = "x86_64" ]; then
- ARCHITECTURE_BUILD_OPTS="-b 64" # for x86_64
- else
- ARCHITECTURE_BUILD_OPTS="-b 32" # for i686
- fi
-
- cd "$srcdir"/ATLAS
- rm -rf build
- mkdir -p build
- cd build
-
- msg 'Configuring ATLAS'
-
- ../configure --prefix=/usr/ $ARCHITECTURE_BUILD_OPTS -Fa alg -fPIC \
- --shared -D c -DPentiumCPS=$CORE \
- --with-netlib-lapack-tarfile="$srcdir/lapack-$_lapackver.tgz"
-
- msg 'Building ATLAS'
-
+ ../configure --prefix=/usr \
+ --shared \
+ --with-netlib-lapack-tarfile="$srcdir/v$_lapackver.tar.gz"
make build
-
- msg 'Building shared libraries'
cd lib
- if [ 1 -lt $NCPU ]; then
- cp "$srcdir/makefile.shared.mt" makefile
- else
- cp "$srcdir/makefile.shared.st" makefile
- fi
- make -f makefile
+ cp $srcdir/Makefile .
+ make
}
check() {
- cd "$srcdir/ATLAS/build"
- unset MAKE
-
- msg 'Checking ATLAS'
+ cd $srcdir/ATLAS/build
make check
make ptcheck
@@ -82,23 +57,17 @@ check() {
}
package() {
- cd "$srcdir/ATLAS/build"
- unset MAKE
-
- msg 'Packaging ATLAS'
+ cd $srcdir/ATLAS/build
- make DESTDIR="$pkgdir/usr" install
- cp -d lib/*.so* "$pkgdir/usr/lib"
- [ -e lib/libptlapack.a ] && cp lib/libptlapack.a "$pkgdir/usr/lib"
- cd "$pkgdir/usr/lib"
+ make DESTDIR=$pkgdir/usr install
+ cp -d lib/*.so* $pkgdir/usr/lib
+ cd $pkgdir/usr/lib
ln -s libblas.so libblas.so.3
ln -s liblapack.so.3 liblapack.so
+
+ cd ../include/atlas
+ sed -i "s#$srcdir# #g" *
- install -Dm644 "${srcdir}/blas-license.txt" \
- "${pkgdir}/usr/share/licenses/$pkgname/blas-license.txt"
- install -Dm644 "${srcdir}/ATLAS/build/src/lapack/reference/LICENSE" \
- "${pkgdir}/usr/share/licenses/$pkgname/lapack-license.txt"
- install -Dm644 "${srcdir}/atlas-license.txt" \
- "${pkgdir}/usr/share/licenses/$pkgname/atlas-license.txt"
+ install -Dm644 $srcdir/ATLAS/build/src/lapack/reference/LICENSE \
+ $pkgdir/usr/share/licenses/$pkgname/lapack-license.txt
}
-
diff --git a/atlas-license.txt b/atlas-license.txt
deleted file mode 100644
index 18e3a60e237f..000000000000
--- a/atlas-license.txt
+++ /dev/null
@@ -1,29 +0,0 @@
- Automatically Tuned Linear Algebra Software v3.8.2
- (C) Copyright 1999 R. Clint Whaley
-
- Code contributers : R. Clint Whaley, Antoine P. Petitet
-
- Redistribution and use in source and binary forms, with or without
- modification, are permitted provided that the following conditions
- are met:
- 1. Redistributions of source code must retain the above copyright
- notice, this list of conditions and the following disclaimer.
- 2. Redistributions in binary form must reproduce the above copyright
- notice, this list of conditions, and the following disclaimer in the
- documentation and/or other materials provided with the distribution.
- 3. The name of the ATLAS group or the names of its contributers may
- not be used to endorse or promote products derived from this
- software without specific written permission.
-
- THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
- ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
- TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
- PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE ATLAS GROUP OR ITS CONTRIBUTORS
- BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
- CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
- SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
- INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
- CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
- ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
- POSSIBILITY OF SUCH DAMAGE.
-
diff --git a/blas-license.txt b/blas-license.txt
deleted file mode 100644
index 79f38386e651..000000000000
--- a/blas-license.txt
+++ /dev/null
@@ -1,19 +0,0 @@
-From: http://www.netlib.org/blas/faq.html
-
- 2) Are there legal restrictions on the use of BLAS reference
- implementation software?
-
-The reference BLAS is a freely-available software package. It is
-available from netlib via anonymous ftp and the World Wide Web. Thus,
-it can be included in commercial software packages (and has been). We
-only ask that proper credit be given to the authors.
-
-Like all software, it is copyrighted. It is not trademarked, but we do
-ask the following:
-
-If you modify the source for these routines we ask that you change the
-name of the routine and comment the changes made to the original.
-
-We will gladly answer any questions regarding the software. If a
-modification is done, however, it is the responsibility of the person
-who modified the routine to provide support.
diff --git a/makefile.shared.st b/makefile.shared.st
deleted file mode 100644
index 5feda573104c..000000000000
--- a/makefile.shared.st
+++ /dev/null
@@ -1,25 +0,0 @@
-include Make.inc
-
-all: libatlas.so libf77blas.so libcblas.so libblas.so liblapack.so.3.6.1
-
-libatlas.so: libatlas.a
- ld $(LDFLAGS) -shared -soname $@ -o $@ --whole-archive libatlas.a \
- --no-whole-archive -lc $(LIBS)
-
-libf77blas.so : libf77blas.a libatlas.so
- ld $(LDFLAGS) -shared -soname libblas.so.3 -o $@ --whole-archive \
- libf77blas.a --no-whole-archive $(F77SYSLIB) -L. -latlas
-
-libcblas.so : libcblas.a libatlas.so libblas.so
- ld $(LDFLAGS) -shared -soname $@ -o $@ --whole-archive libcblas.a \
- -L. -latlas -lblas
-
-libblas.so: libf77blas.so
- ln -s $< $@
-
-liblapack.so.3.6.1 : liblapack.a libcblas.so libblas.so
- ld $(LDFLAGS) -shared -soname liblapack.so.3 -o $@ --whole-archive \
- liblapack.a --no-whole-archive $(F77SYSLIB) -L. -lcblas -lblas
-
-liblapack.so.3: liblapack.so.3.6.1
- ln -s $< $@