summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Fabijan2015-06-13 08:43:42 +0200
committerDavid Fabijan2015-06-13 08:43:42 +0200
commit2cf71324909755178458ecbbc4efa9c92a56895f (patch)
tree68aceb0abedee4f3ac183d0e4b70d4917b0db27a
downloadaur-atomiks.tar.gz
Initail upload to AUR4, and update to version 1.0.4.1 with a move from SDL to SDL2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
-rw-r--r--atomiks.desktop9
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a7a96113fb4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = atomiks
+ pkgdesc = Atomiks is a faithful remake of, and a tribute to, Atomix, a classic puzzle game
+ pkgver = 1.0.4.1
+ pkgrel = 1
+ url = http://sourceforge.net/projects/atomiks/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = sdl2_mixer
+ source = http://downloads.sourceforge.net/project/atomiks/v1.0.4.1/atomiks-1.0.4.1.tar.gz
+ source = atomiks.desktop
+ md5sums = 1922f6b08e2e537b6ffdce3bf8e4721d
+ md5sums = e1e54d118bf749bcaff89a2a18800b14
+
+pkgname = atomiks
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70fbc4353ac0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: McLenin <mclenin at gooogles email>
+
+pkgname=atomiks
+pkgver=1.0.4.1
+pkgrel=1
+pkgdesc="Atomiks is a faithful remake of, and a tribute to, Atomix, a classic puzzle game"
+arch=("i686" "x86_64")
+url="http://sourceforge.net/projects/atomiks/"
+depends=("sdl2_mixer")
+license=("GPL3")
+source=("http://downloads.sourceforge.net/project/atomiks/v1.0.4.1/atomiks-1.0.4.1.tar.gz" "atomiks.desktop")
+md5sums=('1922f6b08e2e537b6ffdce3bf8e4721d'
+ 'e1e54d118bf749bcaff89a2a18800b14')
+
+build() {
+ cd "$srcdir/$pkgname"-"$pkgver"
+ #The file size is not that much bigger anyway and it removes a somewhat rare build dependency
+ #sed -i '/upx/d' Makefile
+ make
+ make editor
+}
+
+package() {
+
+ cd "$srcdir/$pkgname"-"$pkgver"
+ install -D ${pkgname} ${pkgdir}/usr/bin/${pkgname}
+ install -D editor ${pkgdir}/usr/bin/${pkgname}-editor
+ install -Dm644 ${pkgname}.png ${pkgdir}/usr/share/pixmaps/${pkgname}.png
+ install -D readme.txt ${pkgdir}/usr/share/doc/${pkgname}/readme.txt
+ install -D history.txt ${pkgdir}/usr/share/doc/${pkgname}/history.txt
+ cd ${srcdir}
+ install -D ${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
+}
diff --git a/atomiks.desktop b/atomiks.desktop
new file mode 100644
index 000000000000..9febed3ad9e7
--- /dev/null
+++ b/atomiks.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Atomiks
+GenericName=Puzzle game
+Comment=Atomiks is a faithful remake of, and a tribute to, Atomix, a classic puzzle game
+Exec=atomiks
+Icon=/usr/share/pixmaps/atomiks.png
+Type=Application
+Terminal=false
+Categories=Application;Game