summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Snidal2023-01-16 17:02:09 -0500
committerMark Snidal2023-01-16 17:02:09 -0500
commitc8f00368b0c86e93ec5e2379513a034af33a11fd (patch)
tree7640f6cd6cabd05770d31ed7c3c9ad318a16341e
downloadaur-attercop.tar.gz
First AUR deployment of attercop, a command-line shell generation tool using OpenAI's API!
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ba4284e8160
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = attercop
+ pkgdesc = Command generations in the shell with natural language
+ pkgver = 0.3.4
+ pkgrel = 1
+ url = https://github.com/msnidal/attercop
+ arch = any
+ license = GPL3
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python>=3.7.1
+ depends = python-openai>=0.23.1
+ depends = python-pyperclip>=1.8.2
+ depends = python-colorama>=0.4.6
+ source = https://files.pythonhosted.org/packages/source/a/attercop/attercop-0.3.4.tar.gz
+ md5sums = 44de6f87309470fa65b015247d5bd866
+pkgname = attercop
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b949eb61a29b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mark Snidal <mark.snidal@gmail.com>
+pkgname=attercop
+pkgver=0.3.4
+pkgrel=1
+pkgdesc="Command generations in the shell with natural language"
+arch=('any')
+url="https://github.com/msnidal/$pkgname"
+license=('GPL3')
+depends=('python>=3.7.1' 'python-openai>=0.23.1' 'python-pyperclip>=1.8.2' 'python-colorama>=0.4.6')
+makedepends=('python-build' 'python-installer' 'python-wheel')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('44de6f87309470fa65b015247d5bd866')
+build() {
+ cd "$pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
+package() {
+ cd "$pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}