summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorseiuneko2024-03-11 13:07:11 +0800
committerseiuneko2024-03-11 13:07:11 +0800
commit48ffa3395f3cfc9b661b07ea0b3da610e254bfe3 (patch)
tree62840ebb4d37f593b0a9f58bb71891a9d2b25b11
downloadaur-atuin-lily-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD59
2 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..89b9d3418436
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = atuin-lily-git
+ pkgdesc = Magical shell history ( lilydjwg fork )
+ pkgver = r968.9d91564
+ pkgrel = 1
+ url = https://github.com/atuinsh/atuin
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ makedepends = git
+ depends = gcc-libs
+ optdepends = bash-preexec: bash integration
+ provides = atuin
+ conflicts = atuin
+ options = !lto
+ source = atuin-lily::git+https://github.com/lilydjwg/atuin.git
+ sha256sums = SKIP
+
+pkgname = atuin-lily-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c28a882f6b40
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: seiuneko <chfsefefgesfen foxmail>
+# Contributor: Orhun Parmaksız <orhun@archlinux.org>
+# Contributor: Caleb Maclennan <caleb@alerque.com>
+# Contributor: Ellie Huxtable <e@elm.sh>
+
+pkgname=atuin-lily-git
+_pkgname=atuin-lily
+__pkgname=atuin
+pkgver=r968.9d91564
+pkgrel=1
+pkgdesc="Magical shell history ( lilydjwg fork )"
+arch=('x86_64')
+url="https://github.com/atuinsh/atuin"
+license=('MIT')
+depends=('gcc-libs')
+makedepends=('cargo' 'git')
+optdepends=('bash-preexec: bash integration')
+source=("${_pkgname}::git+https://github.com/lilydjwg/atuin.git")
+sha256sums=('SKIP')
+options=('!lto')
+conflicts=('atuin')
+provides=('atuin')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
+prepare() {
+ cd "$_pkgname"
+ cargo update
+ cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
+ mkdir -p completions/
+}
+
+build() {
+ cd "$_pkgname"
+ cargo build --release --frozen --all-features
+ for sh in 'bash' 'fish' 'zsh'; do
+ "target/release/$__pkgname" gen-completions -s "$sh" -o completions/
+ done
+}
+
+check() {
+ cd "$_pkgname"
+ cargo test --frozen --all-features --workspace --lib
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm 755 "target/release/$__pkgname" -t "$pkgdir/usr/bin"
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$_pkgname"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$_pkgname"
+ install -Dm 644 "completions/$__pkgname.bash" "${pkgdir}/usr/share/bash-completion/completions/$_pkgname"
+ install -Dm 644 "completions/$__pkgname.fish" -t "${pkgdir}/usr/share/fish/vendor_completions.d"
+ install -Dm 644 "completions/_$__pkgname" -t "${pkgdir}/usr/share/zsh/site-functions"
+}
+
+# vim: ts=2 sw=2 et: