summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Tiá2020-02-29 14:50:20 -0800
committerJavier Tiá2020-02-29 14:50:20 -0800
commit36d72d85586e2a791e9299ae38c7a7d128d68817 (patch)
treeb43c6152391e6906d32cb511f9bba4f55412234a
downloadaur-aucatctl.tar.gz
Bump up aucatctl 0.1-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44aa717f8623
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = aucatctl
+ pkgdesc = Control aucat and/or sndiod volume through MIDI
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://www.sndio.org/
+ arch = i686
+ arch = x86_64
+ license = ISC
+ depends = alsa-lib
+ depends = libbsd
+ depends = sndio
+ source = http://www.sndio.org/aucatctl-0.1.tar.gz
+ sha256sums = 524f2fae47db785234f166551520d9605b9a27551ca438bd807e3509ce246cf0
+
+pkgname = aucatctl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cbd286cdf728
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Javier Tia <javier dot tia at gmail dot com>
+# Contributer: Giuseppe Calà <jiveaxe@gmail.com>
+# Contributer: giacomogiorgianni@gmail.com
+# Contributor: TingPing <tingping@tingping.se>
+
+pkgname=aucatctl
+pkgver=0.1
+pkgrel=1
+pkgdesc="Control aucat and/or sndiod volume through MIDI"
+arch=('i686' 'x86_64')
+url='http://www.sndio.org/'
+license=('ISC')
+depends=(alsa-lib libbsd sndio)
+source=("http://www.sndio.org/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('524f2fae47db785234f166551520d9605b9a27551ca438bd807e3509ce246cf0')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ sed -i 's?/usr/local?/usr?g' Makefile
+ sed -i 's?man/man1?share/man/man1?g' Makefile
+ sed -i 's?LDADD = -lsndio?LDADD = -lbsd\nLDADD += -lsndio?' Makefile
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}/" install
+
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ sed '/^ \*\//q' aucatctl.c > ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}