summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Lange2020-12-16 00:48:03 +0100
committerThomas Lange2020-12-16 00:48:03 +0100
commitcb5f6f22baf3b8bd182f9d2d197c6a198153a563 (patch)
treeca75d401758ccb9f6b1dfcb575f90746e94c1ef3
parente0b9ad907ae90ab30696af40bc9b193651897e7e (diff)
downloadaur-cb5f6f22baf3b8bd182f9d2d197c6a198153a563.tar.gz
Add config option for Meson
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD33
2 files changed, 27 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ce296958c56..42e8c3448ce3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = audacious-git
pkgdesc = Lightweight, advanced audio player focused on audio quality (git version)
- pkgver = 4.0.beta1.r154.g91de6c1f2
+ pkgver = 4.0.beta1.r214.g411bcf5e3
pkgrel = 1
epoch = 1
url = https://audacious-media-player.org/
diff --git a/PKGBUILD b/PKGBUILD
index b4236e95dd57..148b5c8b4cf7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,13 @@
# Contributor: Alexander Fehr <pizzapunk gmail com>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+# Set to 1 to use Meson build system
+_use_meson=0
+_buildstamp='Arch Linux'
+
_pkgname=audacious
pkgname="$_pkgname-git"
-pkgver=4.0.beta1.r154.g91de6c1f2
+pkgver=4.0.beta1.r214.g411bcf5e3
pkgrel=1
epoch=1
pkgdesc="Lightweight, advanced audio player focused on audio quality (git version)"
@@ -22,6 +26,10 @@ install="$_pkgname.install"
source=("git://github.com/audacious-media-player/$_pkgname.git")
sha256sums=('SKIP')
+if [ "$_use_meson" = 1 ]; then
+ makedepends+=('meson')
+fi
+
pkgver() {
cd "$_pkgname"
git describe --long --tags | sed 's/^audacious-//;s/\([^-]*-g\)/r\1/;s/-/./g'
@@ -30,15 +38,26 @@ pkgver() {
build() {
cd "$_pkgname"
- autoreconf -I m4
- ./configure \
- --prefix=/usr \
- --with-buildstamp='Arch Linux'
- make
+ if [ "$_use_meson" = 1 ]; then
+ arch-meson build -D buildstamp="$_buildstamp"
+ meson compile -C build
+ else
+ autoreconf -I m4
+ ./configure \
+ --prefix=/usr \
+ --with-buildstamp="$_buildstamp"
+ make
+ fi
}
package() {
cd "$_pkgname"
- make DESTDIR="$pkgdir" install
+
+ if [ "$_use_meson" = 1 ]; then
+ DESTDIR="$pkgdir" meson install -C build
+ else
+ make DESTDIR="$pkgdir" install
+ fi
+
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
}