summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOSAMC2025-02-28 23:35:59 +0000
committerFlorian Hülsmann2025-02-28 23:35:59 +0000
commit1562355f4f5db28f73f80c53a1a4dd5eca42f96d (patch)
tree0dfac6ace936d5962a145506bd0b066a15d74542
parentdd7205fc374e56318cda19937c09175808bfb808 (diff)
downloadaur-audiowmark.tar.gz
audiowmark: update to v0.6.4 (#554)
-rw-r--r--.SRCINFO12
-rw-r--r--.nvchecker.toml8
-rw-r--r--PKGBUILD20
-rw-r--r--audiowmark-configure.patch259
-rw-r--r--audiowmark-nostdin.patch95
-rw-r--r--audiowmark-tests.patch81
6 files changed, 14 insertions, 461 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96d8be7299df..6f0862c98b17 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = audiowmark
pkgdesc = Audio and video watermarking
- pkgver = 0.6.3
+ pkgver = 0.6.4
pkgrel = 1
url = https://uplex.de/audiowmark/
arch = x86_64
@@ -17,14 +17,8 @@ pkgbase = audiowmark
depends = gcc-libs
depends = glibc
depends = libgcrypt
- source = https://github.com/swesterfeld/audiowmark/releases/download/0.6.3/audiowmark-0.6.3.tar.zst
- source = audiowmark-configure.patch
- source = audiowmark-nostdin.patch
- source = audiowmark-tests.patch
- sha256sums = 65389bb1de1d5ea40fdf010d9ca2164394550c5b921e25944a117b8f2ddad5ab
- sha256sums = bd91d4c1cecfbb20a86cfd8005caf07d019ac1568f9f76e561f3cd8866e9cbe1
- sha256sums = e46363c767dbd96ba1b6ab91ae0e26fdf05cbebd935cc2cf545e899b368c22b9
- sha256sums = 9bc336a3434edb66518785c2fe9db1de7796cc215904ea1a1f74c0c3b986ba91
+ source = https://github.com/swesterfeld/audiowmark/releases/download/0.6.4/audiowmark-0.6.4.tar.zst
+ sha256sums = 5a4445beb70fc17ee11cdd40788ec9936f0c7bb6cf0395ac9ae077652a16e48d
pkgname = audiowmark
depends = bash
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..8a96030cb885
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,8 @@
+# note: we use the stable website downloads for building, but gitlab for checking
+[audiowmark]
+source = "gitlab"
+host = "code.uplex.de"
+gitlab = "stefan/audiowmark"
+# Regex to avoid the "proof-of-concept" tag. Start with a number.
+include_regex = '^\d.+$'
+use_max_tag = true
diff --git a/PKGBUILD b/PKGBUILD
index 34ed70929201..3f1090490fad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Christopher Arndt <osam -at- chrisarndt -dot- de>
pkgname=audiowmark
-pkgver=0.6.3
+pkgver=0.6.4
pkgrel=1
pkgdesc='Audio and video watermarking'
arch=(x86_64 aarch64)
@@ -12,22 +12,8 @@ license=(GPL-3.0-or-later)
depends=(bash gcc-libs glibc libgcrypt)
makedepends=(autoconf-archive ffmpeg fftw libsndfile mpg123 zita-resampler)
groups=(pro-audio)
-source=("https://github.com/swesterfeld/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.zst"
- 'audiowmark-configure.patch'
- 'audiowmark-nostdin.patch'
- 'audiowmark-tests.patch')
-sha256sums=('65389bb1de1d5ea40fdf010d9ca2164394550c5b921e25944a117b8f2ddad5ab'
- 'bd91d4c1cecfbb20a86cfd8005caf07d019ac1568f9f76e561f3cd8866e9cbe1'
- 'e46363c767dbd96ba1b6ab91ae0e26fdf05cbebd935cc2cf545e899b368c22b9'
- '9bc336a3434edb66518785c2fe9db1de7796cc215904ea1a1f74c0c3b986ba91')
-
-prepare() {
- cd $pkgname-$pkgver
- # https://github.com/swesterfeld/audiowmark/issues/72
- patch -p1 -N -r - -i "$srcdir"/audiowmark-configure.patch || :
- patch -p1 -N -r - -i "$srcdir"/audiowmark-nostdin.patch || :
- patch -p1 -N -r - -i "$srcdir"/audiowmark-tests.patch || :
-}
+source=("https://github.com/swesterfeld/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.zst")
+sha256sums=('5a4445beb70fc17ee11cdd40788ec9936f0c7bb6cf0395ac9ae077652a16e48d')
build() {
cd $pkgname-$pkgver
diff --git a/audiowmark-configure.patch b/audiowmark-configure.patch
deleted file mode 100644
index c22ffc20ed98..000000000000
--- a/audiowmark-configure.patch
+++ /dev/null
@@ -1,259 +0,0 @@
-From f227995dd83dd42f67b6a59d1b98433a1f41aaf4 Mon Sep 17 00:00:00 2001
-From: Stefan Westerfeld <stefan@space.twc.de>
-Date: Sat, 28 Dec 2024 16:26:08 +0100
-Subject: [PATCH 1/5] BUILD: fail if gcrypt is not found during configure (see
- also #72).
-
-Signed-off-by: Stefan Westerfeld <stefan@space.twc.de>
----
- configure.ac | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index 1d01b7d..ee874bf 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -77,7 +77,9 @@ AC_SNDFILE_REQUIREMENTS
- AC_LIBMPG123_REQUIREMENTS
- AC_ZITA_REQUIREMENTS
- AC_FFTW_CHECK
--AM_PATH_LIBGCRYPT
-+AM_PATH_LIBGCRYPT([], [], [
-+ AC_MSG_ERROR([You need to install libgcrypt to build this package.])
-+])
-
- dnl -------------------- ffmpeg is optional ----------------------------
- AC_ARG_WITH([ffmpeg], [AS_HELP_STRING([--with-ffmpeg], [build against ffmpeg libraries])], [], [with_ffmpeg=no])
-
-From 256fe93da3767364216420724c5947ed7257fe0a Mon Sep 17 00:00:00 2001
-From: Stefan Westerfeld <stefan@space.twc.de>
-Date: Sat, 28 Dec 2024 18:42:20 +0100
-Subject: [PATCH 2/5] BUILD: try using pkg-config first to find libgcrypt (see
- also #72).
-
-Signed-off-by: Stefan Westerfeld <stefan@space.twc.de>
----
- configure.ac | 21 ++++++++++++++++++---
- 1 file changed, 18 insertions(+), 3 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index ee874bf..14d9767 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -73,13 +73,28 @@ AC_DEFUN([AC_FFTW_CHECK],
- AC_DEFINE_UNQUOTED(SPECTMORPH_HAVE_FFTW, $SPECTMORPH_HAVE_FFTW, [Whether libfftw3 is available])
- ])
-
-+dnl libgcrypt
-+AC_DEFUN([AC_LIBGCRYPT_REQUIREMENTS],
-+[
-+ dnl newer libgcrypt versions provide a pkg-config file
-+ PKG_CHECK_MODULES(LIBGCRYPT, [libgcrypt], [have_libgcrypt=yes], [have_libgcrypt=no])
-+
-+ dnl older libgcrypt versions provide libgcrypt-config
-+ if test "x$have_libgcrypt" != "xyes"; then
-+ AM_PATH_LIBGCRYPT([], [have_libgcrypt=yes])
-+ fi
-+
-+ dnl fail if neither pkg-config file nor libgcrypt-config was found
-+ if test "x$have_libgcrypt" != "xyes"; then
-+ AC_MSG_ERROR([You need to install libgcrypt to build this package.])
-+ fi
-+])
-+
- AC_SNDFILE_REQUIREMENTS
- AC_LIBMPG123_REQUIREMENTS
- AC_ZITA_REQUIREMENTS
- AC_FFTW_CHECK
--AM_PATH_LIBGCRYPT([], [], [
-- AC_MSG_ERROR([You need to install libgcrypt to build this package.])
--])
-+AC_LIBGCRYPT_REQUIREMENTS
-
- dnl -------------------- ffmpeg is optional ----------------------------
- AC_ARG_WITH([ffmpeg], [AS_HELP_STRING([--with-ffmpeg], [build against ffmpeg libraries])], [], [with_ffmpeg=no])
-
-From 15e4e5643e22182a0bfa458205e763d3cb1f11d9 Mon Sep 17 00:00:00 2001
-From: Stefan Westerfeld <stefan@space.twc.de>
-Date: Sat, 28 Dec 2024 19:01:32 +0100
-Subject: [PATCH 3/5] BUILD: add libgcrypt.m4 check for self contained builds
-
-Signed-off-by: Stefan Westerfeld <stefan@space.twc.de>
----
- m4/libgcrypt.m4 | 167 ++++++++++++++++++++++++++++++++++++++++++++++++
- 1 file changed, 167 insertions(+)
- create mode 100644 m4/libgcrypt.m4
-
-diff --git a/m4/libgcrypt.m4 b/m4/libgcrypt.m4
-new file mode 100644
-index 0000000..cd4249e
---- /dev/null
-+++ b/m4/libgcrypt.m4
-@@ -0,0 +1,167 @@
-+# libgcrypt.m4 - Autoconf macros to detect libgcrypt
-+# Copyright (C) 2002, 2003, 2004, 2011, 2014, 2018, 2020 g10 Code GmbH
-+#
-+# This file is free software; as a special exception the author gives
-+# unlimited permission to copy and/or distribute it, with or without
-+# modifications, as long as this notice is preserved.
-+#
-+# This file is distributed in the hope that it will be useful, but
-+# WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
-+# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
-+#
-+# Last-changed: 2022-11-01
-+
-+
-+dnl AM_PATH_LIBGCRYPT([MINIMUM-VERSION,
-+dnl [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND ]]])
-+dnl Test for libgcrypt and define LIBGCRYPT_CFLAGS and LIBGCRYPT_LIBS.
-+dnl MINIMUM-VERSION is a string with the version number optionally prefixed
-+dnl with the API version to also check the API compatibility. Example:
-+dnl a MINIMUM-VERSION of 1:1.2.5 won't pass the test unless the installed
-+dnl version of libgcrypt is at least 1.2.5 *and* the API number is 1. Using
-+dnl this features allows to prevent build against newer versions of libgcrypt
-+dnl with a changed API.
-+dnl
-+dnl If a prefix option is not used, the config script is first
-+dnl searched in $SYSROOT/bin and then along $PATH. If the used
-+dnl config script does not match the host specification the script
-+dnl is added to the gpg_config_script_warn variable.
-+dnl
-+AC_DEFUN([AM_PATH_LIBGCRYPT],
-+[ AC_REQUIRE([AC_CANONICAL_HOST])
-+ AC_ARG_WITH(libgcrypt-prefix,
-+ AS_HELP_STRING([--with-libgcrypt-prefix=PFX],
-+ [prefix where LIBGCRYPT is installed (optional)]),
-+ libgcrypt_config_prefix="$withval", libgcrypt_config_prefix="")
-+ if test x"${LIBGCRYPT_CONFIG}" = x ; then
-+ if test x"${libgcrypt_config_prefix}" != x ; then
-+ LIBGCRYPT_CONFIG="${libgcrypt_config_prefix}/bin/libgcrypt-config"
-+ fi
-+ fi
-+
-+ use_gpgrt_config=""
-+ if test x"$GPGRT_CONFIG" != x -a "$GPGRT_CONFIG" != "no"; then
-+ if $GPGRT_CONFIG libgcrypt --exists; then
-+ LIBGCRYPT_CONFIG="$GPGRT_CONFIG libgcrypt"
-+ AC_MSG_NOTICE([Use gpgrt-config as libgcrypt-config])
-+ use_gpgrt_config=yes
-+ fi
-+ fi
-+ if test -z "$use_gpgrt_config"; then
-+ if test x"${LIBGCRYPT_CONFIG}" = x ; then
-+ case "${SYSROOT}" in
-+ /*)
-+ if test -x "${SYSROOT}/bin/libgcrypt-config" ; then
-+ LIBGCRYPT_CONFIG="${SYSROOT}/bin/libgcrypt-config"
-+ fi
-+ ;;
-+ '')
-+ ;;
-+ *)
-+ AC_MSG_WARN([Ignoring \$SYSROOT as it is not an absolute path.])
-+ ;;
-+ esac
-+ fi
-+ AC_PATH_PROG(LIBGCRYPT_CONFIG, libgcrypt-config, no)
-+ fi
-+
-+ tmp=ifelse([$1], ,1:1.2.0,$1)
-+ if echo "$tmp" | grep ':' >/dev/null 2>/dev/null ; then
-+ req_libgcrypt_api=`echo "$tmp" | sed 's/\(.*\):\(.*\)/\1/'`
-+ min_libgcrypt_version=`echo "$tmp" | sed 's/\(.*\):\(.*\)/\2/'`
-+ else
-+ req_libgcrypt_api=0
-+ min_libgcrypt_version="$tmp"
-+ fi
-+
-+ AC_MSG_CHECKING(for LIBGCRYPT - version >= $min_libgcrypt_version)
-+ ok=no
-+ if test "$LIBGCRYPT_CONFIG" != "no" ; then
-+ req_major=`echo $min_libgcrypt_version | \
-+ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\1/'`
-+ req_minor=`echo $min_libgcrypt_version | \
-+ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\2/'`
-+ req_micro=`echo $min_libgcrypt_version | \
-+ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\3/'`
-+ if test -z "$use_gpgrt_config"; then
-+ libgcrypt_config_version=`$LIBGCRYPT_CONFIG --version`
-+ else
-+ libgcrypt_config_version=`$LIBGCRYPT_CONFIG --modversion`
-+ fi
-+ major=`echo $libgcrypt_config_version | \
-+ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\1/'`
-+ minor=`echo $libgcrypt_config_version | \
-+ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\2/'`
-+ micro=`echo $libgcrypt_config_version | \
-+ sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\3/'`
-+ if test "$major" -gt "$req_major"; then
-+ ok=yes
-+ else
-+ if test "$major" -eq "$req_major"; then
-+ if test "$minor" -gt "$req_minor"; then
-+ ok=yes
-+ else
-+ if test "$minor" -eq "$req_minor"; then
-+ if test "$micro" -ge "$req_micro"; then
-+ ok=yes
-+ fi
-+ fi
-+ fi
-+ fi
-+ fi
-+ fi
-+ if test $ok = yes; then
-+ AC_MSG_RESULT([yes ($libgcrypt_config_version)])
-+ else
-+ AC_MSG_RESULT(no)
-+ fi
-+ if test $ok = yes; then
-+ # If we have a recent libgcrypt, we should also check that the
-+ # API is compatible
-+ if test "$req_libgcrypt_api" -gt 0 ; then
-+ if test -z "$use_gpgrt_config"; then
-+ tmp=`$LIBGCRYPT_CONFIG --api-version 2>/dev/null || echo 0`
-+ else
-+ tmp=`$LIBGCRYPT_CONFIG --variable=api_version 2>/dev/null || echo 0`
-+ fi
-+ if test "$tmp" -gt 0 ; then
-+ AC_MSG_CHECKING([LIBGCRYPT API version])
-+ if test "$req_libgcrypt_api" -eq "$tmp" ; then
-+ AC_MSG_RESULT([okay])
-+ else
-+ ok=no
-+ AC_MSG_RESULT([does not match. want=$req_libgcrypt_api got=$tmp])
-+ fi
-+ fi
-+ fi
-+ fi
-+ if test $ok = yes; then
-+ LIBGCRYPT_CFLAGS=`$LIBGCRYPT_CONFIG --cflags`
-+ LIBGCRYPT_LIBS=`$LIBGCRYPT_CONFIG --libs`
-+ ifelse([$2], , :, [$2])
-+ if test -z "$use_gpgrt_config"; then
-+ libgcrypt_config_host=`$LIBGCRYPT_CONFIG --host 2>/dev/null || echo none`
-+ else
-+ libgcrypt_config_host=`$LIBGCRYPT_CONFIG --variable=host 2>/dev/null || echo none`
-+ fi
-+ if test x"$libgcrypt_config_host" != xnone ; then
-+ if test x"$libgcrypt_config_host" != x"$host" ; then
-+ AC_MSG_WARN([[
-+***
-+*** The config script "$LIBGCRYPT_CONFIG" was
-+*** built for $libgcrypt_config_host and thus may not match the
-+*** used host $host.
-+*** You may want to use the configure option --with-libgcrypt-prefix
-+*** to specify a matching config script or use \$SYSROOT.
-+***]])
-+ gpg_config_script_warn="$gpg_config_script_warn libgcrypt"
-+ fi
-+ fi
-+ else
-+ LIBGCRYPT_CFLAGS=""
-+ LIBGCRYPT_LIBS=""
-+ ifelse([$3], , :, [$3])
-+ fi
-+ AC_SUBST(LIBGCRYPT_CFLAGS)
-+ AC_SUBST(LIBGCRYPT_LIBS)
-+])
diff --git a/audiowmark-nostdin.patch b/audiowmark-nostdin.patch
deleted file mode 100644
index fdc4e6cda980..000000000000
--- a/audiowmark-nostdin.patch
+++ /dev/null
@@ -1,95 +0,0 @@
-From 4ddb97b05b41b7a6623cffce90c57304d796db3a Mon Sep 17 00:00:00 2001
-From: Stefan Westerfeld <stefan@space.twc.de>
-Date: Mon, 30 Dec 2024 16:30:25 +0100
-Subject: [PATCH] HLS: use ffmpeg with -nostdin argument to ignore stdin
-
-Signed-off-by: Stefan Westerfeld <stefan@space.twc.de>
----
- src/hls.cc | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/src/hls.cc b/src/hls.cc
-index d026119..9d1535d 100644
---- a/src/hls.cc
-+++ b/src/hls.cc
-@@ -192,7 +192,7 @@ ff_decode (const string& filename, WavData& out_wav_data)
- if (!tmp_file)
- return Error ("failed to create temp file");
-
-- Error err = run ({"ffmpeg", "-v", "error", "-y", "-f", "mpegts", "-i", filename, "-f", "wav", tmp_file_name});
-+ Error err = run ({"ffmpeg", "-v", "error", "-nostdin", "-y", "-f", "mpegts", "-i", filename, "-f", "wav", tmp_file_name});
- if (err)
- return err;
-
-@@ -294,7 +294,7 @@ bit_rate_from_m3u8 (const string& m3u8, const WavData& wav_data, int& bit_rate)
- if (!tmp_file)
- return Error ("failed to create temp file");
-
-- Error err = run ({"ffmpeg", "-v", "error", "-y", "-i", m3u8, "-c:a", "copy", "-f", "adts", tmp_file_name});
-+ Error err = run ({"ffmpeg", "-v", "error", "-nostdin", "-y", "-i", m3u8, "-c:a", "copy", "-f", "adts", tmp_file_name});
- if (err)
- return err;
-
-@@ -319,7 +319,7 @@ load_audio_master (const string& filename, WavData& audio_master_data)
- return Error ("failed to create temp file");
-
- /* extract wav */
-- Error err = run ({"ffmpeg", "-v", "error", "-y", "-i", filename, "-f", "wav", tmp_file_name});
-+ Error err = run ({"ffmpeg", "-v", "error", "-nostdin", "-y", "-i", filename, "-f", "wav", tmp_file_name});
- if (err)
- return err;
-
-From 99e0e42a0d1cb7f117f5d599c4ac20f37a570639 Mon Sep 17 00:00:00 2001
-From: Stefan Westerfeld <stefan@space.twc.de>
-Date: Mon, 30 Dec 2024 16:23:43 +0100
-Subject: [PATCH] Use ffmpeg -nostdin in test scripts (ignore stdin input).
-
-Signed-off-by: Stefan Westerfeld <stefan@space.twc.de>
----
- tests/hls-test.sh | 4 ++--
- tests/raw-format-test.sh | 4 ++--
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/tests/hls-test.sh b/tests/hls-test.sh
-index c22117d..1d93b72 100755
---- a/tests/hls-test.sh
-+++ b/tests/hls-test.sh
-@@ -13,7 +13,7 @@ mkdir -p $HLS_DIR
- audiowmark test-gen-noise $HLS_DIR/test-input.wav 200 44100
-
- # convert to hls
--ffmpeg $FFMPEG_Q -i $HLS_DIR/test-input.wav \
-+ffmpeg $FFMPEG_Q -nostdin -i $HLS_DIR/test-input.wav \
- -f hls \
- -c:a:0 aac -ab 192k \
- -master_pl_name replay.m3u8 \
-@@ -31,7 +31,7 @@ done
- cp $HLS_DIR/as0/out.m3u8 $HLS_DIR/as0m/out.m3u8
-
- # convert watermarked hls back to wav
--ffmpeg $FFMPEG_Q -y -i $HLS_DIR/as0m/out.m3u8 $HLS_DIR/test-output.wav
-+ffmpeg $FFMPEG_Q -nostdin -y -i $HLS_DIR/as0m/out.m3u8 $HLS_DIR/test-output.wav
-
- # detect watermark from wav
- audiowmark_cmp --expect-matches 5 $HLS_DIR/test-output.wav $TEST_MSG
-diff --git a/tests/raw-format-test.sh b/tests/raw-format-test.sh
-index e0050b8..15a31de 100755
---- a/tests/raw-format-test.sh
-+++ b/tests/raw-format-test.sh
-@@ -16,14 +16,14 @@ raw_test()
-
- audiowmark test-gen-noise --bits 32 $IN_WAV 200 44100
-
-- ffmpeg -v quiet -i $IN_WAV -f $FFMPEG_FMT -c:a pcm_$FFMPEG_FMT - | \
-+ ffmpeg -v quiet -nostdin -i $IN_WAV -f $FFMPEG_FMT -c:a pcm_$FFMPEG_FMT - | \
- audiowmark_add - - $TEST_MSG --format raw --raw-rate 44100 $AWM_FMT --test-no-limiter | \
- ffmpeg -v quiet -f $FFMPEG_FMT -ar 44100 -ac 2 -i - $OUT_WAV
-
- audiowmark_cmp --expect-matches 5 $OUT_WAV $TEST_MSG
- check_snr $IN_WAV $OUT_WAV $SNR
-
-- ffmpeg -v quiet -i $IN_WAV -f $FFMPEG_FMT -c:a pcm_$FFMPEG_FMT - | \
-+ ffmpeg -v quiet -nostdin -i $IN_WAV -f $FFMPEG_FMT -c:a pcm_$FFMPEG_FMT - | \
- audiowmark_add - $OUT2_WAV $TEST_MSG --input-format raw --raw-rate 44100 $AWM_FMT --test-no-limiter
-
- check_length $IN_WAV $OUT_WAV
diff --git a/audiowmark-tests.patch b/audiowmark-tests.patch
deleted file mode 100644
index 5349c9600d34..000000000000
--- a/audiowmark-tests.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-From 2b29f3fd90c7ce0c51df1925d47682156f47daf5 Mon Sep 17 00:00:00 2001
-From: Stefan Westerfeld <stefan@space.twc.de>
-Date: Sun, 29 Dec 2024 12:53:52 +0100
-Subject: [PATCH 4/5] Abort on error for test scripts (test-common.sh set -eo
- pipefail).
-
-Signed-off-by: Stefan Westerfeld <stefan@space.twc.de>
----
- tests/hls-test.sh | 2 --
- tests/raw-format-test.sh | 2 --
- tests/test-common.sh.in | 4 ++++
- 3 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/tests/hls-test.sh b/tests/hls-test.sh
-index 1c723b2..c22117d 100755
---- a/tests/hls-test.sh
-+++ b/tests/hls-test.sh
-@@ -6,8 +6,6 @@ if [ "x$Q" == "x1" ] && [ -z "$V" ]; then
- FFMPEG_Q="-v quiet"
- fi
-
--set -e
--
- HLS_DIR=hls-test-dir.$$
- mkdir -p $HLS_DIR
-
-diff --git a/tests/raw-format-test.sh b/tests/raw-format-test.sh
-index 12b7a64..e0050b8 100755
---- a/tests/raw-format-test.sh
-+++ b/tests/raw-format-test.sh
-@@ -2,8 +2,6 @@
-
- source test-common.sh
-
--set -e
--
- IN_WAV=test-raw-format.wav
- OUT_WAV=test-raw-format-out.wav
- OUT2_WAV=test-raw-format-out2.wav
-diff --git a/tests/test-common.sh.in b/tests/test-common.sh.in
-index 096cba0..ce5ebcd 100644
---- a/tests/test-common.sh.in
-+++ b/tests/test-common.sh.in
-@@ -4,6 +4,10 @@ AUDIOWMARK=@top_builddir@/src/audiowmark
- TEST_MSG=f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0f0
- TOP_BUILDDIR=@top_builddir@
-
-+## abort on error
-+
-+set -eo pipefail
-+
- # common shell functions
-
- die()
-
-From c9199aec6e772b2a2669d329081ca8806e208897 Mon Sep 17 00:00:00 2001
-From: Stefan Westerfeld <stefan@space.twc.de>
-Date: Sun, 29 Dec 2024 13:08:40 +0100
-Subject: [PATCH 5/5] Fix testrawconverter vector out-of-bounds access (see
- #72).
-
-Signed-off-by: Stefan Westerfeld <stefan@space.twc.de>
----
- src/testrawconverter.cc | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/testrawconverter.cc b/src/testrawconverter.cc
-index c029dd0..0f6528c 100644
---- a/src/testrawconverter.cc
-+++ b/src/testrawconverter.cc
-@@ -83,8 +83,8 @@ main (int argc, char **argv)
- uint64_t K = 33452759; // prime
- vector<float> in_samples (K), out_samples (K);
- vector<unsigned char> bytes (K * 4);
-- for (uint64_t k = 0; k <= K; k++)
-- in_samples[k] = (-1 + double (2 * k) / K);
-+ for (uint64_t k = 0; k < K; k++)
-+ in_samples[k] = (-1 + double (2 * k) / (K - 1));
-
- test_int16 ("int16", in_samples, Encoding::SIGNED);
- test_int16 ("uint16", in_samples, Encoding::UNSIGNED);