summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDave Reisner2018-12-02 15:53:38 -0500
committerDave Reisner2018-12-02 15:54:24 -0500
commitb4922ef9b986654a536d75d5001640cf167f7d32 (patch)
tree5e1a6f69e1be2f48066268982fc9edbd34741dac
parent29b687e995684930b61d5c520510a52ca4d9c5fb (diff)
downloadaur-b4922ef9b986654a536d75d5001640cf167f7d32.tar.gz
Allow building from a "dirty" tree
This allows the meson subproject/wrap cache to be useful.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c56a407a8744..6df7be884ec7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = auracle-git
pkgdesc = A flexible client for the AUR
- pkgver = r190.1f245b6
+ pkgver = r192.ad01c04
pkgrel = 1
url = https://github.com/falconindy/auracle.git
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index f199af59a6db..39d2636886e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=auracle-git
_pkgname=auracle
-pkgver=r190.1f245b6
+pkgver=r192.ad01c04
pkgrel=1
pkgdesc='A flexible client for the AUR'
arch=('x86_64' 'i686')
@@ -23,7 +23,12 @@ pkgver() {
build () {
cd "$_pkgname"
- arch-meson build --default-library=static
+ local action=setup
+ if [[ -d build ]]; then
+ action=configure
+ fi
+
+ meson "$action" build --buildtype=plain --default-library=static
ninja -C build
}